Showing results for 
Search instead for 
Did you mean: 

Fido App not working

I'm a participant level 1
I'm a participant level 1

For the past 1 week or more, my Fido app hasn't opened. Each time I tried, it  keeps showing "Sorry, we've hit a snag. Please check back later"

Does anyone know how to fix this ? I tried Fido live chat but no agent responded.



I'm a participant level 2
I'm a participant level 2

Tried a couple of different things, This finally worked for me:
Go to the app store, uninstall if possible. It may not do that, but might downgrade the app initially.

If it gives the option to "update" choose that.

App should start working again.

I'm a participant level 2
I'm a participant level 2

1. There is no option to UNINSTALL the "My Account" app. Only to DISABLE the app.

2. Restarting the phone doesn't work.

3. App seems to want to open in Chrome. Why? It worked fine several months ago.

4. Clearing the cache on the Chrome browser doesn't fix the app at all.

* You aren't the person to complain to, but I am very disappointed, since I regularly used the app until several months ago. I gave up trying to access it. Tried again, but no luck. 

** Since you're a Senior MVP, you might have some clout. Why not use it to suggest to Rogers that they investigate why the app doesn't work? 

Senior MVP Senior MVP
Senior MVP

Hello Sthone,


  Welcome to the community!


  Sorry to hear you're having issues with opening the app. I understand these suggestions might seem simplistic, however, have you tried to uninstall and reinstall the app? In addition, have you tried closing all open apps or restarting your phone?


Hope this helps 😀