Showing results for 
Search instead for 
Did you mean: 

Cannot login to Fido app - First time user

I'm a participant level 1
I'm a participant level 1

Just switched my phone to Fido and I cannot login to the app! I can login to my account in Safari no problem but every time I login to my account in the iOS app I get a "We've hit a snag, try again later!" error. I've tried:

1) Uninstalling and reinstalling the app

2) Resetting password (2X)

3) Logging in on LTE instead of WIFI

4) Logging in on WIFI with airplane mode 

5) Installing Google Chrome and using this as the browser over Safari


... and nothing works. Only progress was turning off MFA through my acocunt in the browser and trying to login but the app made me turn MFA on to continue and then gave me the same error. I ended up having my account locked for 30 min for too many login attempts ... Super disappointed since I can't login to use any of the features I was shown when I switched plans Sad Does anyone know how to fix this??? I'm using an iPhone XR on iOS 16


Good morning @nicoleps , sounds like you've done the trouble shooting on your end. I'm not familiar with iPhone settings myself but if you call into Fido technical support,  I'm pretty sure they will get you up and running in no time. You can reach out by calling *611 from your device, sending a dm on Twitter or Facebook, see Here for the various ways to reach out. Hope it's resolved soon