Wifi Calling

Wifi Calling

Wifi Calling

SOLVED
I'm a Participant Level 3

Wifi Calling

Have a new lg g5 that i just purchased from costco, specifically for the wifi calling. Seems, sometimes it is enabled, and sometimes not? Bought this phone specifically for this feature, as we have a weak cellular connection where we live. When it works, it seems good, but most times it is not connected.

Any help would be appreciated.

 

Thanks

linz

 

Accepted Solution

Re: Wifi Calling

Solved by I'm a Participant Level 3 tommy44

Yes I did get it figured out. I found that if i put it into airplane mode, then just turn on wifi, it connects after about 5-10 seconds. If i leave it without putting in airplane mode, it doesnt connect as long as there is 1 bar cell connection, and that is sometimes iffy.

 

Thanks all for the help

View solution in context
26 REPLIES 26
I'm a Participant Level 1

 Wifi calling not working on my unlocked OnePlus 5t mobile.

Please help.

Hello AlwaysHappy,

 

  Welcome to the community!

 

  While Fido has recently allowed some grey-market non-Fido phones (Samsung Galaxy devices newer than S8, some LG devices) access to certain features (ie Wifi-calling and voLTE), Fido does not support those features on devices which are not offered by Fido. The reason is that devices from other manufacturers (ie OnePlus, Asus, Xiaomi, etc) have not been tested on the networks. You can view the list of supported devices here. Unfortunately, your phone is not a supported device.

 

Not what you wanted to hear, but hope this helps 😀

 

Cheers

 


I'm a Participant Level 3

Hello I have a unlocked Samsung galaxy s8+ and I had gotten wifi calling to work. But due to a issue with my phone I had to do a factory reset. When I set up my phone again and tried setting up wifi calling again, it said that the phone is not eligible for wifi calling. What is the reason for that. I had contacted fido through facebook messenger, but they couldn't do anything.  Please help 

 

thank you, 

Hakim

I'm a Participant Level 1

Click here
my phone does not work wifi calling 

Hello @HETAL1,

 

Welcome to the community! 

 

You can view our instructions on how to activate Wi-Fi calling here.

 

Hope this helps!

 

-FidoAnthonyZ

 

 



Hello HakimDewani,

 

  Welcome to the community!

 

  You note your S8+ is unlocked. I assume that means you did not purchase it from Fido. Unfortuntately, as far as I am aware, voLTE and Wifi-calling are not available on android devices not purchased from Fido (see here).

 

Hope this helps Smiley Happy

 

Cheers

 


I'm a Contributor Level 1

This is unfair..Fido store did not have the phone I wanted. So..now my option is to find a carrier who has wifi calling with existing phone?

Moderator (inactive)

Hey @murmur,

 

We don't want to see you leave Sad

 

What model were you looking for?  We can have a look at your options, just let us know and we'll PM you!

 

 



I'm a Contributor Level 1

I was looking for samsung Note 9 and bought one at Best Buy, as recommended by the Fido store I normally deal with. I didn't realize I couldn't activate wifi calling if I bought my phone elsewhere. I do have a better connection with the new phone if I am close to the wifi, but not everywhere in the condo.

Hey @murmur


You had a chance to try to add Wi-FI calling following the instructions here

 

There's that section that says ( How do I enable Wi-Fi Calling on my Samsung device?)

 

Let me know how it goes on your end.

 



I'm a Contributor Level 1

I did try the instructions and because I bought an unocked phone, it is ineligible according to the link about which devices can use it.

@murmur

 

I was in the understanding that this phone you bought from Best Buy was a Fido device.


When it's not a Fido phone, some features might not work.

 

We do appreciate your feedback concerning this and I will make sure to share your situation to the right team.

 



I'm a Contributor Level 1

Because of the problems I had in not receiving texts and voice cutting out / calls going straight to voicemail, I did not want to be locked into a Fido phone. I wanted to make sure it worked first. The agent in the Fido store agreed with me.

Thanks for your feedback @murmur

 

We appreciate you taking the time to provide us with these updates. To clarify however, you can purchase a device from Fido and benefit from a 15 days satisfation guarantee to make sure the phone suits your needs.

 

You can check out more details on this here.

 

 



I'm a Participant Level 3

But I had it working on my phone before I had to reset

 

Former Moderator

Hi @tommy44!

 

Welcome to the Community!

The Wi-Fi calling feature will kick-in only when it detects a weak connection to the Fido's network. If the mobile connection is stable, the Wi-Fi calling will not be triggered. 

Hope this clarifies why it's not active sometimes. 

 

 

 



I'm a Participant Level 3

Thanks for the quick response. Under "settings" "networks" "call" there is an option for "wifi preferred" which i have checked. The best reception i get is either 1 or no bars, yet the little phone/wifi icon in the top left doesnt show up. I have found if I put it in airplane mode, then turn on just wifi, the icon pops up after about 10 seconds. Do you think it is a network or phone issue? I am only on the 500/500 plan, so i like to save as much phone time as i can by using the wifi calling.

 

Thanks for your help

Hey @tommy44,

 

Thanks for the detailed info! Smiley

 

First, I'd like to bring a small clarification to how WiFi calling works: the cost of Calls, Texts and MMS are taken from the airtime and messaging buckets in your plan and the internet bucket of your Wi-Fi Network. Therefore, when using WiFi calling, minutes will be deducted out of your plan.

 

You can learn more here.

 

Did you try restarting the phone or doing a factory reset?

 

 



Hey @tommy44!


We never heard back, did you end up getting your wi-fi calling figured out?

 

Let us know! The info can definitely help others here on the Community Smiley

 



I'm a Participant Level 3

Yes I did get it figured out. I found that if i put it into airplane mode, then just turn on wifi, it connects after about 5-10 seconds. If i leave it without putting in airplane mode, it doesnt connect as long as there is 1 bar cell connection, and that is sometimes iffy.

 

Thanks all for the help