Missing Fido Xtra from my account app

Missing Fido Xtra from my account app

Missing Fido Xtra from my account app

SOLVED
inaam
I'm a Contributor Level 1

Missing Fido Xtra from my account app

fido xtra perks disappeared from my number on the my account app I have three numbers associated with the account just one of the number do not show Fido Xtra perks, it's very odd please someone update on the issue 

Accepted Solution

Re: Missing Fido Xtra from my account app

Solved by Moderator

Hey @nick67, @KAPABLE-K, @Cawtau, @inaam! I hope you're all doing well. Smiley

 

Looks like this is now all fixed. Can you all restart your MyAccount apps let me know if it works properly now? It should be good to go!

View solution in context
23 REPLIES 23
amisam
I'm a Participant Level 1

Still broken on both my phone and my partners iPhones. Have tried reinstalling and it makes no difference. 

jlackan
I'm a Participant Level 1

Hi, my Fido Xtra is also missing from my My Fido app.

 

I am a post paid customer and have cleared app cache, restarted both app and phone and still not present.

KAPABLE-K
MVP

@FidoSolutions it seems the problem is not fixed.

 

I just started experiencing all the problems reported by the other users.

 

I cleared the app cache even uninstall.



nick67
I'm Qualified Level 3

I checked my Fido app and can confirm the "5 hours of extra data" and "Fido XTRA" banners have disappeared again as well as the Phone and Plan details tabs now showing errors. I assume it's just Fido updating parts of the app in the background.

nick67
I'm Qualified Level 3

@FidoNick, thank you for confirming that this is a mobile app glitch and Fido is actively working on a fix. I am also experiencing this same issue with the Fido Xtra banner not appearing after my last billing cycle as well as the Phone and Plan tabs are not working.

Hey @nick67, @KAPABLE-K, @Cawtau, @inaam! I hope you're all doing well. Smiley

 

Looks like this is now all fixed. Can you all restart your MyAccount apps let me know if it works properly now? It should be good to go!



Jr_Canuck
I'm a Participant Level 2

Not fixed on my iPhone. Started immediately after the July 19th iOS app update. One of my three accounts is missing the XTRA Perks. If "the" account gets a Perks email, then I can access the XTRA Perks via that email, but not 8n the "normal" way. 

inaam
I'm a Contributor Level 1

Hello @Jr_Canuck 

 

It seems Fido is having ongoing glitches with their APP, it's all good for all of the three lines for me so far. It had glitches twice last week. I would suggest call Fido tech and report it. I hope that helps 

Jr_Canuck
I'm a Participant Level 2

Thx Inaam. But still not resolved. I have called Fido twice now in the last week, still unresolved. They expressed no knowledge of this happening to others and were confused as to why this is happening to my one account. 
nope this happened immediately after the iOS July 19 app update. I just finished reloading the app and the issue still persists.

Along with the Fido extra perks missing, I get no information on my plan details, unlike the other two accounts I have with Fido.

inaam
I'm a Contributor Level 1

Hello @Jr_Canuck 

 

I totally understand your frustration I was in same boat missing Fido Xtra Banner, plan details for quite a few days than I started communicating on forum try to reach out to one of the Fido Moderators on the forum or email screenshot of your app to ticketing.support@rci.rogers.com

JeanAshley
I'm a Participant Level 2

It is not fixed. I reinstalled the app and it did nothing

 

Bankee
I'm a Participant Level 1

Hello, 

This problem is not fixed as I am not able to access anything on my app besides my data usage. I have done everything that was posted however that the problem still persists. 

inaam
I'm a Contributor Level 1

Hello

 

It's all fixed Thanks everyone for contributions special Thanks to Phillipe@Fido for confirmation the app is fixed

Hello again,

 

  I just checked the app again and everything seems to be working properly now. I guess it might have taken a bit of time for the fixes to get pushed to everyone? Hope the fix helps others as well!

 

Cheers

 


Hello Philippe,

 

  Unfortunately, the issue doesn't appear to be fixed. Still no Xtra tab nor access to information on the Phone and Plan tabs. I cleared cache, as well as un-installed/re-installed again.

 

Cheers

 


nick67
I'm Qualified Level 3

I just closed the My Account app and loaded it back up again, the issue still persists. No changes -- Fido Xtra banner still missing and error message with Phone+Plan tabs.

FidoNick
Former Moderator

Hey everyone! @inaam, @Cawtau, @KAPABLE-K Smiley

 

I just wanted to let you know that we're aware of the missing Fido XTRA banner as well as the missing phone/plan details and that our teams are looking into it.

 

I hope that helps! 

 

 



KAPABLE-K
MVP

I currently have 5 lines and I can access the FidoXtra for all but I did notice for 2 of my lines it does not show the device balance and the upgrade date under the phone tab.



Cawtau
Senior MVP

Hello Inaam,

 

  Welcome to the community!

 

  I just wanted to add to this thread as I have also noticed that the Fido Xtra section is no longer showing in My Account app either.

 

Screenshot_20210722-005423_My Account -edit.jpg

 

  I understand that I am currently not logged-in. However, the Fido Xtra used to show even when not logged-in. That said, I get the same result when actually logged-in.

 

  I have also cleared the app's cache and un-installed/re-installed with no change. Fido Xtra is not available via the More tab either.

 

  In addition, I am not able to access the information in the Phone or Plan tabs. I get this error:

 

Screenshot_20210722-004022_My Account -edit.jpg

 

  I have been getting those errors for a few days now. Again, no difference whether I am logged-in or not. In addition, I get the same result whether using data or Wifi. I hope @FidoSolutions might direct these issues to the appropriate team. Thanks 😀

 

Cheers

 


KAPABLE-K
MVP

Hello @inaam,

 

The FidoXtra is only for post-paid accounts and not pre-paid accounts, if that number is not a pre-paid number try clearing the app cache or uninstall the app and reinstall it and see if it helps.