UMIDIGI A7 PRO...CANT'T send or receive MMS on FIDO

UMIDIGI A7 PRO...CANT'T send or receive MMS on FIDO

UMIDIGI A7 PRO...CANT'T send or receive MMS on FIDO

I'm a Contributor Level 1

UMIDIGI A7 PRO...CANT'T send or receive MMS on FIDO

I tried several UMIDIGI phones and all came back with the same problem. I cant send or recieve Pics on MMS.

 

I have a basic talk and text plan with FIDO.

 

UMIDIGI did do an upgrade on Aug 1 2020 but still nothing. The APN cannot be altered. The Phone is on Android 10.

 

HELP!!!

 

PS. I did use a MOTO G8 Play (International Version from Amazon) No problem. Put in my sim card no problem.

13 REPLIES 13
I'm a Participant Level 1

I had this issue as well. I have searched and tried everything. I went I to a Fido store as well as the hour or so on the phone with Fido tech support.

 

Finally I email Umidigi tech support through Amazon and they told me there is an update that fixes this! Go to settings, about phone and click on wireless update.  This worked for me.

 

Let's hope that this fixes the MMS issue for all of us!  Good luck.

Hey @ronp

 

Welcome to the Community. Very_Happy

 

Thank you so much for sharing this! Hopefully it helps some other members who are facing a similar situation.

 

Cheers. Smiley



Senior MVP

Hello Al060487,

 

  Welcome to the community!

 

  Firstly, have you verified that the phone has all of the compatible bands/frequencies for the networks? For some reason, I haven't been able to access the Umidigi websites. You can verify the compatible bands/frequencies here. You should note that since the device is not one Fido offers, it's likely that certain features like voLTE and Wifi-calling won't work.

 

  You note that the APN cannot be altered. Which APN is the device using at the moment? If you cannot edit an APN, are you able to change it? While phone is LTE-capable, using ltemobile.apn would seem appropriate. You can verify those settings here. However, have you tried using fido-core-appl1.apn to see if you can send MMS? That APN might be more appropriate for your situation.

 

  Your issue seems to stem from a relatively new security feature introduced in Oreo. Google has removed the ability to edit APNs with that update. Now phones rely on their internal database of APN settings. Unfortunately, that database is not always accurate. Other community members have similars issue with their unlocked phones (see here and here).

 

  If you are able to switch the APN to fido-core-appl1.apn, that would be the simplest solution. For some reason, that APN seems to have the proper MMS settings in the database. While using that APN won't allow your phone to connect to the LTE networks, you service shouldn't be affected since you have a Talk and Text only plan. With the exception of voLTE and Wifi-calling, voice and messaging would transmit via the 2G and '3G' networks (note: Rogers intends to decommission the GSM (2G) network Dec 2020; see here).

 

  In addition, you might consider disabling LTE on your device (ie setting your network to WCDMA/GSM or 3G/2G only). I'm not sure if disabling LTE would automatically switch the phone's APN to fido-core-appl1.apn.

 

  If you are unable to add an APN or switch to a different one, your options are more limited (see here). You might consider contacting the manufacturer to see if they can edit the phone's apns-conf.xml file with the correct settings.

 

  Hope this helps 😀

 

Cheers

 

 


Hello again,

 

  I forgot to include earlier... Have you verified that data is enabled on the phone? While you don't need a data plan to send/receive MMS, the data setting does need to be enabled.

 

Hope this helps 😀

 

Cheers

 


I'm a Contributor Level 1

Hi

 

Thanks for you response.

 

Yes I do make sure that the Mobile Data is on even though I only have the basic Talk and Text Plan.

 

The Only APN I can chose for FIDO is 1) FIDO INTERNET itemobile.apn 2) FIDO TETHERING isp.fido.apn 3) InTERNET MMS 2 internet.fido.ca and 4) MTS sp.mts

 

There are other APN which I cannot chose but are listed.

 

FIDO MMS mms.fido.ca

FIDO MMS netsvcs

FIDO MMS2 LTEMOBILE.APN ...this one seems to have the proper settings for MMS but I cannot chose it.

SOS sos

 

I cannot add or change APN.

 

The UMIDIGI phone is connected to the Mibile Data as 3G. I do make sure it is connected eventhough I do not have data. FIDO told me that I have to have the data connected on the phone to allow MMS to work.

 

I am in contact with UMIDIGI. They even send me a phone to test to try to resolve this problem.

 

They are taking it seriously.

 

Thanks

 

 

 

I'm a Contributor Level 1

Hi

 

AS to the bands which this phone operates Amazon clearly states the bands.

 

Go to Amazon for the UMIDIGI A7 PRO 4/128.

 

Hope that will help all the gear heads out there who are trying to help.

 

Thanks

I'm a Contributor Level 1

Here is a screen shot of teh APN on UMIDIGI for FIDOScreenshot_20200807-162903.png

Hello again,

 

  Thank you for the additional information. Glad to hear UMIDIGI is trying to help.

 

  Have you tried to use the Internet MMS 2 APN? While that APN is not the official one for Fido, some APN websites (see here and here) do list that one for Fido (possibly where UMIDIGI obtained their list of APNs for their internal database). Although those listings for that APN do not appear to contain the MMS proxy information, it might be worth a try to see if you can send/receive MMS using that APN.

 

  Similar to the Fido-core-app1.apn, using that APN might not allow connection to the LTE networks. However, as mentioned above, your device wouldn't need to access the LTE networks for your services.

 

  Have you tried to access the APN settings with the SIM removed? It's possible you might be able to add an APN if there is no SIM present. If you are, you could add an APN with the proper MMS settings.

 

Hope this helps 😀

 

Cheers

 


I'm a Contributor Level 1

ME Again...

 

Yes I did try the MMS 2 APN with many variations by using the 3G network not the 4G network as was recommended.

 

NOTHING>>>>>

 

Next step try to add an APN with SIM card out..I'll let you know.

 

The mystery continues......

I'm a Contributor Level 1

Follow up as to adding an APN when SIM card is out of the Cell Phone.

 

YOu cant add a apn as the mobile netwrok is greyed out when the SIM card is out of phone.

 

 

if the mobile network is greyed out, you cant access the APN...

 

To be continued...waiting for UMIDIGI to get back to me..I'm their  tester on FIDO. LOL

Hello again,

 

  Thank you for the additional information. I also replied to your other thread here.

 

  Are you able to view the actual settings for those APNs? I'm pretty certain that your issue likely stems from those APNs not containing the MMS settings. An APN which appears to be correct doesn't appear to be selectable.

 

Hopefully UMIDIGI will be able to provide an updated APN database for their devices.

 

Sorry we couldn't be of more assistance, but hope this helps 😀

 

Cheers

 


I'm a Participant Level 1

Has this been resolved? I need a solution been stuck with the same issue here. Thanks 

Hey @Rogerzreik


Welcome to the Community. Smiley 

 

Have you had a chance to try updating the MMS APN settings for your phone as described earlier in this thread?