Mobile Data problem

Mobile Data problem

Mobile Data problem

I'm a Contributor Level 1

Mobile Data problem

Hi, I have a BYOD plan with mobile data.


The phone I was using is a Galaxy S7 Edge, which I dropped and broke the screen. I had no issue what so ever with the phone regarding network connection.


I bought a used phone

LG V30 from a thrusted source. Switch the Sim card to the new phone...

Call and text msg are working find, wifi as well, however I can't get the Mobile data to work. 

I look on the web, and tried several things, reset, factory reset, different APN setting, switching ON/OFF function... Still nothing.


Anyone has an idea of how to fix this issue?


Thank you


Senior MVP

Hello Marc2222,


  Welcome to the community!


  I understand you purchased the phone from a trusted source, however, what version is the phone? Is it the Canadian version, LGH933? If it isn't the Canadian version, have you verified it has the requisite compatible bands/frequencies? You can verify those bands/frequencies here.


  I also understand you have tried different APN settings. Since the phone is LTE-capable, it should be using ltemobile.apn. You can verify the proper settings here.


  If your phone isn't the Canadian version of the V30, you might consider trying to enable roaming data. Sometimes phones purchased from elsewhere think they are roaming even though they might be using a local SIM.


Hope this helps Smiley



I'm a Contributor Level 1



Thank you for replying,


I checked the phone model and it is a LG-H933.



Here is a snapshot of APN default setting.(up)

An other snapshot of the APN I input(down)




Also tried to select roaming data ON\OFF... No joy.


I dont think the SIM is bad because when I swap it to my old phone it work fine.


Im kind of out of idea....


Your help is very much appreciated.


Hey @Marc2222


Thanks for the update, let's take a closer look at your account together. I'll be sending you a PM shortly.


Talk to you soon Smiley

I'm a Contributor Level 1

I read several other discusion about the mobile data not working when an none Fido unlocked devise is brouht to a BYOD plan.


Did anybody had this kind of issue and fixed it?


The previous owner had the phone on Rogers network with no issue. 

With the SIM car in, call and Text work but not mobile data....


Thanks for any feedback!

Hello again,


@Marc2222 wrote:

I read several other discusion about the mobile data not working when an none Fido unlocked devise is brouht to a BYOD plan.....

  Are you referring specifically to the LG V30? Both my sister and brother-in-law are able to use mobile data with their non-Fido phones and BYOP plans. Admittedly, neither of them are using the LG V30. Is it possible those other discussions you have read are related to band/frequency compatibility?


  That said, it is true that Fido does not guarantee that certain services (ie voLTE and Wifi-calling) will work with non-Fido devices. However, accessing mobile data usually does work with compatible devices.


  Thank you for the additional information. Could you also verify the APN type? It should be Internet+MMS or default,mms. In addition, could you also verify the APN protocol. It should be IPv4/IPv6 or IPv4.


Are you able to test a different SIM in your phone or your SIM in a different phone? Have you tried to disable LTE to see if the phone can access data using the '3G' networks?


Hope this helps Smiley



I'm a Contributor Level 1

I did try my current SIM in a Blackberry and it did work.

Tomorrow I will try a different SIM card from a friend.


I will let you know!

Did you verify the APNs types and protocol as suggested by @Cawtau as well?


Keep us updated.



I'm a Contributor Level 1

These are the APN by default and the second one is the one I input.Screenshot_2018-12-17-09-11-06.png






@Marc2222 what do you have in the "APN type" field in your APN settings. 


This might sound silly but double check that your Mobile data settings is on, you can also try turning on data roaming and see if it works.


I notice in all your screenshot you are connected to a WiFi network, turn off your WiFi and see if you can connect to the LTE network it should display by the signal bar.


Also can you send yourself a picture message and see if the image automatically downloads.


If all else fails power off the phone take out the SIM card then reinsert it and power up the phone and see if it works.




I'm a Contributor Level 1



Here is the APN type;Screenshot_2018-12-17-12-48-17.png



I did try some of you tips, with no positive results


I will once again power off and remove the SIM. But I can see that the SIM is ready when I check some setting!


This evening I will try a SIM card from an other carrrier to see if it work.


Thanks for your help

I'm a Contributor Level 1

I found this in Network infoScreenshot_2018-12-17-13-34-12.png



In the Select Network Operator.

I can see all different Carrier , and can register to Fido LTE.... However still no data.

@Marc2222 open your phone app and type *#*#4636#*#*  on the next screen go to Phone information in the Set Preferred Network Type select LTE/UMTS auto.

I'm a Contributor Level 1

When in this setting menu. Not connected to wifi.

Did the Ping test... Both failed





I'm a Contributor Level 1

Anyone could give me the correct full APN setting. I will try to set it once more. I checked on the web, but there are many different options.



Hey @Marc2222,


You can find the correct APN Settings on our Community here.


Quick question, did you make sure there are no other APNs set up along with the Fido one? If you have another APN on there, you'd need to delete it first.