Showing results for 
Search instead for 
Did you mean: 

Data not working

I'm a participant level 1
I'm a participant level 1

Not sure why, my cellular data stopped working mid way through the day. Can’t even access Fido app on wifi. Phone/hardware seem to be okay. 

Is there a Fido Network connection? Or would this be a device specific. I’ve restarted and reset my phone. 


I'm a participant level 1
I'm a participant level 1

I have access to a fresh 30GB of data as per my wireless data plan on my iPhone and have never had an issue in the almost 3 years of service with Fido as a customer all in all happy with everything .... however just recently and out of left field my wireless 3G data coverage stopped working and I cannot find anything to explain the reasoning within my Fido Account Profile ... I have searched all over for a reason but no "Notice, Reason, Issue" has been found.... I have reset my network setting as per Fido Online Chat with a computer system said ..... I have also restarted my phone... I dont understand .... does anyone have any idea what could be the cause and how to fix everything in my account is paid and up to date.... please help.

Hey there @BryceFleck_ST !


Welcome to the Community Smiley


This seems a bit unusual though we'd like to ask you a few questions, in order to better assist you.


  1. when did you first notice that you can't access your mobile data?
  2. Have you made any changes to your services recently?
  3. Are you still using the same device too?
  4. Can you please verify that your data settings have 4G/LTE enabled too?
  5. Where are you currently location? Just the city or postal code will suffice.
  6. Are you still able to make calls, and to send and receive texts?

Let us know!

I'm a participant level 1
I'm a participant level 1

I am having similar issues. It shows no internet connection. Only after I take the sim card out and reinsert it, this issue solves. But it's really annoying.

Hey @tan178! Philippe here. Welcome to the community. Smiley


In order to help you, we'll need to ask you a few questions to determine what the problem is


Can you tell us what kind of phone you're using along with the OS version of that phone please?


Can you also tell us how often this happens?


Do restarting the phone do anything or is removing the SIM card needed to get the data back?



I'm a participant level 1
I'm a participant level 1

I am having the same issue on Iphone X 
All receptions, data services was down for the entire day and now phone calls and text messeges are in service. Although i get full LTE bars,
i have no interenet connection. Only wifi works. No error reports except for that there is not internet. 

I have also reset my network serivces but still no luck! 

I'm a participant level 1
I'm a participant level 1

Same thing happens to me. My mobile data is not working. I already restarted my phone and I still have a remaining data.

Hey @Rosalie16 , 


What happens when you try to use your data? 

I'm a participant level 2
I'm a participant level 2

Just today i can’t use my data.. i can send text messages but not imessage and i can call too.. if i want to use the internet i have to use wifi.. 

Former Moderator
Former Moderator

Hey @Zanne!


I moved your post here as it deals with a similar topic.


That's definitely odd, but can be caused by a few things. 


First things first, have you tried to restart your phone to see if that changes anything? It's also important to be sure that data is active in the phone settings.


That said, data can also be suspended if there's unpaid balance on the account so we suggest checking that too.


If that doesn't help, please contact us.


I'm helpful level 2
I'm helpful level 2

I have noticed that if you activate DataBytes then when it expires, sometimes it will leave you with data not working. You need to turn on airplane mode and turn it back off and that generally brings data back.

I'm a participant level 1
I'm a participant level 1

I am trying to use my data, I am not over or anything. It will not load it is asking me for WIFI. How do I unblock the data?

Hey @smigiel,


Welcome to the Fido Community!


I've moved your post in this thread as it deals with the same topic.


That said, data should work fine if there's no block on your account and the account is up to date with payments.


Did you restart your device to see if that helps?


Otherwise, we'd need to take a closer look at your account. You can always contact us so we can better assist you.

Former Moderator
Former Moderator

Hey @Bhavanm


Is everything working now? Let us know. Smiley


Hey @Bhavanm and thanks for reaching out.


We didn't receive any alert on our end concerning this.


What phone model are you using?

Did you try to restart it to see if you can get a better result?

At the same time, are you getting any error message when you try to use data?

I'm a participant level 2
I'm a participant level 2

Hi I have the same problem 5 hs ago, iPhone 8 plus, just says "searching" but doesn't work!!
I turned off several times, restarted it, extracted the simcard, I also went to Fido to check if there is something wrong with FIDO but they say "nothing wrong whit Fido"
I don't know what can I do!

Hey @alejandrarey


Welcome to the community🙂


Thanks for the info provided!


Are you still having the issue? Are you getting an error message when you try to use Data? 


I'm a participant level 2
I'm a participant level 2

Yes!! I can't use data, I don't get error message, I don't get any message!!


Ah no🙁


We'll have to take a closer look at the details with you @alejandrarey


You can contact us here and we'll take it from there Smiley