Xtra doesn't work

Xtra doesn't work

Xtra doesn't work

I'm a Participant Level 3

Xtra doesn't work

Updated to a new version of the fido app accidentally, and haven't been able to click on any Xtra perks. Never, in months. Not one. No contests, no deals in stores, nothing  The button just doesn't do anything

16 REPLIES 16
I'm a Participant Level 2

Also, please read my messages. The option is there, but the button does nothing when tapped. I know I'm tapping on the button because I have visible screen taps enabled.

Hello @Gdsibdfgh

 

You should be able to use Fido Xtra just fine. Which phone model are you using?


Also, do you have the latest version of the app?



I'm a Participant Level 2

Please read ALL posts before replying. I answered those questions already

@Gdsibdfgh 

We are only trying to help here Smiley I must have missed the information while reading the thread.

 

I'm sending you a PM to go over this. Talk to you soon. 



I'm Qualified Level 1

Hi @FidoKenny 🙂

could it makes a difference like a 2 level in the app if you bought your phone at Fido or not?  Maybe it's partially why some people are having difficulty with contests and all? 

I'm.not having problems and my phone is Fido core I'm just saying also cos

somewhere on the community I read that some functions aren't available if not Fido phone like for wifi-calling VoLTE ? 

Have a nice weekend!

Hey @Scooby-Doo! Thanks for your contributions. Smiley

 

This shouldn't make any difference. People should have access whether they have a Fido phone or not.



I'm a Participant Level 3

I'm logging in with my phone number because that's been the ONLY way to log in successfully.

I am using the most recent version because a phone rep told me to reinstall to fix the problem  It didn't work

Hello @Tetranius,

 

Have you tried logging out of your profile before clicking on the FidoXTRA tab?

 

Also, what device are you using? 



I'm a Participant Level 3

I did log out because i umlninstalled the app and it still didn't work. I'm using the cat S61 device

Hey @Tetranius,

 

The first thing that comes to mind when reading your post is that you maybe need to update your device. 

 

If you've got the latest version of the Fido My Account app but your software is not up-to-date, that can create a conflict in the execution of the app.

 

Try that before anything else and let us know how it goes!

 



I'm a Participant Level 3

My device is up to date as of May 1st, and the last check for an update was yesterday.

I'm running android 8.1

 

I'm pretty sure I have the system requirements that the app demands. 

Thanks for confirming! 

 

Are you able to access all other features on the app such as the invoices? 

 

Also, if you go to the "More" tab, do you see the "My Data Bytes History" banner there? 

 

Let me know! 

 



I'm a Participant Level 2

Still doesn't work. I Uninstalled the app, reinstalled  registered with my email address, entered the 4 digit code that fido sent me  logged in with my email address, and still doesn't work.

 

Worse, since my user name was taken (by ME)  I had to make up those bogus user name just to reply to this thread

 

I've been missing out on so much stuff including THREE contests that can only be entered by using this flawed app

I'm a Participant Level 3

The app has no problems otherwise but when I look for the 'my data bytes, 'I don't see it.

Thanks! 

 

Can you please register to My Account with your email? 

 

You mentioned it didn't work, you'll need to create a profile for it to work, once you log in with your email let us know if you see the the option.

 

 



Former Moderator

Hello @Tetranius

 

That's rather odd. From your post it seems the update you've made a few months back caused this. Do you have the latest version of the app now installed though? 

 

Also, are you logging in unto the app with your phone number instead of your email?

 

Please keep the Community posted and we'll reassess accordingly. Smiley