Galaxy S6 from Hong Kong

Galaxy S6 from Hong Kong

Galaxy S6 from Hong Kong

SOLVED
I'm a Participant Level 2

Galaxy S6 from Hong Kong

Hello,

 

I bought a Galaxy S6 from Hong Kong.  I am trying to get the 4G to work (it detected 4G on my S4 before, also bought in Hong Kong).  

 

Can anyone let me know if there are any extra settings I need to do on the S6 to get the 4G working?  Currently only showing 3G network.

 

Thanks in advance.

Camila

 

 

*** Edited to add lables***

Accepted Solution

Re: Galaxy S6 from Hong Kong

Solved by Fido Employee AdamBeast

1. Make sure your phone model supports LTE/4G and it is compatibale with fido LTE network, fido LTE network are:

  • 700 MHz on Band 17;
  • 1700/2100 MHz on Band 4;
  • 2600 MHz on Band 7.

2. Turn on LTE mode from Settings -> More Network/More Options -> Mobile Network -> Network Mode -> GSM/HSPA/LTE auto select. 

 

3. Make sure you have the proper lte apn added, you can find how from http://www.fido.ca/web/content/phonewarranty/configure_unlocked_device_guide 

and http://forums.fido.ca/t5/forums/forumtopicpage/board-id/NonTechnical/thread-id/5820

 

 

View solution in context
4 REPLIES 4
Senior MVP


@camloopy wrote:

Hello,

 

I bought a Galaxy S6 from Hong Kong.  I am trying to get the 4G to work (it detected 4G on my S4 before, also bought in Hong Kong).  

 

Can anyone let me know if there are any extra settings I need to do on the S6 to get the 4G working?  Currently only showing 3G network.

 

Thanks in advance.

Camila

 

 

*** Edited to add lables***


 

Hello Camila,

 

  I have a couple of things that might help...

 

  Firstly, when you refer to 4G, are you referring to LTE? Fido, like many other mobile companies, has labelled their HSPA+ service as '4G' even though those protocols use UMTS or WCDMA. Samsung is usually pretty consistent with their icons so if your previous S4 did not show 'LTE', are you sure you have a LTE SIM?

 

  If you are certain that you have a LTE SIM, check to make sure the phone is using the LTE APN as AdamBeast suggested above.

 

  Secondly, since you bought your S6 from HK, I assume this is the phone here , the SM-G9200. Judging from the specifications I was able to find online, that phone should be compatible with two of Fido/Rogers' LTE bands, bands 4 and 7 (1700/2100MHz and 2600MHz, respectively). The 700MHz listed refers to band 28 and is not compatible with Fido/Rogers. 

 

  Also within those specifications, it suggests that the phone is a dual SIM phone. From what I can gather, only SIM-1 is capable of LTE. Make sure the LTE SIM is in the phone's primary SIM slot.

 

  If the SM-G9200 is not your phone, could you let us know which model version of the S6 you have?

 

Hope some of this helps Smiley

 

Cheers

 


I'm a Participant Level 2

Hi All,

 

Thanks everybody for your help.  There was a setting in the APN that was incorrect, but after I changed it, it is now showing 4G as the label, like my old S4.  

 

Though, I am not 100% sure what the difference between 4G and LTE is.  

 

Again, thank you for all the help, really appreciate it!

 

 

Former Moderator

Hey there, 

 

Like Adam said, make sure the phone is set up correctly. 

 

Let us know if it works. 

 

- Mathieu



Fido Employee

1. Make sure your phone model supports LTE/4G and it is compatibale with fido LTE network, fido LTE network are:

  • 700 MHz on Band 17;
  • 1700/2100 MHz on Band 4;
  • 2600 MHz on Band 7.

2. Turn on LTE mode from Settings -> More Network/More Options -> Mobile Network -> Network Mode -> GSM/HSPA/LTE auto select. 

 

3. Make sure you have the proper lte apn added, you can find how from http://www.fido.ca/web/content/phonewarranty/configure_unlocked_device_guide 

and http://forums.fido.ca/t5/forums/forumtopicpage/board-id/NonTechnical/thread-id/5820