Showing results for 
Search instead for 
Did you mean: 

We've Hit a Snag!!!

I'm a participant level 1
I'm a participant level 1

Help! It keeps saying they hit a snag every time I try to log in the My Account app with my email. I also tried linking my Facebook to my account but it did not work! Says they hit a snag, come back later again. I really want to view my bill when it's gonna be the first time I receive one in a few days. 


I'm a participant level 1
I'm a participant level 1

I'm getting the same issue, can't access the app. when i try to log in it says "sorry we've hit a snag. Please check back later." the main reason i chose fido over vigin (i used to be with) is for the fidobytes since I don't have wifi. if this won't work then i just wasted 45$ set up fee to switch over. is there a workaround or something i can use?


Hey @rift2012 !


Welcome to the Community. Very_Happy


I'm sorry to learn that you're having difficulty using the My Account app.


Here are a few things you can try out :

1. Uninstall and reinstall the app

2. Make sure you're logging in using the correct username (you can contact us to confirm this info, if you're unsure) and that you're not using Wi-Fi.

3. Verify that you're on the latest version of iOS or Android software available for your device.


If all fails, don't hesitate to reach out to us so we can look into this together! Smiley

I'm a participant level 1
I'm a participant level 1

I checked and tried all these but still I cant use the app. I even contacted your agents but they also replied that they can't help with the app. 

Hey there @Ravinath 


Welcome to the Community Smiley


To better assist you, can you please confirm a few more details:

  • At which step/action on the app do you get the error message "We've hit a snag"?
  • Are you able to login to your Fido mobile app? 
    • If not, are you able to access your account on
  • Are you using an iPhone or an Android device?
  • Do you have the latest OS installed on your phone?
  • What is the Fido app version you currently have installed?
  • When was the last time you were able to access the Fido mobile app?

Let us know!

I'm a contributor level 1
I'm a contributor level 1

I am having the same problem from January 29-2021, please help

I'm a participant level 1
I'm a participant level 1


Try clearing the cache and data in Fido app settings. It worked for me.

Hey @Mati1,


Welcome to the community!


I'm sorry that you've been experiencing issues with the app.


Is the app on your device up to date with the most recent update? 

If so, can you try to delete it from your phone and reinstall it? 


Let us know how it goes!

Former Moderator
Former Moderator

Hey @Xphorize,


Welcome to the Community!


We'll need to ask you a few questions to better help you Smiley


1. What is the version of the MyAccount app you have installed on your device?


2. Did you tried to login with the Wi-Fi off and the cellular data on?


3. What model of phone are you currently using?

I'm a participant level 3
I'm a participant level 3

This issue is back again, on my android device. 

"Something went wrong

Sorry, we've hit a snag. Please check back later"


If turn off wifi, I can log into the mobile app.

Hey @bfdy Fido is aware of the issue and is currently looking into it.