IOS IKEv2 VPN over LTE does not work anymore

Reply
I'm a Contributor Level 1 kris2k
I'm a Contributor Level 1

IOS IKEv2 VPN over LTE does not work anymore

I’ve read the recent posts about people affected by usage NordVPN complaining, but in my case, it’s my personal network and my internal users.

 

I’ve ran through the preliminary details and it appears that the phone is initiating a direct IPV6 tunnel that’s superseding the device’s routing table and not allowing the device to use the IPv4 or IPv6 gateways provided by the VPN tunnel (our IPSec tunnel is dual-stack) which are provided by the device’s routing table.

 

What’s up with this?

 

Any recommended IOS profile tweaks to push down?

Accepted Solution

Re: IOS IKEv2 VPN over LTE does not work anymore

Hey everyone!


A little bit of an update for this. Smiley 

 

For Apple devices: 
Apple has released the latest iOS 12.0.1 software which may resolve issues for certain remote/VPN Apps using the IPv6-only connections.

 

If you’re experiencing this issue, please update to iOS 12.0.1 (or newer) and test again.


A possible workaround for Android devices only:
Modify the APN “ltemobile.apn” to IPv4 instead of the default IPv4/IPv6 in the phone settings, under Wireless & Networks - Cellular Networks - Access Point Names.

 

Power cycle the device and test the VPN connection again.


If the issue persists, please note the date and time of the failure and let us know so we can send you a PM to look closer into this with you.

View solution in context
Flag this to a Moderator
Message 1 of 117
20,909 Views
Moderator
Moderator

Re: IOS IKEv2 VPN over LTE does not work anymore

Hey @Kwjej,

 

To ensure we get to the bottom of this, please answer these questions:

 

-Which OS version do you have at the moment?

-What troubleshooting steps did you take? 

 

Keep us posted! 



Flag this to a Moderator
Message 111 of 117
598 Views
I'm a Participant Level 2 Kwjej
I'm a Participant Level 2

Re: IOS IKEv2 VPN over LTE does not work anymore

-IOS 12.4

-have tried rebooting phone, reinstalling VPN profiles, etc.

 

VPNs works perfectly fine on WiFi but runs into issues over LTE. Worked perfectly fine over LTE just days ago so assuming something changed?

Flag this to a Moderator
Message 112 of 117
583 Views
Highlighted
Moderator
Moderator

Re: IOS IKEv2 VPN over LTE does not work anymore

Hey @Kwjej! I hope your doing well. Smiley

 

Looks like we'll have to take a closer look at this with you. You can contact us here or we can send you a PM from the community.



Flag this to a Moderator
Message 113 of 117
556 Views
I'm a Participant Level 2 x_liu
I'm a Participant Level 2

Re: IOS IKEv2 VPN over LTE does not work anymore

I am using a iPhone 8 with iOS 12.4. My VPN type is L2TP.

No problem with the server or setup, the VPN works fine if I am using WiFi.

But it fails with fido LTE network. it is said "server did not respond".

If I setup a hotspot and let my iPad to connect to the internet over iPhone's LTE network, the VPN also works.

 

 

Anyone know how to fix it? thank you

Flag this to a Moderator
Message 114 of 117
419 Views
Moderator
Moderator

Re: IOS IKEv2 VPN over LTE does not work anymore

Hey @x_liu

 

I moved your post here as it's about the same topic.

 

I'll send you a PM so we can take a look at this together.  Talk to you soon!



Flag this to a Moderator
Message 115 of 117
392 Views
I'm a Contributor Level 1 ek66
I'm a Contributor Level 1

Re: IOS IKEv2 VPN over LTE does not work anymore

Hi again,

It is been log time since these ip4/ ipv6 stack troubles on certain iphones.

I would like to know please:

1) Was the issue completely resolved, assuming latest iOS ?

2) People like me were taken a special care by a PM and a  tweak against the IMEI.

If changes were done at Fido for specific issue (put on "old stack" etc.) - were these changes reverted after all is fixed?

Flag this to a Moderator
Message 116 of 117
279 Views
Moderator
Moderator

Re: IOS IKEv2 VPN over LTE does not work anymore

Hey @ek66

 

For iPhone users, the iOS update at 12.2 seems to fix this issue while for Android users, they'd need to disable iPv6. However, if you're still experiencing difficulties past this, you can reach out to us and we'll have our support teams further look into this for you. Smiley 



Flag this to a Moderator
Message 117 of 117
227 Views