Showing results for 
Search instead for 
Did you mean: 

Uknown Device

I'm a contributor level 1
I'm a contributor level 1

For the "fun of it" today I was rooting around in my modem trying to match up/rename all of our devices.  I see one strange thing that doesn't match anything in the house.  I tried blocklisting it, although that appears to do nothing, even with the 24 hrs per day/7 day per week block.  It's still in the *active* list when refreshed...

... 3 hours later, I'm still obsessing over it.  I get back in there and change the wifi password... and update all the household devices.  It's still there.  **blank stare**

What could this possibly be? The IP doesn't match the other devices.  Is this part of the modem configuration?  Probably not since I theoretically have it blocklisted, if that feature even works at all.. and with it on the blocklist, the internet is working fine.  (Well as fine as it has ever worked.)  


This Hitron modem administration is a little wonky anyways.  Device/mac filtering on my Bell internet was 100x easier (just not worth the $).  This thing says "saved", yet there it sits in the active category.  (Just as a "complaint" nobody will care about, maybe work on that UI for any upcoming updates.)    If it was some random neighbouring device who somehow got my wifi password, it should've been booted when I updated the password?



Anyone have similar unknown devices in their wireless list?  



I'm a contributor level 1
I'm a contributor level 1

still tinkering with this... process of elimination.

switched off 2.4 GHz, it disappears, doesn't show under the 5GHz.
.. 2.4GHz back on, it reappears.

switched off the GUEST wifi, it's gone. 

There has never been a device connected to the guest account.  (I've basically enabled it and named it to appear like I have a surveillance system installed for all my slimy wifi-scanning neighbours to see, and given it some obscenely complicated password. lol)


If this "unknown" is the guest account connection, why is it showing as a connected device?  Since there has never been a single thing connected to the guest account (other than my own to verify the 'open' connection showing required a password), there shouldn't be any devices associated with that connection..  


Hello Jewlee121,


  Do you happen to have an Alcatel tablet or device? Apparently, devices with MAC addresses beginning with 94-27-90 were made by TCT Mobile Ltd (see here) which are affiliated with Alcatel (see here). Fido does (at least did) offer an Alcatel tablet (see here).


Hope this helps 😀




I'm a contributor level 1
I'm a contributor level 1


Negative on the Alcatel. 

In that list of connected devices, I have everything accounted for except the "Unknown", the phones/kobo were all prelabelled "android-.....", the computers show their names "PC/Laptop", the FireTV shows "amazon-..."  but that strange little "unknown" says nothing.  

Since leaving the guest account off, it hasn't popped back up.. but it is going to drive me nuts what that was.