cancel
Showing results for 
Search instead for 
Did you mean: 

Fido My Account app "I'm not a robot" only when on Wifi

danthemanx
I'm Helpful Level 2
I'm Helpful Level 2

Hi,

 

Since recently I've been getting a "I'm not a robot" ReCAPTCHA popup after logging in the My Account app ONLY when I'm connected on MY wifi. 

It's the worst recaptcha too, there's so many things to verify, not just a single picture and move on type of thing. 

 

When I'm on LTE or any other Wifi, that blank white recaptcha page shown below doesn't pop up. It only does on my home Wifi. Any reason for that?

This has nothing to do with uninstalling/reinstalling the app or even my specific phone. Tested with another Fido user in my household on their phone as well while on Wifi and it's the same behavior.

 

Wifi is provided by Bell Fibe

Screenshot_20220406-100819_My Account.jpg

13 REPLIES 13

FidoValerie
Moderator
Moderator

Hey @danthemanx Smiley 

We're not sure why this would happen, but it may be related to the security settings on your home Wi-Fi.

Could you please clarify the following, so we can understand the issue a little better? 

1. Are you using the app on an Android device or an iPhone? 

2. What version of the app are you using? 

3. When did this start happening? 

4. Have you tried uninstalling the app completely and reinstalling it? 

 

Thanks in advance! 

 



Hi @FidoValerie ,

 

1. Android

2. Latest app v4.19.0.22

3. Started happening around when my Wifi got upgraded with Bell to a faster speed.. Nothing else changed (a week ago)

4. The app can't be uninstalled, it can only be disabled since it seems it's like a system app. So I did disable, I re-enabled, no change.

 

Thanks! 

 

Hey @danthemanx, Alex here! 

 

Thank you for the details! You should definitely be able to uninstall the application, though. If you don't see the option in your device settings, you should be able to do it from the Play store. I know you mentioned seeing the same issue with another user's phone as well, but can you try to uninstall and reinstall the application anyway? That can help with a lot of different things so it's still a good step to take. 

 

Let us know if you see any change after that. 



danthemanx
I'm Helpful Level 2
I'm Helpful Level 2

Hi @FidoAlex ,

 

I can press Uninstall in the App store, sure, however the My account app is System app, so I can only uninstall the updates not the app completely. I have done that. 

But in order to reopen the app, I have to go back to Play store and do an update because the app says to do that before I can launch it. 

 

Oh actually wow, that did get rid of the I'm a robot issue the 2nd time I tried to uninstall the updates and update the app again for some reason 😲😲

 

Thanks @FidoAlex !

Screenshot_20220411-102803_Google Play Store.jpg

Screenshot_20220411-102920_My Account.jpg

@FidoAlex 

 

Nevermind it's not resolved, the white page with I'm not a robot still pops up, sometimes occasionally sometimes consistently. 

Not sure what's up with it..

Hello Danthemanx,

 

  Sorry to hear you're having issues with the app. From what you note, it sounds like the IP address you phone is receiving from your Bell modem is potentially suspicious (ie lots of suspect connections). That's why the app wants to verify you're not a robot. I sometimes get similar multiple verification requests when I switch my VPN servers as well, though I have not noticed when using the app.

 

  You might consider rebooting your Bell services to see if you can obtain another IP address. Alternatively, you might consider checking your Bell modem to see if there are any settings which could be changed (ie built in VPN?).

 

Hope this helps 😀

 

Cheers

 


danthemanx
I'm Helpful Level 2
I'm Helpful Level 2

Hi @Cawtau ,

 

I have rebooted the Bell modem plenty of times but still have this same behavior.

 

Thanks for your help,

Dan

Hello again,

 

  Thank you for the additional information. I understand this might sound like passing the buck, but have you contacted Bell to ask them how they are assigning your IP address for your internet? Do you get unique IPv4 and/or IPv6 address(es) with Bell? Your issue still sounds like there could be suspicious or increased traffic from that IP. Unusual traffic is generally a cause for repeated CAPTCHAs (see here and here).

 

  As you note, the app seems to work normally using data or other Wifi sources so the issue does not appear to be app related. Do you have similar issues using the internet (ie Google search)? Do you have access to a VPN? If you do, you might consider trying different servers to see if there is a site where you are not prompted with the multiple CAPTCHAs. However, as implied in my previous reply, some VPN servers have been known to be a source of high volume activity.

 

Hope this helps 😀

 

Cheers

 


Hey @danthemanx! Do you happen to run into the same issue when using another Wi-Fi connection? Are you able to log into your account after completing the Captcha? Does this happen with other apps or websites?



Hi @FidoJonathan ,

 

Not an issue on any other Wifi. Not even an issue over VPN, just an issue over MY wifi. Yes I'm able to log in if I go through the captcha, or when I see that checkbox I just do back then try to login again and it sometimes let's me through with no captcha...

Does no happen with other apps or websites.

Thanks for all your feedback @danthemanx!

 

I personally think this may be caused by the fact that Bell Fibe apparea to use a dynamic IP. As you get a new IP everytime your reconnect, this may be what is confusing the ReCAPTIA.



Hi @FidoPhilippe ,

No that's false. I was finally able to resolve this issue. And in fact, it was a problem with the IP I had, I was able to finally get it to change by disconnecting my modem for 30min-1hour. It finally gave me a new IP and I have not had that problem since.

 

So the solution was actually to get a new IP. Not sure why Fido My Account had an issue with that other specific IP I had before, to be honest. 

danthemanx
I'm Helpful Level 2
I'm Helpful Level 2