Showing results for 
Search instead for 
Did you mean: 

Tethering issue - can connect but no internet access

I'm a contributor level 1
I'm a contributor level 1



While trying to fix an issue with short code message, I found another problem...

When I enable tethering (personal hotpot) with current phone ($50/month with 4GB plan), my other device can connect, but there is no internet connection.


Please help me...


Thanks in advance


Senior MVP Senior MVP
Senior MVP

Hello Othersky,


  If I remember correctly, you have a Xiaomi phone. At one point, they had a software issue with tethering. It might have to do with the phone having two SIM slots. Apparently, if one of the slots is left empty, tethering won't work (see here). Are you using two SIMs? If not, do you have access to an old SIM you can test with?


Hope this helps Smiley



I'm a contributor level 1
I'm a contributor level 1

Hi Cawtau,


Thanks for your reply.

I don't think it is a software problem.

Even with only one SIM card, I could do tethering with Bell...

Not sure if the problem is from Fido SIM card....


Thanks anyways..


Hi @Othersky!


Do you have another phone you can test the Fido SIM card in?

I'm a contributor level 1
I'm a contributor level 1

Hi Philippe,


Actually on the way back to home, I went to the Fido Store and tested my SIM card.


First, get a new SIM card (transferred from old one, so same phone number) and tested on my phone.. same different.


Second, the store had a sample SIM card so tested on my phone then I worked. I could get the short codes message and MMS message.


Third, take my SIM card and tested on their phone. Not working as on my phone.


So, definetely the problem should be from the Fido side...(not my phone or SIM card)


I'm a contributor level 1
I'm a contributor level 1

Sorry Philippe,


Ignore my prevous reply. It was for other post...(for short code message issue).


I also tested tethering with other phone and it worked with other phone.

I think somehow this phone's tethering software is not compatible with Fido network... 

As I said, I had no issue of tethering with Bell...


Hope someone can help to solve this..

Hey @Othersky


This service may sometimes work with unlocked phones but it is actually not 100% guaranteed unless it is with a Fido device. There are certain limitations to the support we can offer on the functionalities of unlocked phones. 


Have you tried confirming that you were using their most recent OS version? 

I'm a contributor level 1
I'm a contributor level 1

 @FidoPierre Thanks for your reply.


After spending a lot of time by searching internet and playing with settings.... I think I found something weird..


When I insert Fido SIM card, mjy phone automatically detects Fido network and assign correct APN. However the APN assigned is with fido-core-appl1.apn. I believe because of it gets only 3G and I have to create/modify APN to ltemobile.apn in order to get LTE/4G as @Cawtau hepled me.


The funny thing is tethering is not working with ltemonbile.apn but it is working with fido-core-appl1.apn

Is this a problem from my phone's software or just due to setting or Fido?


I know that whenever I need tethering, I can switch the APN but this is kinda annoying...specially it was working fine under 4G network with Bell...


Any solution or Fido can do to fix this issue?



I can understand how this can be a issue.Since it's not a Fido phone, it's not possible on our end to troubleshoot your device in order to fix this.

I suggest to contact the manufacturer, they might be able to help you with the settings.


@Community: Anyone else had this same issue?