Can't send text messages but can receive

Can't send text messages but can receive

Can't send text messages but can receive

SOLVED
mrschultz
I'm a Participant Level 2

Can't send text messages but can receive

I had an iphone 4 and could send and receive text messages without a problem.  I sold the iphone and switched to an android (big mistake I know), then sold the android and bought another iphone 4.  I can receive text messages, but cannot send text messages!  and this was the same on my andoid phone.  I recently found that if I input the "subject" field in the text, then enter a message, it works fine! but I always need to add a subject every single time I send a text, even though there's already a conversation with myself and the other person.

 

this is frustrating and I have no idea why this happens!  someone please help.

 

 

***Edited to add labels***

Accepted Solution

Re: Can't send text messages but can receive

Solved by I'm a Participant Level 2 mrschultz

yes, very sure i'm not sending mms.  If you check in "message" settings it will give you an option on turning the subject field on or off.

 

Fortunately, I found the solution for my texting problem!

 

All I had to do was change the SMS MESSAGE CENTER NUMBER to +15149931123, previously it was set to my cell number.  Once that was changed, worked fine! and this will fix the visual voice mail option as well.

 

see below:

 

To check your message centre number

  • On your Phone app, go to keypad and type in *#5005*7672# and Call
  • Message number is displayed

If the SMS message centre number is incorrect (does not show +15149931123), you can change it by doing the following:

 

  • PostPaid Number -> *#5005*7672*+15149931123#

 

And there you have it!

 

View solution in context
2 REPLIES 2
10yearfido
I'm an Expert Level 2

Are you sure you aren't sending MMS? text messages don't have a subject line afaik.
mrschultz
I'm a Participant Level 2

yes, very sure i'm not sending mms.  If you check in "message" settings it will give you an option on turning the subject field on or off.

 

Fortunately, I found the solution for my texting problem!

 

All I had to do was change the SMS MESSAGE CENTER NUMBER to +15149931123, previously it was set to my cell number.  Once that was changed, worked fine! and this will fix the visual voice mail option as well.

 

see below:

 

To check your message centre number

  • On your Phone app, go to keypad and type in *#5005*7672# and Call
  • Message number is displayed

If the SMS message centre number is incorrect (does not show +15149931123), you can change it by doing the following:

 

  • PostPaid Number -> *#5005*7672*+15149931123#

 

And there you have it!