cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi calling always off in Google pixel 6

Irf1
I'm a Participant Level 2
I'm a Participant Level 2

Hi,

 

I recently got pixel 6 from Fido before travelling outside Canada. I am already outside Canada. I am trying to turn wifi calling on but it always stays off. When I turn it on, I get a screen to enter my phone number to get an sms verification code from Fido. After entering verification code, I get a screen showing my 911 address. There isn't anything else to do on this screen. If I close this screen, I am back to phone/internet settings and wifi calling still  shows 'off'.

 

After doing all this, I tested by putting phone in airplane mode (and with wifi connected) and I stopped receiving calls and SMS.

 

Any help?

5 REPLIES 5

Irf1
I'm a Participant Level 2
I'm a Participant Level 2

Hi, thanks for the reply.

 

I know I have roaming because I am able to receive calls and SMS while outside Canada (pay per use). I will attempt GPS related stuff you mentioned.

 

As I understand, with wifi calling I will not incur roaming charges if I receive calls on my Canadian number or if I make calls to other Canadian numbers. That's what I am looking for.

Hello again,

 

  Thank you for the additional information. Did you opt-out of Fido Roam or do you have a pre-paid line? If you have the latter, you should note that Wifi-calling is not available with pre-paid accounts:

Wifi Prepaid.jpg

~taken from link in my previous post.

 

Hope this helps 😀

 

Cheers

 

 

 

 


Irf1
I'm a Participant Level 2
I'm a Participant Level 2

It's post paid line (i.e I get a bill at end showing my account activity and charges incurred). I know roaming isn't disabled because I can receive calls and SMS from Canada (I am currently outside Canada).

Hey @Irf1,

 

Have you tried contacting tech support to look into this? 



Cawtau
Senior MVP Senior MVP
Senior MVP

Hello Irf1,

 

  Welcome to the community!

 

  Sorry to hear you're having issues setting-up your Wifi-calling. When setting-up or enabling the feature, is your GPS enabled? The service does need your location. While the GPS is not always enabled in my phone, it does automatically enable when connecting Wifi-calling. Once connected, it disables again. If your device settings have not been set up to automatically enable GPS when required, you might need to manually enable it.

 

  In addition, if (or when) you do get Wifi-calling enabled on your phone, are you aware that Wifi-calling usage is not free and that some usage is considered roaming?

Wifi-calling.jpg

~taken from link above.

 

  If you wish to prevent roaming charges, you might consider enabling Airplane of Flight modes on your device. You could then manually enable Wifi when required.

 

  What plan do you have? You should note that roaming might not be available with some plans. If you don't have a plan with roaming, Wifi-calling outside of Canada might not work. In addition, Wifi-calling is not available on plans without a Talk (voice minutes) component.

 

Hope this helps 😀

 

Cheers