cancel
Showing results for 
Search instead for 
Did you mean: 

Roaming in US Almost Never Works!

YYC2
I'm a Participant Level 1
I'm a Participant Level 1

I have been a Fido customer for at least 6 years and I have never once travelled and had any of my Fido purchased phones work properly. I have traveled to Seattle, Tacoma, Yelm, Spokane & Republic, WA. Orlando, FL, Albuquerque, NM. Houston and Dallas, TX as well as Puerto Vallarta Mexico and have had the same issue in ALL of these locations. 

 

In all of these instances calling usually works, texting sometimes works - and if so it's not consistent. And Data almost never works. In my last trip to Washington it worked briefly for about 30 minutes near Graham, WA.

 

I have called tech support (while in Canada) and determined that yes my roaming was on. I was told to try switching to other available networks so in Spokane WA I did just that. There were 6 or 7 networks and I was not able to use any of them. I was also not able to send or receive phone calls or texts in Spokane. 

 

It is not a problem with this specific device because this problem has been persistent throughout my entire experience with Fido in which time I have had 5 phones. 

 

I am currently using a pixel 1 (this is the 3rd pixel 1 as the first two were replaced under warranty though all three had the US roaming issue.) And the problem was also present with my Nexus 5&6 phones. 

 

The ONLY commonality on this 6+ year experiment in the limits of my patience has been Fido. 

 

Fido does not Roam.

 

I am traveling to Orlando for work at the end of October and I must have a working phone. If someone can fix this - please get a hold of me. 

-m 

18 REPLIES 18

chrissycee75
I'm a Participant Level 2
I'm a Participant Level 2

I realize this post is from 2019 but I am also having similar issues while in Orlando. I can connect to the network and use data but I cannot make or receive calls either to U.S. or Canadian phone numbers. I have tried restarting my phone, connecting with or without wifi, I have no other networks to connect to, and yet I'm being charged $12/day for roaming. I travelled to NYC in February and I had full use of my phone at that time, so I wonder if it has something to do with AT&T's network? 

Hello Chrissycee75,

 

  Sorry to hear you are having issues making calls in the US. What phone and plan do you have? From what  you note, it sounds like your device might be impacted by the '3G' newtork shutdown in the US (see here and here). If your device and/or plan are not voice-over-LTE (voLTE) compatible, they would not be able to access any '3G' networks for calls. That could explain why your data works (LTE), but voice calls do not. In the absence of voLTE, voice calls would necessarily need to fall-back to a '3G' network. Unfortunately, the US does not have any '3G' networks in operation anymore.

 

  You note that your voice calls worked in February. As noted in those links, the US providers started to shut down '3G' services beginning February 2022. It's possible the shut-down hadn't affected NYC at that time.

 

  I understand it's frustrating not being able to use your devices for calls, however, you should note that roaming usage is more than just calls. From what you note, it appears your device is able to use data. The Fido Roam charge incurs when you use Fido services (Talk, Text or Data).

 

Hope this helps 😀

 

Cheers

 

 

 

 

 

 

 


chrissycee75
I'm a Participant Level 2
I'm a Participant Level 2

P.S. I checked and can confirm that the VoLTE and LTE video calling settings are both active on my phone.

chrissycee75
I'm a Participant Level 2
I'm a Participant Level 2

Hi Cawtau, thanks for your response. I have a Blackberry KeyOne (Android/LTE) and I have the Fido Pulse 10GB talk/text/data plan. If 3G no longer works in the U.S., wouldn't LTE kick in? Should I manually input AT&T's APN settings? (I found this online but not sure if it is up to date). 

Hello again,

 

  Thank you for the additional information. Which version of that device do you have? According to this source, AT&T only allows their version to access certain features (see also here). Is it possible your device is not the AT&T version?

 

  Generally, yes. If '3G' no longer works in the US, devices would access the LTE networks (if capable). I think that is why your device is able to use data. However, if AT&T is not allowing voLTE with other versions of that device to access it on their networks, that could account for your situation. If that is the case, I'm not sure manually entering their APN settings would help.

 

Hope this helps 😀

 

Cheers

 


hjkcga
I'm a Participant Level 1
I'm a Participant Level 1

I realize this is old but you could this.  Phone a # that you know will not pick up too fast.  While that call is going through turn on your hotspot.  Try to use the data on a laptop or tablet.   Once the data connected while the phone call was on, it stayed connected.  It was something to do with how the USA tower was blocking the data on my phone.  I also remember having to program an APN on my phone.  Just search how to do that because it is different for each version of Android and Apple.

Good morning @Al_Daigen , sorry to hear that you are having difficulty getting your roaming to work. First suggestion I have is to check your settings to ensure you have roaming turned on. Also, ensure your plan supports roaming. If you have already looked at that, then you would need technical support to take a look for you. I use roaming frequently and haven't had your experience. Call *611 from your device and have tech support troubleshoot it for you. I hope that it gets sorted out for you. 



Al_Daigen
I'm a Participant Level 2
I'm a Participant Level 2

As of June 2022, nothing has changed---had zero call, text, or data connectivity when I crossed the border from Ontario into NY State. Fido Roaming doesn't just suck-it doesn't exist. 

Hello Al_Daigen,

 

  Sorry to hear you're having issues with roaming. As Original_Lucy mentioned, certain plans do not allow for roaming. Specifically, the Basic plans do not allow for roaming.

 

  In addition, while not necessarily applicable to your situation, it should be noted that the US has shut-down their '3G' (WCDMA/UMTS) networks since the original post (see here). Devices without LTE would not work in the US anymore. Also, it should be further noted that Pre-paid plans would no longer be able to roam in the US.

 

  Do you have a Pre-paid plan? If you do, that could explain your current situation and why you were unable to access data in your other post. Before the '3G' shut-down, pre-paid plans only allowed for voice and text message roaming. In fact, pre-paid data is still not available for other destinations either.

 

  If you don't have a pre-paid plan, then the issue would appear to be device- or account-related. I have previously successfully used cellular services when roaming in the US so the service does exist.

 

 Hope this helps 😀

 

Cheers

 


Al_Daigen
I'm a Participant Level 2
I'm a Participant Level 2

Dear Original Lucy and Cawtau,

My plan is pre-authorized payment, charged to my credit card automatically.

Phone and plan are 4G LTE.

Mobile data was on, roaming was on.

 

Before leaving Canada, I phoned Fido Tech Support, they looked up my account, and they assured me that US Roaming would kick in automatically as soon as I crossed the bordert. It did not. I called tech support from the US, and they had me reboot my phone and all that **bleep**--it made no difference. They were supposed to investigated, and I was supposed to call them back in 24 hours, but I didn't bother.

How do you explain all the other people in this thread who have had experiences nearly identical to mine? 

 

ccczzz
I'm a Participant Level 3
I'm a Participant Level 3

+1 - I'm travelling in Seattle right now and Fido gives a "No Service" on my iphone - no txt, no phone call, no data - nothing available even though I double checked my Fido account has been activated with Fido Roam.

 

The tech support does not really helpful, they suggested to "turn on & off my iphone" - which obviously doesn't do the magic to fix the issue.

 

Also, since the 3 hours time zone difference, when I tried to reached out another live agent at 5 pm in Seattle, they already "out of business hours" as its already 8 pm in Eastern time.

 

So given the unreliable Roaming service, non-international service support - I will switch my phone service to someone else other than Fido - as I do need roaming and Fido does not support as what it claims.

Hey @ccczzz

 

Welcome to the Fido Community!

 

Sorry to learn you've having trouble using Fido Roam in the States. As long as you are enrolled for the service and are close to an American tower, there's no reason it shouldn't work.

 

Have you tried to manually select a network from your phone's settings to see if any appears? 

 

Having said that, we offer multiple ways to contact us. We are available until 12 AM through our Social Media channels. Feel free to send us a private message there so we can look into this with you. Alternatively, I can send you a PM here.

 

Let me know what you prefer.



ccczzz
I'm a Participant Level 3
I'm a Participant Level 3
Hi FidoSaira,
 
I've tried below things:
 
- turn on/off my phone
- reset network settings
- turn on data roaming on my iphone
- double check Fido account with Roam activation
- manual network carriers selection (from AT&T to T-Mobile to several other carriers)
- Change data options (LTE, 3G, 2G)
- chat with Fido live agent, who confirmed my Fido account is good with fido roaming (not blocked), and then suggested turn off & on my phone, and then she saids she gonna "resend my network which requires turn off my phone again" (which afterwards I think it just an excuse to get rid of me as she is near to off work it was 5 PM Seattle time but 8 PM on EST time))
 
And now I'm still getting "no service" on my phone.

ccczzz
I'm a Participant Level 3
I'm a Participant Level 3

And also FYI, I'm in Seattle downtown right now, so there should near to some American towers here.

ccczzz
I'm a Participant Level 3
I'm a Participant Level 3

Therefore, I couldn't imagine any other reason other than Fido makes a fake claim on its roaming service. The fido roaming DOES NOT WORKING.

Hey @ccczzz

 

It seems like you've tried every possible troubleshooting step on your end.  I'll send you a PM so we can take a look at this together.

 

Talk to you soon!



FidoFrancois
Former Moderator
Former Moderator

Hello @YYC2,

 

What you're describing is certainly not the experience we aim for with our roaming service! 

 

To ensure we get to the bottom of this for you, can you answer and expend a bit more on those questions: 

 

-Have you changed your SIM card? 

-While traveling, do you set network selection to automatic or manual? 

-Did you speak with technical support after your experience in Spokane to reassess the situation? 

 

Let the Community know, we'll reassess from there.