Hitron CGN3AMF unusable 2.4GHz WiFi

Hitron CGN3AMF unusable 2.4GHz WiFi

Hitron CGN3AMF unusable 2.4GHz WiFi

I'm a Contributor Level 1
I'm a Contributor Level 1

Hitron CGN3AMF unusable 2.4GHz WiFi

Using 60/10 service for few months. No issues with cable connection (all parameters normal), no issues with 5GHz WiFi (7 x 802.11ac devices connected), but never managed to make 2.4GHz WiFi work as expected. It works well for about 1min after router restart and then slows down to about 2Mbps and stays there until next restart. 

 

- wireless channel is relatively clear (other routers as Access Point transfer >50Mbps on the same channel)

- tried both "Mixed" mode and "N Only", no difference

- tried both security settings WPA-PSK/WPA2-PSK + TKIP/AES and WPA2-PSK + AES, no difference

- tried to eliminate WiFi clients one by one to isolate client side issues, no difference

- tried resetting the Hitron and set it up from scratch, no difference

 

ASUS RT-N66U as Access Point has no issues whatsoever running both 2.4GHz and 5GHz WiFi networks.

ASUS RT-N12D1 as Access Point has no issues whatsoever running 2.4GHz WiFi network.

 

Something is not right on Hitron device. Firmware version is 4.5.8.17. Is it a known issue or I need call FIDO Customer Service and ask for device replacement?

 

Thank you!

 

***Edited to add labels*** 

14 REPLIES 14
I'm a Participant Level 3

The only way I could fix that was setting up my notebook to G only.

 

Check this link and change you PC/Notebook to 02 - 11g

http://www.thewindowsclub.com/enable-802-11n-mode-wireless-connection-windows-8

 

I hope it helps you.

 

Rafael.

I'm a Participant Level 1

Hi,

I have been having the same issue where 2.4GHz just does not work. I have spoken with Tech Support sveral times, changed the modem, 3 times, and also had a Fido technician stop by and change my modem a 4th time. The technician also said that it was an issue with the modem and there was nothing he could do.

 

Some of my devices only work on 2.4GHz so I require a decent 2.4Ghz signal. I am also not willing to pay extra for seperate router as I have very basic internet usage in a small condo.

 

What are my options? Is Fido willing to solve this issue (with a modem upgrade or fix) or is this something I will have to live with? Thanks.

I'm a Participant Level 2

You have to live with it I have been for months now.

 

im a certified network engineer for 20 years, tge issue is the firmware, its not working with 5g and 2.4 simultaneously, you have to pick one or the other.

 

since I live in a big house i set tgis to 5g and i tether off 2.4 routers which works great.

 

u can buy cheap router for 20 bucks new online.

 

fido has done nothing or will do nothing so I’ll change providers when I get back from vacation 

Hey @Ajoci & @DrData!

 

We'd love to help out with this, and we do understand the importance of a reliable service!

 

Have you checked out our Fido Home Internet Firmware Trial?

 

The trial allows you to test new firmware for our modem, you can even see some of the fixes the new firmware offers here!

 

To sign up, just send a PM to @FidoSolutions here on the Community, and we'll get you set up!

 

 



I'm a Contributor Level 1
I'm a Contributor Level 1

And one more interesting detail - Airlink101 Wireless N USB adapter (model AWLL6075, chipset Realtek RTL8191SU) is rebooting the Hitron immediately after establishing connection. I already replaced the adapter with AUKEY Wireless AC USB and solved this problem, but still it's not normal. None of the two other routers mentioned in the first post reboot because of Airlink101. Firmware bug in Hirton, probably?

Hey @VBD

 

Welcome to the Community. 

 

This definitely doesn't sound right. Did you get a chance to speak with our Fido Internet technical support about this? They should be able to help you out and shine some light on this situation. 

 

They can be reached through live chat right from here. Smiley 



I'm a Contributor Level 1
I'm a Contributor Level 1

Replaced the Hitron device today as per FIDO Customer Service recommendation. The Sales Rep at the store didn't complete the transfer process properly and the new device wasn't connecting. Had to call FIDO Support, wait 20min to speak to someone and then another 30min to get the new modem finally activated. Have no idea what took them so long to enter the Serial Number and MAC address in the system. 

 

The bad news is the new device has exactly the same issues as the old one. 2.4GHz WiFi network starts fast at about 50Mbps Internet speeds and shortly after drops down to 2Mbps. 5GHz WiFi network is flying at full speed. I have to use a second router as Access Point in order to have Internet on my 2.4GHz devices. Entry level ASUS RT-N12D1 for instance hits consistently 40-50Mbps internet speeds, no problem.

 

Well, I guess Hitron in 2017 still can't fugure out how to implement properly 802.11n standards. CGN3AMF is probably the worst router I deal with in last 10 years. Even cheap N300 routers beat it's 2.4GHz WiFi performance easily. That explains why many Rogers/FIDO Internet customers use their own routers and put the Hirtons in Bridge Mode.

I'm a Participant Level 2

I have the EXACT same issue! I am a certified network engineer on multiple router types for 20 years and 2.4g is an issue on this router.

I put a cheapie cisco router daisy chained off this router and I get full speed, so it's obviously the hitrin fido router an issue.

I was getting fido service at my other place but went with dsl because i can't afford down time or have the time to address these type of issues especially when I'm running my ipcams and need stability and every one of them are offline now.

I have to drive home and move them to my cheap router running ddwrt.

Hopefully fido can fix it. Fixing it will generate new business vs losing existing business.. I promise you.

Thanks for sharing those details @VBD, @DrData ! Our tech. team will be able to escalate the issue if needed, that's why you need to contact them.  Once they access your account and see what's up with the hardware they'll be able to take action from there. The more examples we have about this problem, the better we can work on having it resolved!



I'm a Contributor Level 1
I'm a Contributor Level 1

I did contact the tech team and no one has no clue what is happening. My modem was just rebooted few times and then replaced. Problem can't be solved this way. FIDO modem is in Bridge mode now and I'm using my own router.

Thanks for the feedback. I'll send you a PM so we can discuss this further!



I'm a Contributor Level 1
I'm a Contributor Level 1

FIDO's modem in Bridge Mode and additional brand name gigabit WiFi router is the only solution for now. There is a huge difference in WiFi performance.

Former Moderator

Hey @VBD

 

Thanks for keeping us posted! I see that you were instructed to have the modem exchanged by customer service. 

 

I just wanted to ask if you spoke to our Internet technical support team as @FidoPierre suggested ? They might be able to give more information ! 



I'm a Contributor Level 1
I'm a Contributor Level 1

I work in IT. After analizing the traffic on the 2.4GHz network I found Hitron's WiFi crashes when specific WiFi devices connect to the network. In my case Brother MFC-J265W wireless printer (802.11g) and an Atheros AR5B97 network adapter (802.11n) cause the slowdown and 2.4GHz WiFi never recovers. Hitron must be rebooted to recover. Above mentioned Airlink101 USB adapter (802.11n) crashes the entire router causing automatic reboot. Those are critical compatibility issues with Hitron. I have 3 other routers around to play with and they all work perfectly with all devices on the network.

 

Other issues noticed with Hitron:

- configuration page hangs often after changes

- sometimes 2.4GHz WiFi completely disappears after device reboot without changing any settings

- connected devices table often contains duplicated host names or is incomplete

- DDNS service doesn't work with 3 popular providers 

- USB storage is a hit and miss, only some devices are recognized 

 

I don't see how exactly Internet Tech support will be able to help here. The manufacturer of the device has to fix their firmware first. Hardware is acceptable, software is terrible. I read Rogers is testing new firmware versions for CGN3 devices, hopefully the device performance improves over time.