iPhone Fido app not working

iPhone Fido app not working

iPhone Fido app not working

Na10
I'm a Contributor Level 1

iPhone Fido app not working

Just switched to Fido yesterday. Loaded my Fido app and have been trying to log in with my mobile number ever since. Every time I get the authenticity code I put it in and it tells me log in session has expired I called technical support and they said it would take 30 to 60 days to fix. I’m really confused. I have the latest iPhone software and I’ve tried uninstalling and reinstalling on Wi-Fi and without Wi-Fi. No success. Any ideas? Thanks so much in advance!

28 REPLIES 28
FidoPierre
Moderator (inactive)

Hey @Na10,

 

Welcome to the Community. 


Can you confirm if you are able to log into My Account from a browser page? Also, can you try registering your email address as a username to log in and let us know if that works on your side? 



Na10
I'm a Contributor Level 1

Hi there,

Yes, I can log in with my email from a browser with no problem.  Now I've been kicked out for 24 hours due to too many codes being sent to me and tried.

Thanks!

Can you also let us know if you're trying to access the app while connected to WiFi? 

 

Can you turn your WiFi OFF and try again to see if that changes anything?

 

Keep us posted!

 

 



Na10
I'm a Contributor Level 1

Hi there,

Done that...as stated in my previous message I have done on and off wifi.

Thanks,

Naomi

FidoAmanda
Former Moderator

Are you using the same credentials that you use when you log in to My Account on Fido.ca? 

 

If you are, could you try creating a new profile using your email address as your username instead and let us know if that changes anything?



Na10
I'm a Contributor Level 1

Hi everyone, 

i really appreciate your assistance, however this is getting very daunting. In the app the Only option is putting in a phone number. There is no option to type in letters for an email.

Hey @Na10

 

Do you have an option that says "I don't have a Fido number" on your screen?  If you have that, try selecting it then choosing the log in option.  It should take you to the login page.

 

Let us know how it goes Smiley



Na10
I'm a Contributor Level 1

I do, and I was going to try that, but when I called technical support they said not to do that as it will mess up my account.  I can log in to the site from the Internet, no problem.  I just am apprehensive as I don't want more issues.

FidoThomas
Moderator (inactive)

Hey @Na10,

 

I get where you're coming from. Rest assured that you've taken the right steps to ensure the resolution of your issue Smiley I understand it's a long delay, and we'd love to shorten the time as much as possible. We also don't want to create more issues, as you said, so at this point we'll need to wait. Sorry for the inconvenience!

 

The situation has been escalated to the technical support, they'll fix this for you. Very_Happy

 

In the meantime, if you have any questions, feel free to ask us!



yatmandu
I'm a Contributor Level 1

I have the same probem as Na10 - new Fido subscriber on two lines. My son was able to get a code for his Fido My Account app, and all is good, but mine gives the "session timed out" thing until I exhaust all codes for the day. The only thing is I also tried logging in via email (before I read all of this), which gets me usage and billing but no "Free 5 hours DATA" thing. Also, since I've logged in by email into the app, my mobile number has disappeared from my online account profile on the web. When I add it back in and save, it disappears next time I log in.

 

I thought I was leaving all these kinds of problems when I switched from Rogers!!! 

 

What do I do next? Tech support?

samgabbay
I'm Helpful Level 1

Hey @yatmandu,

 

That's quite unusual, I had issues like that when i first activated but everything was sorted after calling tech support.  I hope a mod could reach out to you. 

 

if anything, you can always give them a call and they should be able to escalate a ticket to tech support.

 

Cheers!

yatmandu
I'm a Contributor Level 1

Thanks @samgabbay I will phone tech support tomorrow and see if they can clear this thing up.

Na10
I'm a Contributor Level 1

Please post what they say...GRRR...so frustrating!!! When I called Tech support they said they would fix it between 30-60 days...I also switched from Rogers...not a great welcome to Fido Smiley

 

yatmandu
I'm a Contributor Level 1

Last tech support guy I talked to seems to think it's related to some Rogers system that still has my email associated with it. He thought that was the reason for the session timeout on the authentication code and why my mobile contact info keeps disappearing from my fide.ca profile. They're going to try to disassociate my email from Rogers, which should clear things up (maybe?) but it's going to take a few days.

cytuser1
I'm a Participant Level 2

I have exactly the same problem! I hope they fix this issue soon. I too am tempted to switch back to Rogers.

Na10
I'm a Contributor Level 1

You and me both....it’s going on 8 weeks now!

FidoKija
Former Moderator

Hey Na10! 

 

Did you receive a follow up by our technical team? 



Na10
I'm a Contributor Level 1

 No, I have called numerous times! My understanding is that Fido doesn’t even have a technical department. I am always told that there is nothing wrong on their end. It’s pretty frustrating! Pretty soon I think they’ll be some Twitter voice happening. Perhaps someone at Fido will then take notice. 

FidoThomas
Moderator (inactive)

Hey Na10,

 

Of course we do have a technical support department! It's definitely taking much more time to fix than most issues, it's quite unusual. 

 

I also understand how frustrating this situation is, I'm really sorry for the inconvenience. I'll send you a PM, I'd like to check the status of your case!

 

Talk to you soon Smiley



Na10
I'm a Contributor Level 1

Ok thanks