Showing results for 
Search instead for 
Did you mean: 

“Something went wrong, we’ve hit a snag”

I'm a contributor level 2
I'm a contributor level 2

I could log in to the app this morning, but I get this error now, for the last hour or so.  Anyone else?


I can log in to the website, reinstalled the app, rebooted the phone, tried wifi...


I'm a participant level 1
I'm a participant level 1

Hi, i have the same 'we've hit a snag' message on the app. The website on chrome works though. I have cleared the cache and even deinstalled and reinstalled it but in vain. 

Hey there @Shanil2302!


Can you please confirm that your phone has the latest OS update installed as well? To ensure the best experience using out app, both the OS and the app's version should be the latest available.


If that's already done and you're still unable to log into the Fido mobile app, we would suggest resetting your login password.


Let us know how it goes Smiley

I'm a participant level 2
I'm a participant level 2

Unfortunately not. Still getting this error for the last few months 

I'm a participant level 2
I'm a participant level 2

I think I have been having the same error for several weeks?  Tried clear cache and I just tried on my computer with no luck.


I did try saying that I forgot my password. I have dual authentication and I was able to reset it.  I noticed that my new password could only have certain non-alphanumeric characters. My old password wouldn't have met the criteria. So they changed the requirements and I automatically couldn't get in until I fixed the password to meet what they wanted.

Hey @micielo,


We'll be happy to go over the situation with you


There are several ways to reach customer service:


 - On the phone (by dialing 611 from your Fido device), you will have a call back option instead of waiting on the line

- Via live chat on

- By writing us a private message on our social networks (Facebook, Twitter or Instagram).


Hope to talk to you soon. 

I'm a participant level 2
I'm a participant level 2

For the last 3 years, it was acceptable to have * ^ or % in my password.
Then for the last several weeks, it was only acceptable to have $ # or @ as a character in my password.

There was NO indication with the message that was given, "Sorry try again later" that it was my password / Fido's password requirement changes that was causing the problem.


Did you read my previous post?
My last sentence indicated: 
"...couldn't get in until I fixed the password to meet what they wanted."

That means I did get in but only when I fixed my password. 


I share because others are probably getting similar messages (Sorry try again later.). And from what I got when I searched, not much help.

Thank you for your feedback. If you encounter any other issues, feel free to contact us.

Hi there @ColinVincent,


That's definitely not right. 


Have you cleared your cache? That's very often helps. 


Let us know


Hello @Cm2017,


I believe the website was down for some time, it should be working fine now let us know if you are still having issues.