Showing results for 
Search instead for 
Did you mean: 

My fido account apps

I'm a participant level 2
I'm a participant level 2

After updating the apps , it's directed to login screen everytime, Before I can checked my data usage just opening the apps. I tried to uninstall/install but it's the same thing. My wife Apple phone works just fine after the update. My Google Pixel doesn't work at all. 


I'm a participant level 1
I'm a participant level 1

Hi there,


Have you resolved this issue yet? It's annoying to enter email address and password every time I login.

Clearing cash and uninstalling app didn't work at all.





Former Moderator
Former Moderator

Hey @Jae3


Thank you for letting us know what you've already tried. We're looking into this and working to having it resolved for everyone impacted as quickly as possible! 

I'm a participant level 3
I'm a participant level 3

I have the same issue. Did all troubleshooting steps.


Everytime I login, there's a pop-up message that says "GENERIC_ERROR_TITLE" below that, it says "WE'VE_HIT_A_SNAG"


Then, when I tap OK, it directs me to a screen that has my name and number at the top which asks me to log in to securely access your bill and account info.


Uninstalled app, restarted phone, reinstalled app -- NO LUCK


I am using iPhone XR.


Hopefully, this will be resolved as soon as possible.



Hey @NPR! Welcome to the community. Smiley


Make sure that your app is updated to the latest version. Can you also answer these questions:


1. Are you getting the error message while you're connected to Wi-Fi or to the Fido network, or both?

2. Can you log-in on 

3. Is your iPhone iOS updated as well? 


Let us know!

I'm a participant level 3
I'm a participant level 3

Thanks! Fido app is updated.


To answer your questions:


1. Both

2. No issues logging into

3. iOS is updated

Hey @NPR! Thanks for replying. 


In this case, I recommend that you contact our customer service. We can also send you a PM on the community, we'll be happy to look into it with you. Let us know what you prefer!

I'm a participant level 3
I'm a participant level 3

I don't know what happened but it's all good now. 

Thank you for responding on this thread. Stay safe!

Senior MVP Senior MVP
Senior MVP

Hello Edmond1,


  Welcome to the community!


  Had you tried to clear the app's cache to see if that helps your situation?


Hope this helps 😀