Links to contests in Fido Extra Not Working

Links to contests in Fido Extra Not Working

Links to contests in Fido Extra Not Working

SOLVED
helkur
I'm a Contributor Level 1

Links to contests in Fido Extra Not Working

I have tried on many occasions to enter the contests using the link in the Fido Extra page. )Cineplex Odeon this time). Anyone else have this issue?

Accepted Solution

Re: Links to contests in Fido Extra Not Working

Solved by I'm a Participant Level 3 ayw

Not sure if you were able to rectify your problem for not being able to enter contests.  I had the exact same problem and I am now able to enter all contests and perks.  My problem was that I was running an Ad Blocker app  and after I turned it off I was able to enter all contestes and all extra perks.  Hope this helps.

View solution in context
30 REPLIES 30
Scootericity
I'm a Participant Level 1

Fido Extra links not working (again). Big surprise after you decide to "upgrade" the app. My solution... leave what works alone instead of trying to justify your paycheck.

Hey @Scootericity!

 

Thank you for your feedback, we'll be happy to take a look at this with you. 

 

Did you get any emails about this? 

 

Have you tried uninstalling the app and reinstalling it again?

 

Thanks!

FidoFrancois
Former Moderator

Hello @helkur,

 

What happens exactly when you try to enter the contest? Can you give us more details about what you encounter? 

 

Please keep us posted, 

 

 



Scooby-Doo
I'm Qualified Level 1

Hi @helkur 

 

have you resolve your issue with entering  the appcontest  Fido has updated their app this week. Also  please insure you have the latest IOS updates on your iphone and apple tablet.

 

Cheers!

garyo99
I'm a Participant Level 3

I have the exact same problem, the app on iphone, when you click on Perks every Thursday, all it says is Sorry, we couldn't find that page. Go Back.

Every since the upgrade, it rarely works anymore has become super frustrating to use.

Hey @garyo99

 

Can you uninstall the app and reinstall it? That should fix what you're experiencing. 

 

Keep us posted Smiley  



garyo99
I'm a Participant Level 3

Hi. The app has stopped working again for the perks. This is very frustrating. 

Thanks for trying. I'll send you a PM so we can look into this @garyo99.

 

 



sgosein
I'm a Participant Level 2

Same issue for me. Can't complete the entry on any of the contests! Sad

Hey there @sgosein!

 

What happens when you try to enter the contest? Do you get any error messages?

 

Can you please confirm to us which contest you're referring to, and please make sure that you have the latest version of the Fido mobile app installed.



sgosein
I'm a Participant Level 2

Nothing happens at all. 

Deleted app and reinstalled with the same result. 

Cleared storage and cache before and after, same result.

 

This applies to all perks / contest.

 

I was trying for this one:

Checked the box to agree to contest rules and tapped enter now. Absolutely nothing. 😳

 

 

14 DAYS LEFT
sgosein_0-1582201249827.jpeg

 

Win 1 YEAR of FREE Fido service!

A Fido XTRA contest like you’ve never seen before! Each month, all year round, 10 lucky Fido XTRA users will win 1 YEAR of FREE Fido service.

Each winner will receive a one-time credit representing 1 year of Fido service (one mobile line or Internet service), to be applied to their Fido account. To be eligible, you must be an existing Fido Mobile or Internet postpaid customer before February 6, 2020.

Don’t miss out on the chance to enjoy a full year of savings! Enter daily for more chances of winning.

HOW WILL POTENTIAL WINNERS BE CONTACTED?

Keep an eye on your Fido app and make sure your app notifications are turned ON! Potential winners will receive an app notification and a message will be displayed right here at the top of the Fido XTRA section as of March 12, 2020. Make it a habit to come back every Thursday to make sure you never miss out.

 

By entering this contest, I agree to be bound by the contest rules.

ENTER NOW

REDEEM BY 03/04/20 at 11:59 pm

BACK
ayw
I'm a Participant Level 3
I'm a Participant Level 3

Not sure if you were able to rectify your problem for not being able to enter contests.  I had the exact same problem and I am now able to enter all contests and perks.  My problem was that I was running an Ad Blocker app  and after I turned it off I was able to enter all contestes and all extra perks.  Hope this helps.

nomorevoicemail
I'm a Participant Level 3

I cannot enter any contests, the "Enter Now" button is not the same colour as the "FIDO EXTRA" bar at the top, The "EnTER NOW" button is a light Yellow, and is unusable !!

I have read and tried everything on the subject to no avail.

Please stop sending e-mails every thursday for something that does not work.

 

Yes..that worked, the box i was to click was almost invisible, I kept looing through the pages and pages of contest rules looking for the box, Maybe make the box a little more obvious.

Thankx muchly from a 70 y/o

Happy to hear that it all worked out in the end @nomorevoicemail, and thank you for the feedback Smiley

 

You're welcome, and make sure to check out the other perks as well, we always got new ones coming each week.

 

Cheers!



Hey there @nomorevoicemail

Do you have the latest Fido app version installed on your phone?

If so, to enter the contest, you first need to agree to the contest rule (check the box) and the yellow box "Enter Now" will become available.

Can you please confirm?



Hey @sgosein,

 

That's odd, I just tested it on my side and it seems to work. 

 

Did you try entering the contest while on WiFi? If yes, can you turn it off and try again on LTE?

 

Also, if your account has multiple lines, can you please confirm that you're using your own number to log in?

 

Keep us posted.



ayw
I'm a Participant Level 3
I'm a Participant Level 3

I have never been able to enter a contest either and this one is again not working on my phone.  I have a Huawei Nova Plus phone and I have updated to the new app version.  It will let me fill in the box but pressing the enter button nothing happens.  I have also tried on wifi and on data.

Hello @ayw

 

This doesn't sound right, you should be able to enter contests without a problem.

 

To better understand what's going on, I just want to ask you a few questions.

 

Have you tried to restart your device to see if you get the same result?

 

What's the last contest that you tried to participate to?

 

What's the OS version that you are using now for your Huawei device?

 

Let us know. 



ayw
I'm a Participant Level 3
I'm a Participant Level 3

Tried restarting to no effect.  

I only tried entering contests since last year which did not work.

 

My EMUI version is 5.0.3 - MLA-L03C654B350

Andriod version 7.0

 

Tried checking for updates but it says there are no updates

 

 

Thanks

Glenn