Showing results for 
Search instead for 
Did you mean: 

Can’t login to myfido app

I'm a participant level 2
I'm a participant level 2

I’ve been trying to login to myfido app for the past couple days but it won’t let me. I can login just fine online on but when I use the app, it says account info not available. Any ideas why? Thank you.






I'm a participant level 2
I'm a participant level 2



I'm experiencing the same issue!

Hey dleungtm!


Could you confirm a few details for us? 


Are you using your email address or phone number as your username? Are you on Wifi or the Fido network when you experience this error? Have you tried uninstalling ad reinstalling the app?


Let us kow and we'll take it from there!

I'm a participant level 2
I'm a participant level 2

Hey Amanda!


I'm logging on using my email address, and the issue is present on both wifi and the Fido network. Uninstalling and reinstalling the app also does not resolve the issue.



Thanks for getting back to us! 


Are you using the iOS version or the Android version?


Are you using the latest version of the app? Can you confirm the version number?

I'm a participant level 2
I'm a participant level 2

I'm using the iOS app, and yes, the latest version: 3.2.5 (1)


Perhaps it has something to do with the email login being associated with a prepaid account as well? When the account login was set up, I recall a technical limitation on the backend meant that both the postpaid and prepaid accounts would be associated with the email address, despite prepaid accounts not being compatible with the app (hopefully that's something the team is working on as well!) As of the last major update though, the app was able to separate the two, and allow the user to retrieve the details of the postpaid account only - so I'm not sure what's changed to prevent logging in now.

Hey @dleungtm


Thanks for the update Smiley


We'll need to take a look at your account to figure out what's causing this, so I'll send you a PM.


Talk to you soon!

Former Moderator
Former Moderator

Hey @Bhupi,


Does this happen once you attempt to fully log in or only when you are viewing your usage?


Do you get the same error on Wi-Fi and on Data?


Let us know!

I'm helpful level 3
I'm helpful level 3

for checking usage i dont need to login it will work with my data to see my usage. but to get bill or download bill or other details i have to login and getting error message.


i tried with Data and WiFi - same issue. unable to login with my Email address and password. same email and password work fine on


this is my very old account i know you have issue for new user  registered to My Account on or after December 6, 2017 have issue with myaccount login but my account is almost 9 year old.