Voicemail notifications on S9

Reply
I'm a Participant Level 3 Skinned
I'm a Participant Level 3

Voicemail notifications on S9

Does anybody else have a problem with Galaxy S9 voicemail notifications? It comes up even if there is no voicemail, and when there is deleting all messages doesn't make it go away. Clearing the phone app data and cache makes the notification and indicator go away but only temporarily. It's driving me crazy. 20190327_150132.jpgMy mailbox is currently empty.

 

Accepted Solution

Re: Voicemail notifications on S9

I fixed the problem. It appears to be a bug in the Samsung Phone app. I installed a modified version of the Google dialler that works with the phone, set it as default and then revoked all of the Samsung phone app's permissions. Problem solved.

 

I just came to post the fix here in case others run into the problem.

View solution in context
Flag this to a Moderator
Message 1 of 10
762 Views
Former Moderator FidoValeska
Former Moderator

Re: Voicemail notifications on S9

Hey @Skinned

 

I can see how inconvenient it can be to keep getting that notification. 

 

Let's try these to disable and then re-enable the “show notification” option via the voicemail app settings. This fix is known to remove the ever persistent new voicemail notification. Here’s what you need to do:

 

  • Firstly, access the “Show notifications” setting in your voicemail application by going to your Galaxy S9 Settings.
  • Here, find and open the Application Manager.
  • Navigate to all apps.
  • Scroll and find the Voicemail app.
  • Tap to open it and then deselect the Show notifications option.
  • Once disabled, tap the option to re-enable it.
  • Make sure to check “Show notifications.”
  • Reboot your Galaxy S9 and test that the voicemail works correctly by leaving yourself a test voicemail.

Keep us posted if that works! Smiley 



Flag this to a Moderator
Message 2 of 10
734 Views
I'm a Participant Level 3 Skinned
I'm a Participant Level 3

Re: Voicemail notifications on S9

Hello @FidoValeska

 

Thanks for responding.

 

Unfortunately I can't follow this instructions. The S9 doesn't use the voicemail app, it has its own "Phone" app. Notifications cannot be turned off for it. Best I can do is "Silent and Minimized" Screenshot_20190328-085914_Settings.jpg

 

20190328_090003.jpg

 

Flag this to a Moderator
Message 3 of 10
724 Views
Moderator
Moderator

Re: Voicemail notifications on S9

Hey @Skinned!

 

Would you be able to try performing a full factory data reset to see if that changes things?

 

Let us know if that helps!



Flag this to a Moderator
Message 4 of 10
704 Views
Highlighted
I'm a Participant Level 3 Skinned
I'm a Participant Level 3

Re: Voicemail notifications on S9

Hello @FidoAmanda,

 

Unfortunately that doesn't fix the problem. I've reset factory reset it it twice; once before the Pie update and two weeks ago when I had my screen replaced. The issue has existed since the first day I was issued the phone running Oreo. It appeared to be brand new when I got it.

Flag this to a Moderator
Message 5 of 10
672 Views
Former Moderator FidoValeska
Former Moderator

Re: Voicemail notifications on S9

Let's try something else! 

 

Go to Setting> Apps > on the 3 dots (show system apps) > Look for phone. There a 3 phone apps listed, you can choose the first one, then click storage and clear data. 

 

Let me know if that works! 



Flag this to a Moderator
Message 6 of 10
648 Views
I'm a Participant Level 3 Skinned
I'm a Participant Level 3

Re: Voicemail notifications on S9

That does work, but only temporarily. The voicemail notification will eventually come back in time, even without so much as an incoming phone call, sometimes in a day or two, sometimes within an hour or two. I don't see any type of pattern.

 

Maybe it's worth noting that before this phone I used to have an iPhone and I had visual voice mail. I thought maybe something was wrong on the account end so I phoned in an had my add-ons looked at. No issues found.

Flag this to a Moderator
Message 7 of 10
625 Views
Former Moderator FidoValeska
Former Moderator

Re: Voicemail notifications on S9

Thank you for trying that out @Skinned

 

At this point, I would like to double check the add on on the account, just to make sure that everything is right on our end. 

 

I'll be sending you a PM shortly. 

 

Talk to you soon! 



Flag this to a Moderator
Message 8 of 10
610 Views
I'm a Participant Level 3 Skinned
I'm a Participant Level 3
Solution

Re: Voicemail notifications on S9

I fixed the problem. It appears to be a bug in the Samsung Phone app. I installed a modified version of the Google dialler that works with the phone, set it as default and then revoked all of the Samsung phone app's permissions. Problem solved.

 

I just came to post the fix here in case others run into the problem.

Flag this to a Moderator
Message 9 of 10
369 Views
Community Specialist
Community Specialist

Re: Voicemail notifications on S9

Sweet, thanks for sharing @Skinned ! 



Flag this to a Moderator
Message 10 of 10
344 Views