Fido tethering: connected but no internet

Fido tethering: connected but no internet

Fido tethering: connected but no internet

sdafasdfsdfas
I'm a Contributor Level 1

Fido tethering: connected but no internet

I have a data plan (10gb) and account in good standing. I had Moto X Play and tethering worked great.

 

I got a new phone (unlocked LG phoenix 3 2017) and now when I create hotspot, a device can connect to it but there is no internet.

 

I have already set up the APN (LTEmobile.apn) and data works fine on the phone. Just not the tethering.

 

I have looked and no posts on this forum definitively solve this issue. Please help, thanks

 

 

22 REPLIES 22
c781
I'm a Participant Level 1

I had this problem as well, and stubmled upon a solution.

I could connect to the hotpsot, but it kept saying "no internet," even though LTE worked fine on my phone. When I turned off wifi (in network settings on my mac) the hotspot connection immediately worked. It seemed the wifi connection was taking priority, even though the internet was not working through wifi, and prevening a connection to the hotspot. Turning off wifi so I was only connected to one network (the hotspot) worked for me.

Thank you for sharing that with us @c781.



dalberts
I'm a Participant Level 3

I have

ltemobile.apn {currently active}

fido-core-appl1.apn

internet.fido.ca

isp.fido.apn

sp.mts

Hello again,

 

  Thank you for the additional information. While internet.fido.ca and isp.fido.apn might still work, they are no longer the official APNs for Fido (see here). However, they are still found as Fido APNs on numerous sites. One APN not found on Fido's APN & MMS page is the one for their LTE tethering: ltedata.apn. It's essentially the same as ltemobile.apn except without the MMS settings and the replacement of 'dun' for 'internet & MMS' as APN type.

 

  Even if isp.fido.apn is still a valid APN for Fido non-LTE tethering, it appears that OnePlus has incorrect settings for it since you note it does not include 'dun' in the APN type.

 

  If you are unable to add or edit APNs, I still think your best option would be to contact OnePlus to request they update their APN database on their devices.

 

Hope this helps 😀

 

Cheers

 


dalberts
I'm a Participant Level 3

Yeah I'm locked out of modifying APN's via the UI.

 

I went ahead and downloaded the APN config file from my phone and it has the ltedata.apn in there for fido but doesn't show up in the list. 

 

I missed that ltedata is under cityphone no clue why that shows up in the lists. People in the oneplus forums are saying that the list might be coming from the sim card itself and not using the local config file.

 

Hello again,

 

 


@dalberts wrote:..I went ahead and downloaded the APN config file from my phone and it has the ltedata.apn in there for fido but doesn't show up in the list. 

  Is that Fido's APN? I think it might have to do with the Mobile Country Codes (MCC) and Mobile Network Codes (MNC). Fido's MCC and MNC are 302 and 370, respectively (see here). Other providers may call their APNs similar (or the same) names as Fido's, but if the MCC/MNC are not for Fido, it would not have configured that APN.

 

  At boot time, Android determines the correct network configuration based on the MCC and MNC from the SIM card and automatically configure all network settings (taken from here). While the MCC/MNC come from the SIM, the APNs come from system/etc/apns-conf.xml.

 

  Depending on the file the phone manufacturer used, it's possible those codes are mixed up. For example, this file from 2015 shows MTS Tethering with the same MCC/MNC as Fido. Strangely, that file shows a proper entry for Fido's ltedata.apn. There is also a Cityfone ltedata.apn with Rogers' MCC/MNC. That could be a reason why you are unable to select that APN.

 

  As far as I am aware, the only other solution would be to amend the file yourself. However, that would entail having to root the phone. This community member had a similar situation where his ltemobile.apn did not include MMS settings. They were able to solve their issue by amending the APN settings in the file. That said, if you are not familiar with the process, rooting your phone is not recommended as it could permanently damage your phone if done improperly.

 

Hope this helps 😀

 

Cheers

 


dalberts
I'm a Participant Level 3

I was talking about the apn_config.xml in the system files of the phone https://drive.google.com/file/d/1FoIEXjWwWRUQRW2ExSNVouxOlgCxAwXg/view?usp=sharing

It's got some but not all of the Fido entries in there so I'll have to see if there is a secondary location of a config file for apns. As the settings don't even match up with that, hence the leaning that something from the sim is providing settings vs using that the phone has when no sim is present.

 

Yeah I can't root my phone as that would cause issues playing Pokemon Go

 

I need to come up with a solution other then rooting.

dalberts
I'm a Participant Level 3

Just switched to a OnePlus 7 Pro and have the same issue.

 

Android 9 and up seem to have removed the ability to customize APN's so can't add dun, which I'm pretty sure is what the issue is.

 

I tried using the Fido Tethering APN (isp.fido.apn) but doesn't give me a working network connection in general.

 

None of the 5 default APN's I have available have DUN as a setting so have yet to get tethering to work.

Hello Dalberts,

 

  Welcome to the community!

 

  What APNs are available on your device? I understand you are not able to edit the APNs, however, are you able to add any? My phone has two APNs: ltemobile.apn and ltedata.apn for tethering. If you are able to add APNs, I believe the correct tethering APN is ltedata.apn. The isp.fido.apn might be an older APN which is no longer in use.

 

  One of the problems with non-mainstream devices is that their APN database might not be the most up to date or even accurate. Often, manufacturers not affiliated with certain providers will just find APN settings from the internet rather than from the providers themselves. Some sites might have correct settings, but others merely perpetuate inaccurate information.

 

  If you are unable to add APNs, you might consider contacting OnePlus and request they update the APN database for their devices.

 

Hope this helps 😀

 

Cheers

 


Cawtau
Senior MVP

Hello Sdafasdfsdfas,

 

  Welcome to the community!

 

  Some devices seem to need to have dun in the APN type field in order to have wifi hotspot (or tethering in general) work. DUN stands for dial-up networking. While that terminology might be out-dated, some phone still need it to be specified in the APN. You might consider editing the APN to ensure that your APN type includes default,supl,mms,dun.

 

Hope this helps Smiley

 

Cheers


sdafasdfsdfas
I'm a Contributor Level 1

Thank you for that tip. I added that data in to the APN, saved it and tried it. Unfortunately it did not work. I rebooted and tried again. Still does not work.

 

Are there any other ideas for the LG Phoenix 3 (2017 model)?

 

Thanks in advance for more help.

sdafasdfsdfas
I'm a Contributor Level 1

Other possibly relevant info: it is an AT & T branded phone but as I mentioned, it was unlocked. Everything else about the phone works properly on Fido network (data, calling, mms txt etc).

 

Tether connects device, but does not give internet access to device (aka "connected but no internet") 

Hey sdafasdfsdfas!

 

Not too sure if it would change anything, but, have you tried a factory reset of the device?

 

I can't say I know what might be causing this, I wasn't able to find too much about this myself, but, I am wondering if it's possible that this may be something that can be blocked by AT&T. 

 

@Community, Does anyone have any info/ideas?



sdafasdfsdfas
I'm a Contributor Level 1

Thank you for the idea -- I am going to hold off on that route for a moment because the phone is essentially new out of the box and I have taken steps to get the phone working with data on Fido (adding APN and overriding AT&T in Android settings.db to enable tethering).

 

It would be great to know what solution has actually worked for this issue from Fido's point of view. Judging by the posts on this topic, it seems there are others who had the issue but it never was resolved in the threads.

Hey @sdafasdfsdfas,

 

Which APN do you have set up on your phone, is it ltemonbile.apn? 

 

Can you replace it with with fido-core-appl1.apn and let us know if that changes anything in terms of tethering?

 

 



sdafasdfsdfas
I'm a Contributor Level 1

Yes, I had it set as ltemobile.apn. I also tried fido-core-appl1.apn before but did not mention that in my original post. fido-core-appl1.apn did not work then ewither. I tried it again now just to be sure (and even tried it with adding in default,supl,mms,dun too) and the same issue is there "conneced, no internet"

Hey @sdafasdfsdfas

 

Let's check your account to see if you have any restriction that would stop you from using mobile hotspot.

I'm sending you a PM now. Talk to you soon Smiley

 

 

 



sdafasdfsdfas
I'm a Contributor Level 1

Ok great - I don't think there are any restrictions on my account as I have had this account for 15+years in good standing (with data).

 

I have not seen the PM from you yet but I will keep checking. Thanks

sdafasdfsdfas
I'm a Contributor Level 1

After DMs with forum support staff and no further solutions on that front, they directed me to FIdo support.

 

Fido support (on chat) was pretty brief on the topic: "If it is not a Fido device, wqe can not provide support"

 

So even though this phone has no problem with tehering on other networks (tested at phone shop with other SIM cards, it is somehow not compatible with the Fido network.

 

To me, this is an issue with the settings on the Fido network not an issue with the phone. It is unfortunately not something Fido has plans to correct.

 

I am just closing the loop for any of you who have this phone and who had hopes of tethering on Fido network. It will not work, look elsewhere for a provider if you require this (basic) function.

Hey @sdafasdfsdfas

 

Thanks for the update Smiley

 

I know it's not ideal but the fact is that, as much as we would like to be able to tell you otherwise, we don't have a way to guarantee that any services will work on a non-fido phone, and, that the support that we can offer non-Fido phones is limited. That said, we'd hate to lose you over this. There may still be things that we haven't tried yet. Have you given a factory reset of your device a try to see if that changes anything?

 

Keep us posted!