Showing results for 
Search instead for 
Did you mean: 

Can't receive and send MMS on Google Pixel 2

I'm a participant level 3
I'm a participant level 3

I bought this phone last month and have been had this problem. Help me please


Community Manager
Community Manager

Hey @caiachuang,


Welcome to the Community Smiley


Did you get your device through us? If not, did you already set up the MMS APNs on your phone as follows:


MMS (Picture & Video Messaging Settings):

More info on this here.


Let us know Smiley

I'm a participant level 3
I'm a participant level 3

Hi @FidoClaudia 


I bought it from Bestbuy and it is Fido's unlocked phone.

I set the APN which you mentioned but it's still not working.

I also find out I only can receive and send MMS with my data on and have to turn off WI-Fi.

Thank you for helping.

Thanks for the details @caiachuang!

That's right, in order to send an MMS, you need to use the Fido mobile data. It's possible to send them through Wi-Fi only if you're using a messaging app that needs data to work.  

Are you able to send an MMS when you're using mobile data?

I'm a participant level 3
I'm a participant level 3

Hi @FidoManuel

Yes, I only can send and receive MMS when I use mobile data.

But I didn't have the same problem when I use HTC phone with only WI-Fi on.

Hello Caiachuang,


  Welcome to the community!


  Are you sure your data wasn't enabled when your HTC phone was connected to Wifi? Are you sure you were sending MMS and not using a third party messaging app?


  As FidoManuel noted above, it is not possible to send/receive MMS via Wifi. Data must be enabled for it to work. Note that you do not need a data plan to send/receive MMS (unless roaming), however, data needs to be enabled.


Hope this helps Smiley



I'm a participant level 3
I'm a participant level 3

I am sure I wasn't use the third party and the data was off. I went to Fido they told me they change the setting of sending MMS which needs data on.

I'm a participant level 1
I'm a participant level 1

For anyone having this issue, I resolved mine by:


1) make sure data is on 

2) set your texting app to auto retrieve MMS messages

3)turn off data saver that might be inhibiting your texting app's functionality

3) MOST IMPORTANT: in the APN settings, under APN protocol,  select ipv4.  When mine is either set to ipv4/ipv6 or ipv6,  I have the exact symptoms mentioned above.  The second I switch back to ipv4, my MMS messages send and receive instantly!


Hope this helps

Hey Curtisy! 


Welcome to the Community! 


Thanks for sharing. Smiley That info will definitey help out everyone here!