All the incoming call display "No caller ID(unknown)" on my iphone.

All the incoming call display "No caller ID(unknown)" on my iphone.

All the incoming call display "No caller ID(unknown)" on my iphone.

SOLVED
I'm a Participant Level 3

All the incoming call display "No caller ID(unknown)" on my iphone.

All my incoming call display "No caller ID"(unknown) on my iphone. Even the callers are actually on my contact list and they didn't set up "don't show number ". They have no problem when they call other people . I thought that was my Iphone7's problem. But found out it might be Fido's issue. I contacted with Fido online chatting ,they reset my internet and I restart my phone as well. However,It didn't change anything . I have been using the same plan for 3 years but I hadn't had this issue before .Is there any solution I can solve the problem? 

 

Accepted Solution

Re: All the incoming call display "No caller ID(unknown)" on my i

Solved by Senior MVP Senior MVP

Hello Lauren2788,

 

  Since you previously mentioned that you've had the same plan for 3 years, it sounds like you have the Tablet plan. Is that correct? When that plan was introduced, it allowed for talk and text on a pay per use basis. However, that plan was intended for tablet data use. As far as I am aware, they have recently removed that functionality from that plan. Are you able to still make or receive calls even though there is no caller ID?

 

  Since that plan is not intended for calling or texting, it would not have call display. That could explain why you're not getting the caller IDs.

 

  If you have one of the newer Data and Text plans, they are also not intended for calling. As such, it would also not have call display.

 

Hope this helps 😀

 

Cheers

 

View solution in context
6 REPLIES 6
I'm a Participant Level 3

Hi ! there,

I just found a solution online from other telecom .Does fido have the same setting online which I can set up ? Because I can't find in my account .

Need a solution please , thank you !

dd.JPG

Hello again,

 

  Fido's plans with Talk do include Call Display. However, since the other plans are not intended for voice calls, I don't think that service is available on data-only plans.

 

Hope this helps 😀

 

Cheers

 


I'm a Participant Level 3

Hi there ,

All my incoming still display "No caller ID"(unknown) on my iphone,all of them . Even though I just change a new phone and the version is the latest .

It has been almost a year . And the problem is not from the device .Is it because I'm using data only plan? I need your technical support please .I can't see anying caller number . Thank you .

Hello Lauren2788,

 

  Since you previously mentioned that you've had the same plan for 3 years, it sounds like you have the Tablet plan. Is that correct? When that plan was introduced, it allowed for talk and text on a pay per use basis. However, that plan was intended for tablet data use. As far as I am aware, they have recently removed that functionality from that plan. Are you able to still make or receive calls even though there is no caller ID?

 

  Since that plan is not intended for calling or texting, it would not have call display. That could explain why you're not getting the caller IDs.

 

  If you have one of the newer Data and Text plans, they are also not intended for calling. As such, it would also not have call display.

 

Hope this helps 😀

 

Cheers

 


I'm a Participant Level 3

Hi Cawtau,

Thank you so much for the reply . Since they changed the plan so I guess just like you said, it cause this problem.

It does help solving my confusion .Thank you so much again ! Stay safe.

 

Moderator

Hi @Lauren2788

 

That is definitely odd. Sad

Are your carrier settings updated to the latest version?

You can verify that by going to Settings > General > About.

Make sure you're using Wi-Fi, when you do that.

If an update is available, you'll see the option to update your carrier settings.

 

Should that not be the cause, please reach out to us again and let us know, so we can look into it further!