Showing results for 
Search instead for 
Did you mean: 

Website crashes for my account

I'm a participant level 2
I'm a participant level 2

Hi , every time I tried to made change on my account: price plan change , SIM card change or hup or add a line  , the website would crash on my account, same result on different laptop or iPad. And no problem when I logged into my friend account, no issues at all . The page just went blank. 
Thank you 


I'm a participant level 2
I'm a participant level 2

Hi FidoSaad , 

1- I tried from my phone , not working 

2- different browser - safari/ google chrome / cleared caches - not working

3- different laptop - same result 

4- went to my brother house and use his laptop- samething

Issues: not able to change plan, add a line or sim swap-- brings me to a blank page or loading forever


if I repeat all these step with my friends login --- no problem * able to order a phone ( ordered one last week) 


Clearly is my account 




Hey @Kk88!


I suggest that you contact customer service for this issue. We will need to investigate further if the problem comes from your account. 


Visit our Contact Us page for all the possible ways to reach out or we can send you a PM from here.


Let us know!

I'm a participant level 2
I'm a participant level 2

Hi Vanessa , 


I called in last time to activate a line and they said my account was up to date. At first i thought the credit check didnt pass , but they said i was able to add extra line. Which department should i contact because i ordered two phone using my friend login and it gone through, im sure there some issues my account.

Thank you for the details! 


We've not heard of any issues on that would prevent you from making changes online. That said, I'll send you a PM shortly so we can look into it with you. 😊

Former Moderator
Former Moderator

Hey there @Kk88


I'm sorry to hear that you're unable to manage your account on


A few we'd like to confirm:

  1. Are you able to access and manage your account on the Fido mobile app?
  2. Have you had the chance to try a different web browser to sign in?
  3. You can also try clearing the cache and cookies of your browsers.

Let us know!