Trouble Sending Pics by MMS on a OnePlus 6

Trouble Sending Pics by MMS on a OnePlus 6

Trouble Sending Pics by MMS on a OnePlus 6

SOLVED
Dark_Turban
I'm a Contributor Level 1

Trouble Sending Pics by MMS on a OnePlus 6

Hi:

 

So I have a OnePlus 6 which is a great phone and works fine on Fido's network, save one thing - I can't send phone pics via MMS.

 

Chatted with Fido and they reset me on the network. Checked my APN settings (https://www.fido.ca/consumer/content/configure-unlocked-device-guide) and reset them and then did a soft reboot on the phone. Still no luck, has anyone had this issue and found the solve?

 

Thanks,

MB

Accepted Solution

Re: Trouble Sending Pics by MMS on a OnePlus 6

Solved by I'm a Contributor Level 1 Dark_Turban

So I seemed to have solved my own problem! I was set up on the tethering APN and then changed it to the LTE APN which still wasn't working, but after I set the APN to 'Fido-core-appl1.apn' pics sent and everything worked. That's the ticket for anyone out there. Consider this resolved.

View solution in context
24 REPLIES 24
Tsiow
I'm a Participant Level 1

I know thus is an old thread but for those still searching for solution. 

The fix is turn on the "Developer Option" in setting.  Scroll down to "Networking" and turn on "Mobile Data Always Active "

For the APN.... Stick to the "ltemobile"

Dark_Turban
I'm a Contributor Level 1

So I seemed to have solved my own problem! I was set up on the tethering APN and then changed it to the LTE APN which still wasn't working, but after I set the APN to 'Fido-core-appl1.apn' pics sent and everything worked. That's the ticket for anyone out there. Consider this resolved.

Hello Dark_Turban,

 

  Welcome to the community!

 

  I'm glad you were able to send MMS using the Fido-core-appl1.apn. However, if you set your APN to that APN, your phone won't be able to access the LTE network. You should also be able to send MMS using the ltemobile.apn. Have you verified that the MMS settings are available with that APN? Be sure to include:

 

within the ltemobile.apn and you should be able to both access the LTE network and send MMS.

 

Hope this helps 😀

 

Cheers

 

 


Dark_Turban
I'm a Contributor Level 1

Thanks Cawtau.

 

Actually that was the first setting I tried (my phone was actually automatically set to tethering when I checked the APN settings) but it didn't work, only the second option did.

 

Totally agree that my preferred would be the LTE option as well, but that didn't work as I said.

 

And stranger still, even though I am in developer mode I couldn't change any of the APN settings specifically. I could either reset the list or pick one that's it. Weird.

 

Any more suggests would be most welcome!

Ji
I'm a Participant Level 1
I'm a Participant Level 1

Hey Dark_Turban,

 

I have the exact same phone and problem. When I try to send a MMS in my group chat when I'm on WiFi, my message will stay stuck on "sending" but If I disconnect from my WiFi, the message will then go through.

 

I wonder if this is a phone or Fido issue?

Blackvz
I'm a Participant Level 2

yes, i have the same issues, NEVER had this problem with Telus, Bell or Virgin, only on FIDO..Never heard of disabling wifi to send a picture from within my home.. bizzarer

Hello Ji,

 

  Welcome to the community!

 

  I think the issues are slightly different...

 

  Firstly, MMS -- whether individual messages or group messages -- are sent over the networks and does not get sent via Wifi. To send MMS, your data would have to be enabled. There's an exception, however. Devices with Wifi-calling enabled will have their MMS sent via Wifi since voice and messages are sent via IP to the network gateway (see graphic here). Note that messages sent as MMS are not the same as messages sent via iMessage or via rich communications service (RCS). Those latter message types are sent as data and therefore can be sent via Wifi.

 

  While MMS messages also contain data, the data within a MMS is handled differently and does not count against any data allotments. However, I believe the data sent as iMessages or RCS messages does count against your data allotment.

 

  Since your MMS eventually does get sent once you disconnect from Wifi, it appears your device settings to send MMS are correct. Are you able to send a single MMS without having to disconnect from Wifi? Is your data setting enabled, even when connected to Wifi? It's possible your phone disables all data when connected to Wifi and doesn't even allow MMS data to get sent. What phone do you have? I had phones which allowed me to send MMS while I was connected to Wifi (data also enabled) and I have also had a phone which required me to disconnect from Wifi. All my services have been with Fido so I think it's more phone dependent rather than a network issue.

 

@Dark_Turban Your issue seems to stem from a relatively new security feature introduced in Oreo. Google has removed the ability to edit APNs with that update. Now phones rely on their internal database of APN settings. Unfortunately, that database is not always accurate. Another community member has a similar issue with their unlocked phone (see here). I just checked my phone (Samsung) and I cannot edit the APNs either. However, fortunate for me, Samsung appears to have the correct APN settings in their database.

 

  If your issue is due to an incomplete or inaccurate APN database, you might consider trying the suggestions outlined in that thread (see here).

 

Hope this helps 😀

 

Cheers

 


Hello again,

 

  Something just came to mind...

 

@Dark_Turban Are you able to add a APN? I understand you might not be able to select the APN once added, but are you able to at least add a new one? If so, you might consider trying to add an entirely new APN, say ltemms.apn, for example. Include:

 You might not be able to manually select this APN, however, your phone might be able to select the APN when sending MMS. My rationale for this possible workaround is that prior to the LTE APN, phones used to have two APNs, one for internet and the other for MMS. They were later merged into a single APN. 

 

  Depending on the APN Type listed in the ltemobile.apn on your phone, this workaround may or may not work but it's worth a try if you can add an APN.

 

Hope this helps 😀

 

Cheers

 


Dark_Turban
I'm a Contributor Level 1

Hey @Cawtau thanks for all the keystrokes and brain waves on this issue.

 

So no I cannot add a new APN or edit an old one as pointed out in the security update of Android reply. Funny thing is that both the APN and the LTE are correct based on your config settings so I just changed it back to the LTE APN and I am going to test to see if that works.

 

Read the other thread and I think I have a different problem as the settings are correct it's just that the APN selection didn't want to work. Note I said didn't, will see what future attempts bring.

 

Anyway, thanks again. Wish me luck...

donfano
I'm a Participant Level 3

I also have a similar issue with OnePlus 6 running Android 9.

 

My phone is using ltemobile.apn, and I'm unable to send MMS with the Textra app while connected to the Wi-Fi. I have to disconnect from the Wi-Fi before I can send MMS. There's no problem to receive MMS as the phone automatically disconnects from the Wi-Fi, turns data on to receive MMS, and reconnects to the Wi-Fi when done.

 

If I use the stock messaging app, then I can send and receive MMS while connected to the Wi-Fi... One would think, including me, that the issue must be with/in Textra, but I'm not too sure about that.

 

I decided to try using fido-core-appl1.apn, and lo and behold I was able to send and receive MMS with Textra or the stock app while connected on the Wi-Fi (where the phone obviously follows the drill of disconnecting from the Wi-Fi, turning data on to receive or send MMS, and reconnecting to the Wi-Fi). And the drawback of using this APN is that I lose the LTE feature. It's not really an option!

 

I've already tried to reset the APN settings without seeing any change.

 

@Dark_Turban @Ji do you get this issue when using the stock messaging app or with another app?

Dark_Turban
I'm a Contributor Level 1

So this problem has resurfaced again with a vengeance now that I have updated my OnePlus Six with Android Q.

 

The upside is that I have a definitive on the problem situation, the downside is now tracing it back to exactly what is causing the issue.

 

Pictures will not send via text...when I am at home and connected to my home WiFi network. As soon as I turn off my WiFi here at home the picture via text immediately sends without delay. And I have confirmed that my Fido APN settings are correct so that is not the problem. 

 

(https://forums.fido.ca/t5/General-Support/Fido-s-APN-amp-MMS-Settings/td-p/9161)

 

With that I am left with the following: a) it is a Google Messaging bug; b) it is a OnePlus Six bug; or it is a Fido network issue.

 

Would be great if someone from Fido could weigh in so that I can trace the problem back to its source and chase the right company for a fix.

Dark_Turban
I'm a Contributor Level 1

A further update...

 

Group MMS (just text, no pics) will also not send if I am connected to my home WiFi network.

 

As soon as I turn my phone's Wifi off the group MMS can be sent immediately.

Dark_Turban
I'm a Contributor Level 1

So I wanted to get to the bottom of this since it has happened twice and so I called Fido and talked to Tech Support.

 

This is the official answer.

 

MMS functionality will never work if both means of connectivity on a phone (wifi and cellular) are on and active at the same time when a group or picture message is being sent. A phone's wifi always has to be off for MMS to be used as it has to access the cell network and can't do so if the device detects WiFi.

 

I actually pushed back to verify that this is really how the technology works as I had been using the Fido Default APN (fido-core-appl1.apn) to send MMS messages on this phone (with both cell and wifi active on my phone) prior to updating to Android Q. They confirmed saying that they can't do it on their phone either.

 

Would love it if a Fido guru could chime in and confirm. Is this really how things are supposed to work???!

Dark_Turban
I'm a Contributor Level 1

But the saga still continues! I actually did not receive the straight goods from Fido on what is really happening here.

 

So my friend in Ontario who is a Rogers cell and internet customer just sent me a pic...via MMS... from his OnePlus Six Pro...with his WiFi still on...successfully!

 

Right after that I went back to my phone switched over from the Fido LTE APN to the Fido Default APN and tried it again...with the WiFi on and active...and now it works again too!

 

For those confused this is the same work around that I used back when I first started this thread last May. Never solved it, just found a work around. Anyway the issue came back again with the update to Android Q and now the work around works again. Thankfully.

 

So....

 

Care to weigh in Fido as to what is going on here? For real this time? On the record?

donfano
I'm a Participant Level 3

I just resolved my problem by using the settings for "Fido LTE 4G" at https://www.4gapn.com/ca/en/fido

 

The real difference seems to be the MMS proxy setting apart from the APN protocols...

 

NameFido LTEFido LTE 2
APNltemobile.apnltemobile.apn
ProxyNot setNot set
PortNot setNot set
UsernameNot setNot set
PasswordNot setNot set
ServerNot setNot set
MMSChttp://mms.fido.cahttp://mms.fido.ca
MMS proxy205.151.11.13mmsproxy.fido.ca
MMS port8080
MCC302302
MNC370370
Authentication typeNot setNot set
APN typedefault,supl,mmsdefault,mms,supl
APN protocolIPv4/IPv6IPv4
APN roaming protocolIPv4/IPv6IPv4
BearerUnspecifiedUnspecified

 

Dark_Turban
I'm a Contributor Level 1

Interesting!

 

Hey do you mind describing how you did that? I have my handset in Dev mode and I can't edit or manually add anything APN wise.

 

Can only choose from the APN list I already have on the phone and each of the individual APN settings are greyed out.

 

Thanks

donfano
I'm a Participant Level 3

There is a "+" sign to allow me to add a new APN, and I can edit any of the existing APNs by tapping on the name

Screenshot_20191224-125727.jpg

 

Blackvz
I'm a Participant Level 2

Darn... tried it, stillcan't send pictures ..wifi on or off.. through mms.. very frustrating..

Dark_Turban
I'm a Contributor Level 1

Do you have a OnePlus Six? Because I found exactly what is causing it and the solve is not fun, so I am still living with it as hit and miss.

Deangus
I'm a Participant Level 2

I'm using a Oneplus 5T.  And I've never had much of an issue until yesterday morning.  Went to bed and was able to send/receive MMS messages without issue.  First thing in the morning I noticed MMS waiting to download alerts and was unable to download any MMS at all.

 

Spent the day off and (many times) on with tech support and got no further ahead.  From my own trouble shooting I found that:

1. on the ltemobile.apn I was only able to send/receive MMS to/from another Android phone.

2. on the core apn I was able to send/receive MMS to/from iPhones as well.

 

Not happy with the idea of having to keep switching between lte and 3G to send/recieve MMS but was told that since it's not a FIDO phone there was nothing further that could be done.

 

Of note: Had done no firmware/app updates between working/not working.  Tried clearing cache and rebooting.  No luck.