Trouble Sending Pics by MMS on a OnePlus 6

Reply
I'm a Participant Level 3 Dark_Turban
I'm a Participant Level 3

Trouble Sending Pics by MMS on a OnePlus 6

Hi:

 

So I have a OnePlus 6 which is a great phone and works fine on Fido's network, save one thing - I can't send phone pics via MMS.

 

Chatted with Fido and they reset me on the network. Checked my APN settings (https://www.fido.ca/consumer/content/configure-unlocked-device-guide) and reset them and then did a soft reboot on the phone. Still no luck, has anyone had this issue and found the solve?

 

Thanks,

MB

Accepted Solution

Re: Trouble Sending Pics by MMS on a OnePlus 6

So I seemed to have solved my own problem! I was set up on the tethering APN and then changed it to the LTE APN which still wasn't working, but after I set the APN to 'Fido-core-appl1.apn' pics sent and everything worked. That's the ticket for anyone out there. Consider this resolved.

View solution in context
Flag this to a Moderator
Message 1 of 9
239 Views
I'm a Participant Level 3 Dark_Turban
I'm a Participant Level 3
Solution

Re: Trouble Sending Pics by MMS on a OnePlus 6

So I seemed to have solved my own problem! I was set up on the tethering APN and then changed it to the LTE APN which still wasn't working, but after I set the APN to 'Fido-core-appl1.apn' pics sent and everything worked. That's the ticket for anyone out there. Consider this resolved.

Flag this to a Moderator
Message 2 of 9
234 Views
MVP
MVP

Re: Trouble Sending Pics by MMS on a OnePlus 6

Hello Dark_Turban,

 

  Welcome to the community!

 

  I'm glad you were able to send MMS using the Fido-core-appl1.apn. However, if you set your APN to that APN, your phone won't be able to access the LTE network. You should also be able to send MMS using the ltemobile.apn. Have you verified that the MMS settings are available with that APN? Be sure to include:

 

within the ltemobile.apn and you should be able to both access the LTE network and send MMS.

 

Hope this helps 😀

 

Cheers

 

 



Flag this to a Moderator
Message 3 of 9
226 Views
I'm a Participant Level 3 Dark_Turban
I'm a Participant Level 3

Re: Trouble Sending Pics by MMS on a OnePlus 6

Thanks Cawtau.

 

Actually that was the first setting I tried (my phone was actually automatically set to tethering when I checked the APN settings) but it didn't work, only the second option did.

 

Totally agree that my preferred would be the LTE option as well, but that didn't work as I said.

 

And stranger still, even though I am in developer mode I couldn't change any of the APN settings specifically. I could either reset the list or pick one that's it. Weird.

 

Any more suggests would be most welcome!

Flag this to a Moderator
Message 4 of 9
202 Views
I'm a Participant Level 1 Ji
I'm a Participant Level 1

Re: Trouble Sending Pics by MMS on a OnePlus 6

Hey Dark_Turban,

 

I have the exact same phone and problem. When I try to send a MMS in my group chat when I'm on WiFi, my message will stay stuck on "sending" but If I disconnect from my WiFi, the message will then go through.

 

I wonder if this is a phone or Fido issue?

Flag this to a Moderator
Message 5 of 9
175 Views
I'm a Participant Level 3 Dark_Turban
I'm a Participant Level 3

Re: Trouble Sending Pics by MMS on a OnePlus 6

Good question, hopefully someone else weighs in because I don't know. I have tried the settings above with individual recipients but not in a group messages, will have to test that next. What surprises me in the APN settings is that I can't edit them on my 6, even when I try to input a new APN - I can only pick from the Fido presets, otherwise this phone has worked flawlessly on the network.

Flag this to a Moderator
Message 6 of 9
164 Views
MVP
MVP

Re: Trouble Sending Pics by MMS on a OnePlus 6

Hello Ji,

 

  Welcome to the community!

 

  I think the issues are slightly different...

 

  Firstly, MMS -- whether individual messages or group messages -- are sent over the networks and does not get sent via Wifi. To send MMS, your data would have to be enabled. There's an exception, however. Devices with Wifi-calling enabled will have their MMS sent via Wifi since voice and messages are sent via IP to the network gateway (see graphic here). Note that messages sent as MMS are not the same as messages sent via iMessage or via rich communications service (RCS). Those latter message types are sent as data and therefore can be sent via Wifi.

 

  While MMS messages also contain data, the data within a MMS is handled differently and does not count against any data allotments. However, I believe the data sent as iMessages or RCS messages does count against your data allotment.

 

  Since your MMS eventually does get sent once you disconnect from Wifi, it appears your device settings to send MMS are correct. Are you able to send a single MMS without having to disconnect from Wifi? Is your data setting enabled, even when connected to Wifi? It's possible your phone disables all data when connected to Wifi and doesn't even allow MMS data to get sent. What phone do you have? I had phones which allowed me to send MMS while I was connected to Wifi (data also enabled) and I have also had a phone which required me to disconnect from Wifi. All my services have been with Fido so I think it's more phone dependent rather than a network issue.

 

@Dark_Turban Your issue seems to stem from a relatively new security feature introduced in Oreo. Google has removed the ability to edit APNs with that update. Now phones rely on their internal database of APN settings. Unfortunately, that database is not always accurate. Another community member has a similar issue with their unlocked phone (see here). I just checked my phone (Samsung) and I cannot edit the APNs either. However, fortunate for me, Samsung appears to have the correct APN settings in their database.

 

  If your issue is due to an incomplete or inaccurate APN database, you might consider trying the suggestions outlined in that thread (see here).

 

Hope this helps 😀

 

Cheers

 



Flag this to a Moderator
Message 7 of 9
151 Views
Highlighted
MVP
MVP

Re: Trouble Sending Pics by MMS on a OnePlus 6

Hello again,

 

  Something just came to mind...

 

@Dark_Turban Are you able to add a APN? I understand you might not be able to select the APN once added, but are you able to at least add a new one? If so, you might consider trying to add an entirely new APN, say ltemms.apn, for example. Include:

 You might not be able to manually select this APN, however, your phone might be able to select the APN when sending MMS. My rationale for this possible workaround is that prior to the LTE APN, phones used to have two APNs, one for internet and the other for MMS. They were later merged into a single APN. 

 

  Depending on the APN Type listed in the ltemobile.apn on your phone, this workaround may or may not work but it's worth a try if you can add an APN.

 

Hope this helps 😀

 

Cheers

 



Flag this to a Moderator
Message 8 of 9
138 Views
I'm a Participant Level 3 Dark_Turban
I'm a Participant Level 3

Re: Trouble Sending Pics by MMS on a OnePlus 6

Hey @Cawtau thanks for all the keystrokes and brain waves on this issue.

 

So no I cannot add a new APN or edit an old one as pointed out in the security update of Android reply. Funny thing is that both the APN and the LTE are correct based on your config settings so I just changed it back to the LTE APN and I am going to test to see if that works.

 

Read the other thread and I think I have a different problem as the settings are correct it's just that the APN selection didn't want to work. Note I said didn't, will see what future attempts bring.

 

Anyway, thanks again. Wish me luck...

Flag this to a Moderator
Message 9 of 9
103 Views