Fido blocked Live View service from Ring.com?

Fido blocked Live View service from Ring.com?

Fido blocked Live View service from Ring.com?

SOLVED
I'm Qualified Level 1

Fido blocked Live View service from Ring.com?

I have a video doorbell from Ring.com and it seems like my phone always have issues connected to Ring.com for live view. 

 

When I am on local Wifi everything works fine it does not work but when I am on Fido's LTE network.  I did an upload / download speed test on my phone and I am getting upwards of > 30 Mbps for upload and > 20 Mbps for download. 

 

I was wondering if ring.com services are blocked by Fido. Can anyone help?

 

 

 

Accepted Solution

Re: Fido blocked Live View service from Ring.com?

Solved by I'm a Participant Level 1 luhua90

So I just had to deal with this issue as well between a Ring Doorbell Pro and a LG G5. No live view on LTE, worked fine on Wifi. I saw the APN solution online in a few places and followed it copying the fido settings over apart from ipv4 and internet + mms + dun. Original APN (Fido Internet) could not be edited.

 

Managed to create a new one but couldn’t get it to switch over. Apparently the Default tag is pretty important for it to be possible to set the one I made to active. So pretty much the only change I needed was switching ipv4/6 to 4 only. Type was left as “default,mms,supl”, haven’t tested on other devices, but it got my G5 going at least. A bit annoying because my iPhone 7 and a 6S both worked without a hitch, just seems to mess up on Android.

View solution in context
21 REPLIES 21
I'm a Participant Level 1

Just updated "ipv4 and internet + mms + dun" from "ipv4 and internet + mms" in my Samsung S8, works INSTANTLY. 

Thanks! 

I'm a Participant Level 2

I have the problem described in this thread, and need to force my phone to use ipv4. I have actually been in contact with Ring and they have suggested the same.

 

However, I have tried the suggestions in this thread and when I do, the phone loses internet connectivity.  Specifically I have tried this:

 

----------

What you need to to is create a new APN that is exactly the same as the Fido Internet APN with the exception (APN Protocol: "IPv4" instead of "IPv4/IPv6").  Select this Access point as default and live view will work with Ring products.----------

 

My device is a Google Pixel 3.

 

Does anyone have any other suggestios?  Thanks!

Hey there @mexxmann

 

I've moved your post to this thread as it contains the answers to your questions.

 

Restricting your mobile data to IPv4 only may impact your connection to our network. We would advise you to follow up with the app vendor for an updated version that supports IPv6-only networks such as ours.

 

Hope this clarifies, and let us know if you have any questions.



I'm a Participant Level 2

@FidoSaad Thanks. However, the answers are not found on this post as I've tried them and they cause my phone to lose internet connectiivty.

 

I have reached out to the app vendor and while they will eventually fix, there is no immediate fix, so I'm left with using a workaround unfortuantely Sad

 

Thanks for the update @mexxmann

 

We no longer provide or support any workarounds as we've already implemented all the necessary fixes on our network.



Hey @EFTC if I understand correctly your door cam works fine when you are connected to your local WiFi network is it the same local Internet your door cam is connected to? 

 

Can you view it outside your local network meaning from a different Internet connection? If you can't then you have an issue making connection to the cam from outside your network. 

 

I would check your router/modem firewall and see if it being blocked then if you know which port the door cam uses you can port forward that port to the internal IP for the cam.

 

I have cameras all around my home but not a Ring I use a Swann system and I setup a static IP to the system and then use a DDNS for my IP and forward the port to the IP to the system so I can connect to it from outside of the network.



I'm Qualified Level 1

To @Kapable-K

 

Doorbell cam works fine when both the phone and doorbell Cam are connected to the same local internet.

 

I am unable to view it if I use Fido LTE network, yet i can view it when I am using company or other Wifi internet.

 

The weird thing is that while the app say that It has trouble connecting to the doorbell cam when I am on Fido's LTE network, Live view was recorded and stored on the cloud so I can return to the app 5 minutes later and view it offline. I just can't seem to look at Live View when I am on Fido network. 

 

I wonder if it is a phone problem or an app problem as Fido mentioned that Ring.com is not blocked by Fido.

I'm a Contributor Level 1

I had the same problem on my phone and what I did to get it going was to turn off "Automatically select network", the phone then searched for a network and I selected Fido EXT. 

Hello EFTC,

 

  It sounds like others are also having a similar issue to yours (not necessarily with Fido). You might consider amending your APN with:

 

APN type - internet + mms + dun
APN protocol - IPv4/IPv6
APN roaming protocol - IPv4

 

  It seems to have help some others.

 

Hope this helps Smiley

 

Cheers


I'm Qualified Level 1

Thanks for the suggesiton. I read about it in the Rogers forum as well (http://communityforums.rogers.com/t5/Android/No-Video-with-Google-Hangouts-Video-Call-or-Live-Video-...)

 

How do I go about doing amending the settings above? It appeas that the settings are locked and it cannot be changed.

Hello again,

 

  If those setting are locked, have you tried to create a new APN (see here) with the additional settings?

 

Hope this helps Smiley

 

Cheers


I'm a Participant Level 1

So I just had to deal with this issue as well between a Ring Doorbell Pro and a LG G5. No live view on LTE, worked fine on Wifi. I saw the APN solution online in a few places and followed it copying the fido settings over apart from ipv4 and internet + mms + dun. Original APN (Fido Internet) could not be edited.

 

Managed to create a new one but couldn’t get it to switch over. Apparently the Default tag is pretty important for it to be possible to set the one I made to active. So pretty much the only change I needed was switching ipv4/6 to 4 only. Type was left as “default,mms,supl”, haven’t tested on other devices, but it got my G5 going at least. A bit annoying because my iPhone 7 and a 6S both worked without a hitch, just seems to mess up on Android.

I'm Qualified Level 1

It works.  Thank you all for your help. 

 

Finally it works!!

I'm a Participant Level 2

So what's the solution exactly? I have the same issue with a Ring Spotlight wired camera.

I'm Qualified Level 1

What you need to to is create a new APN that is exactly the same as the Fido Internet APN with the exception (APN Protocol: "IPv4" instead of "IPv4/IPv6").  Select this Access point as default and live view will work with Ring products.

 

Please note that every time you restart the phone, you will have to reset the default APN to this "new" one. 

 

Be sure to leave a 1 or 2 star rating on the Ring app and ask them to enable IPv6 on their app.  Unfortunely this is the only work aorund at this time.

 

Good luck and please let me know if I can be of any assistance.

I'm a Participant Level 2

Thanks. What's the impact of changing the original FIDO APN setup to IPv4 only, so it persists even after restarts? Will anything on my phone stop working? And thanks for the tip with the rating on Ring.

I'm Qualified Level 1

I got so fed up with Ring that I sold my doorbell and went to Nest Hello.  No issues whatsoever and the app and video loads within 1 - 2 seconds whereas it takes Ring ~ 10-15 seconds from app loading to video on-line and you can talk. By that time the person at the door would have concluded that nobody is at the door and the house is empty. 

 

My most recent experience put me to the edge. The video simply won't load after the person pressed the doorbell. After 30 - 40 seconds of waiting, the video finally loads and the couple that rang the door bell have already walked down the driveway, across the sidewalk, up the driveway and 10 steps to the door to my neighbor's house.  

Thanks for the update, EFTC!



@EFTC if it works on WiFi sounds like the app is working fine I could be wrong you can try contacting Ring and see what they say. 

 

Try disabling LTE on your phone and see if it will work with just the 3g connecting, I won't rule out Fido's LTE just as yet. I myself have been loosing faith in their service.



I'll just open by saying that I am unfamiliar with this service, but if you're specifically using an application to do live viewing, it is possible that you have background data deactivated for it, which makes it so you won't receive notifications if it is not in the foreground, deactivating background data can also sometimes cause issues when tabbing into the application from another app.