Fido Chat Secure Form not going through?

Fido Chat Secure Form not going through?

Fido Chat Secure Form not going through?

I'm a Participant Level 2

Fido Chat Secure Form not going through?

Recently I've tried using Fido's support chat for adding new lines, and everytime I fill out the secure form, the agent tells me they didn't receive it and tells me to try filling it out again. I'm on a mac(m1) and I've tried both Safari & Chrome. Anyone else have this issue or have an idea whats going wrong? Thanks in advance.

3 REPLIES 3
Moderator

Hey @jgrewal1

 

Welcome aboard!

 

The authentication form works on both browsers as far as I know. Can you confirm if you can login on your fido.ca account through both browsers?

 

If you can, I would suggest that you clear cookies and cache to see if that can help you. Also, make sure the browser's not open in private/incognito mode when you are filling out the form.

 

You can also activate new lines and upgrade devices directly through your fido.ca account (given you have access to it) and save on the one-time fee of $45 per line. If you need customer care's assistance, you can always contact us through Social Media channels (Facebook or twitter). We can also send you a private message on the Community!



I'm a Participant Level 1

The authentication form did not work for me 9 out of 10 times.  I have tried different browsers (chrome, edge) and different computeres, and cleared cache.  None of that really guarantee to work.  Sometimes the form worked after submitting the 3rd or 4th time, from the same browser with the exact same setting, but some agents refused to try so many times.

 

Live chat became an extremely frustating experience due to this.  Your custmers had to go through the wait in queue, just to be asked by the agent to go through the queue again, because the authentication form could not submit. 

 

Does fido even acknowledge this as a system issue?  Is this problem being investigated?

Hello @number1

 

Welcome to the community!

 

What kind of problems are you having with the form exactly?