Echo, delayed texts

Echo, delayed texts

Echo, delayed texts

I'm a Participant Level 2

Echo, delayed texts

Lately (the few days to a week) we have started hearing an echo when talking to someone on the phone.  The other party says things sound fine, but we hear our own voice echoing back to us.  This is on every call, regardless of who we're calling.  It doesn't matter where we are calling from, or whether we are using a bluetooth headset or not.  And it's happening on multiple phones in the family (iPhone, LG, and Samsung devices), so I doubt it's hardware.

 

Also, SMS messages to/from these devices are often delayed by several minutes or even an hour or more.

 

Completely powering off the devices and restarting them makes no difference.

 

The only thing they all have in common is Fido.  Could these symptoms be caused by a congested network?

 

 

 ***Edited to add labels***

5 REPLIES 5
Senior MVP

Hello Morbazz,

 

   Perhaps this site might help with cancelling the echo. Some phones might call it different things: noise suppression, noise reduction... If enabled, try disabling. If disabled, try enabling.

 

  I admit it's a little strange having all of your phones affected at once, however, it's worth a try.

 

Hope this helps Smiley

 

Cheers


Hey @morbazz !

 

Just wanted to check in with you since this thread dates back a little while. Did @Cawtau 's suggestion help? Are you still experiencing this echo?

 

Keep us posted!



Former Moderator

Hi @morbazz!

 

That's definitely odd. We did have a text messaging issue, but it has been resolved. I'll need a few more details to look into the echo issue.

 

Where in Canada are you located?



I'm a Participant Level 2

We are in Victoria BC

@morbazz Thanks!

 

We don't have any alerts about issues with the network in Victoria BC. On what network mode are your phones (2G/3G/LTE)?