Data and WiFi off-internet access still working

Reply
Highlighted
I'm Helpful Level 1
I'm Helpful Level 1

Data and WiFi off-internet access still working

Hello everyone!

I usually use wifi when I'm home and only turn on my data when I leave the house. I was typing a message on WhatsApp before I realized I didn't turn on data, but when I hit Send the message still went through. I also received replies. 

Double checked to see that both wifi and data were off..  went on Google and was able to perform a search no problem.

Is this happening to anyone else?

 

On another note.... I hope everyone stays safe and if you have to head out make sure to practice social distancing and remind others around you if they aren't doing the same 😊

Accepted Solution

Re: Data and WiFi off-internet access still working

@KAPABLE-K thanks for the screenshots! My screen definitely looks similar to yours with the signal bar X and toggle is off for mobile data.

The links given by @Cawtau show that I'm not the only one and is a known issue for many with Pixels.

Thank you both for your input and assistance!

Very much appreciated Smiley

View solution in context
Flag this to a Moderator
Message 1 of 7
353 Views
Highlighted

Re: Data and WiFi off-internet access still working

Hello @charalique,

 

What is the make and model of the phone you are using and how do you normally turn off your mobile data?



Flag this to a Moderator
Message 2 of 7
349 Views
Highlighted
I'm Helpful Level 1
I'm Helpful Level 1

Re: Data and WiFi off-internet access still working

Hello @KAPABLE-K !

 

I have a Pixel 3A and I usually turn both my data and WiFi settings on/off by swiping down on the settings menu at the top of my screen. It does confirm by saying under the icon "Mobile data off". There is no confirmation for the wifi, but both icons are either grey when off or blue when on

Flag this to a Moderator
Message 3 of 7
345 Views
Highlighted

Re: Data and WiFi off-internet access still working

Hello @charalique,

 

These screenshots are from my Pixel 3 XL the layout should be the same as your 3A.

 

When you disable the data as indicated at 1 does your signal bar status look like it does at 2?

pixel data icon.jpg

 

If it does not then your data is not being disabled, you might want to go to settings-> network and internet-> mobile network->  then toggle mobile data as indicated at 3.

 

pixel data toggle.jpg

 

 



Flag this to a Moderator
Message 4 of 7
337 Views
Highlighted
Senior MVP Senior MVP
Senior MVP

Re: Data and WiFi off-internet access still working

Hello Charalique,

 

  Apparently, the issue you're facing is fairly common (see here and here). While I haven't found a definitive solution, some have suggested that a setting in Developer mode may be the culprit. In Developer mode, there is a setting: Mobile data always active. Some have found that the Android 10 update might have enabled that setting by default. There seem to be mixed reports as to whether disabling that setting helps the situation or not.

 

  Since it appears to be an issue with the OS for the device(s), you might consider contacting Google for support or additional information.

 

Hope this helps 😀

 

Cheers

 


Flag this to a Moderator
Message 5 of 7
322 Views
Highlighted
I'm Helpful Level 1
I'm Helpful Level 1
Solution

Re: Data and WiFi off-internet access still working

@KAPABLE-K thanks for the screenshots! My screen definitely looks similar to yours with the signal bar X and toggle is off for mobile data.

The links given by @Cawtau show that I'm not the only one and is a known issue for many with Pixels.

Thank you both for your input and assistance!

Very much appreciated Smiley

Flag this to a Moderator
Message 6 of 7
316 Views
Highlighted

Re: Data and WiFi off-internet access still working

Hey @charalique,

 

I know a while back an update was breaking the data connection but that should have been resolved. Sometimes I find you get bugs like these after a major update and I always recommend a factory reset.

 

Before you do a factory reset you can try disabling mobile data always active in the developer settings, see here on how to enable developer settings.

 

You can also try doing a network reset to see if it helps before resorting to a full factory reset.

 

If you do go ahead with the factory reset remember to back up all your data.



Flag this to a Moderator
Message 7 of 7
295 Views