DHCP Issues

Reply
Highlighted
I'm a Contributor Level 1 pasteusername
I'm a Contributor Level 1

DHCP Issues

I have been experiencing this problem for a few months and decided to finally dig in and figure it out.

 

Issue: Router loses its ip address.  DHCP requests go unanswered.  

 

Workaround: Unplug the router from the modem, plug it back in.  DHCP then renews successfully.  Not an ideal workaround.

 

Background:

The Fido router is a toy and is not flexible enough for what I need and want to do and has far too many open ports.  With that being said the modem is configured in bridge mode. I have a EdgeRouter-X serving all my routing needs behind the modem.

 

Findings:

When the EdgeRouter-X is plugged in it broadcasts  (255.255.255.255) a DHCP request. The host 64.71.246.168 answers and gives the router a lease. All is good. Subsequent to the expiration of the lease the router makes a DHCP request. The requests continues to go on until I unplug and plug the router back in as these requests go unanswered.  What I found is that the DHCP server that responds to the DHCP broadcast (64.71.246.168) reponds with an ip address and tells my router to make further requests for leases via 99.239.245.125. So of course my router does what it is supposed to do but no one is home at 99.239.245.125.  The ip is active but it is not responding to DHCP requests.  Now because my router is highly configurable I can tell it to ignore the address supplied by the DHCP server and always make requests to 64.71.246.168 so the problem is solved, until Rogers/Fido make changes that is.

 

Anyone willing to look into this?

 

Cheers!

Flag this to a Moderator
Message 1 of 3
1,073 Views
Moderator
Moderator

Re: DHCP Issues

Thanks for posting @pasteusername !

 

We've reviewed this for you on our end and since the Fido modem is connected to a third party router our support is a little limited in terms of why this is happening and many factors can be involved.

 

That said, are you certain that the Fido modem is set up in Bridge mode? We suggest double-checking and if it's not to set that up. If it is, then this would be something to maybe look into with your third-party modem's manufacturer as there may be an additional setting on that modem that needs to be configured. 

 

Hope this helps out, we really do wish we could provide more info, however, this is outside of our scope as it involves a setup with a non-Fido router. 



Flag this to a Moderator
Message 2 of 3
984 Views
Moderator
Moderator

Re: DHCP Issues

Hey again @pasteusername!

 

We dug a little deeper and I'd like to get some more info for you in order to see if anything can be done to help Smiley

 

I'm sending you a PM, see you there!

 

 



Flag this to a Moderator
Message 3 of 3
932 Views