Showing results for 
Search instead for 
Did you mean: 

cant access my fido account from the android app

I'm a participant level 2
I'm a participant level 2

i'm new to fido, so i bought a sim card 3 days ago and it works all fine. However when i want to login with the android app it says "you haven't linked any account to your profile. Please visit to link your account(s)" and when i visit the website i can login into my account but i can't see any information about my subscription (how many data left etc ...).
i contacted the support but they didn't resolved it!
anyone can help please?


I'm a participant level 1
I'm a participant level 1

Having the same issue, 
Using a Google PIxel 2 (android device). The minute I open the Fido Myaccount app, and click Sign in it says you haven't linked your account visit 
Where ofcourse I am able to log in through the web portal just tno through the app. TRied clearing cache, uninstalling, reinstalling the app, restarting the phone , everythinig in the manual. Still no luck ! 
Clearly frustrating as I just moved over to Fido and the first day is a disappointment in itself ! Wonder what lies ahead. 

Appreciate if anyone can help. 

Hey @NT88  We're sorry to read about your first impression, that's certainly not the way we want you to feel!
You can contact us through one of our channels and we'll be happy to help with your Fido MyAccount app. 

Former Moderator
Former Moderator

Hi there @Youva7


That shouldn't be the case 


Have you tried reinstalling the app? 

I'm a participant level 2
I'm a participant level 2

Hi @FidoStephane thank you for your response.

So yes i tried reinstalling the app but nothing happend so i gave up lol ... but many days later, i tried to login and it worked!

So the problem is resolved Smiley