Showing results for 
Search instead for 
Did you mean: 

The fido my account app on my phone not working

I'm a participant level 1
I'm a participant level 1

is there anyone else having this problem i can not log into the app at all and its been 2 weeks now i have called fido support and tried uninstallling and reinstalling the app countless times. but nothing works and no one can give me an answer as to what the problem is. this has happened ever since the update for the app. please help if anyone can 


I'm a participant level 1
I'm a participant level 1

Same here, no support. Switch to Lucky Mobile imminent. 

I'm a participant level 2
I'm a participant level 2

I'm getting a similar issue as well. I can see the information for my mobile account if I log into the site via Chrome on my phone or on my laptop, but if I attempt to use the app, I get a "No Linked Accounts" message. I have no idea why.


Things I have tried

  • I've uninstalled and reinstalled the application from the Play store with no change in behavior.
  • Rebooted the phone multiple times. No change in behavior.
  • Turned off wifi, cleared cache and storage, and retried. No change in behavior. 
  • Airplane mode with wifi, cleared cache and storage, and retried. No change in behavior. 


The customer support representative stated that they deleted my profile so that I could re-register it in order to correct the issue, but as of this note, my profile remains 36hr after I was told it was deleted. I can't re-register, and I can't use the app, so some of the benefits of the account (e.g. the free data hours accessible via the app) are no longer available to me.  My wife's phone (a Pixel 6a cyrrently financed through Fido) has the same issue. 


How do we correct this?




Going to doesn't accomplish anything, as the account is properly linked there. I can see all of my billing and usage data quite easily through a browser on the same device.


Given that the issue appears on different devices for the same credentials, I'm assuming it's an issue with the profile on the server side with respect to the app, but I can't correct it and it appears that neither can the client service reps. 


All in all, it's very frustrating. I'm just hoping Fido Roam in the US doesn't rely on the app being functional. If it is, I will be without a functional phone on an upcoming trip, which will be problematic. 



Hey @DaveC


It looks like you've gone through most of the troubleshooting steps. In this case, feel free to send us a message on Facebook or Twitter. Our social media team will be happy to help you!

I'm a participant level 1
I'm a participant level 1

I've had the same issue for more than a month.  Gave up and just use the website to look at my account. The 'Thursday deal' stuff is either gone by the time I get email (I'm in the West), or the  majority of the contest winners are from the East, such as Ontario and Quebec. I deleted the app as it no longer works. 

Hey @Sb81, we'll be happy to go over the situation with you.


There are several ways to reach customer service:


 - On the phone (by dialing 611 from your Fido device), you will have a call back option instead of waiting on the line.

- Via live chat on

- By writing us a private message on our social networks (Facebook, Twitter, or Instagram).


Hope to talk to you soon. 

Hi @h3rmitb0i , sorry you are having trouble with the app. If you could provide a bit more information as to, what device you have, if the device software is up to date,  what message you receive when you try to log in, whether you are using your data or Wi-Fi or both to try and log in. That way if one of us has had a similar experience,  someone here may have some good troubleshooting tips. I have the occasional " we've hit a snag" so I try rebooting my samsung device, turning off wifi and try signing in with data only. If that doesn't work, I put airplane mode on and try with Wi-Fi only. If that doesn't work, I try a network reset. Clearing the cache might help also. I found wifi only to work for me just today. Once I was finally able to connect,  I just turned off airplane mode and let both Wi-Fi and data stay on. Not sure which one made the difference but I am now connected and accessing the fido app. I'm sure others have had this issue on occasion and could chime in. Let us know if anything that you try worked for you. Best regards