Fido My Account app asking for e-mail validation

Fido My Account app asking for e-mail validation

Fido My Account app asking for e-mail validation

I'm a Contributor Level 1

Fido My Account app asking for e-mail validation

The My Account app wasn't working so I re-installed it and now the app is saying my e-mail needs to be verified when it was working hours ago. I checked my e-mails too and none of the ones sent by Fido had any sort of confirmation link. Anyone deal with any similar issues?

Accepted Solution

Re: Fido My Account app asking for e-mail validation

Solved by Moderator


Hi everyone,


If you're experiencing this and you've registered to My Account on or after December 6, 2017, please note that we're aware of it and currently looking for a resolution.


Your patience is much appreciated Smiley



View solution in context
I'm a Participant Level 1

Hi im still having the same problem for over two weeks now. Is there anyone working on it??


Thank you

Hey @NickBol!


Has this been resolved?


Let us all know. Smiley

I'm a Contributor Level 1


-resolved this issue by troubleshooting using a computer browser (rather than a mobile device browser) to:

a) "forgot/reset password"

b) click on email verification

c) login at

-this resulted in a message saying "Email verified", which not getting in the mobile device browser

-finally now able to login via the Fido app

Hey @NickBol


Welcome to the Community ! 


Did you try the troubleshooting steps listed in this thread ? 


If not can you give it a shot and let us know if it helps? 


Also what happens exactly? You get the pop-up for email validation? 



I'm a Participant Level 2

After a few Fido App updates not only is the issue still there but now I am unable to start the Data Bytes feature...when I'm sitting in a Fido LTE zone.


The app has lost even more functionality for me and I don't think I can just be referred to the website this time because I can't find where to activate Data Bytes there.



Hey @Adflau,


We haven't heard back from you. Were you able to access Data Bytes?


Let us know! 

I'm a Participant Level 2

I am still unable to login on fido app its been 4 months now

Let us know what's going on, barbie0288!

I'm a Contributor Level 1

Well better late than never. Finally letting me log on the app with no issues. Will update if any problems occur but so far so good! Should be fine for everyone like me who signed up around the holidays for that 10gb/$60 offer. Thanks!

Moderator (inactive)

Glad to hear it @JBond Happy


Keep us posted if anything happens.

I'm a Participant Level 2

Can confirm that it is working for me as well now. 

Happy that it works now, @SaraB14, and thanks for keeping the Community updated Smiley

I'm a Participant Level 2

Hello, I can see that this issue has been resolved for some but I am also running into the same problem. I cannot log in to my account on the Fido App without the validation pop up. Is this still being fixed?



Moderator (inactive)

Hey @ndrwsrks


Welcome to the Community. 

Did you get a chance to try some of the troubleshooting steps in the beginning of this thread? 


Can you log-in on to see if you're using the same email on both the website and the APP? If it is the same email can you try disabling your Wi-Fi from your phone and checking if you get the same pop-up when trying to connect through the Fido network? 


If you still get the same pop-up, can you try uninstalling the App and downloading it again? 


Keep us posted. Smiley 

I'm a Participant Level 2

Yes I am using the same email for both the website and the app. I have also tried all the troubleshooting steps you have mentioned but am still running into the same issue.

Moderator (inactive)

Hey @ndrwsrks,


Thanks for the infos! Hmm, we'd need to take a closer look at this. I'll send you a PM and we'll continue over there Smiley

Hey barbie0288!


Are you still getting the same error message? 


Let us know if updating the app helps.

Hey @Adflau


Were you able to use the service before? 


Can you also confirm that you're able to log in and see the "Usage" and "Services" tab? 


Let me know Smiley 

I'm a Participant Level 1

I’m still surprised to see that this hasn’t been resolved yet! I’d like to be able to use the app for billing purposes rather than having to check out my bill details on the website all the time. I’m having the same issue and it’s still ongoing. Has Fido ACTUALLY been looking for a resolution? 





We sure are, @mattcharles24. Sorry about the time it's taking to sort things out Sad