Fido My Account app asking for e-mail validation

Fido My Account app asking for e-mail validation

Fido My Account app asking for e-mail validation

SOLVED
JBond
I'm a Contributor Level 1

Fido My Account app asking for e-mail validation

The My Account app wasn't working so I re-installed it and now the app is saying my e-mail needs to be verified when it was working hours ago. I checked my e-mails too and none of the ones sent by Fido had any sort of confirmation link. Anyone deal with any similar issues?

Accepted Solution

Re: Fido My Account app asking for e-mail validation

Solved by Moderator

 

Hi everyone,

 

If you're experiencing this and you've registered to My Account on or after December 6, 2017, please note that we're aware of it and currently looking for a resolution.

 

Your patience is much appreciated Smiley

 

 

View solution in context
88 REPLIES 88
Michaeljmcgill
I'm a Participant Level 1

Resetting my password did not fix the problem.  As far as I can see, it's been 3 months since this issue was initially raised.   That's over 450 working hours.

 

I'm not even angry.  I'm just... disappointed.

I 100% understand your frustration with this @Michaeljmcgill, and our teams are working hard and looking into it!

 

For the moment, you can log in directly on Fido.ca to view your account details, billing, and usage. For usage, you can also dial *3337 directly on your Fido phone! Smiley

 

 



A password reset seems to have fixed the issue for other users.

 

Can you try to reset yours and let us know?



boriscolin
I'm a Participant Level 2

Having the exact same issue. New customer. Can only log in using the Fido website and having the email validation error when trying to log in from the app...

JBond
I'm a Contributor Level 1

Glad I'm not the only one with this problem. Also a new customer. I think the app just needs patching then.

 

Hi everyone,

 

Can you please validate if you registered to My Account on or after December 6, 2017?

 

Thanks!



nahuhh
I'm a Participant Level 2

Dec 22nd here

 

Hi everyone,

 

If you're experiencing this and you've registered to My Account on or after December 6, 2017, please note that we're aware of it and currently looking for a resolution.

 

Your patience is much appreciated Smiley

 

 



rian444
I'm a Participant Level 1

From reading on this website that Fido has been aware of the app problem since December 6.  Since I can’t reach anyone at Fido unless I wait an hour, maybe someone could tell me when the fix will be done. Why don’t you have a call back service like every other company in the world?

Hey rian444!

 

Welcome to the Community! 

 

I wanted to let you know that I moved your post to this thread since it's about the same subject and you can find the info you're looking for here. 

 

I assure you that we're working to get this sorted out as fast as we can. Smiley



DataUsr
I'm a Participant Level 2

Hi FidoAmandaN,

 

Just wondering if there have been any updates on this issue... Please keep us posted when it's solved (or maybe I' missreading the messages on this forum, and there's a later post with the solution which I missed altogether). In either case, any news would be much appreciated.

 

Thanks again,

 

DataUsr

DataUsr
I'm a Participant Level 2

Aha... Found the post suggesting a password reset! Unfortunately, that did not help.

 

FYI, I registered sometime in the 2nd half of Dec 2017.

 

Also, I had not seen the recent replies to this post, and see now that there's been some chatter on this issue the last few days, and that it hasn't yet been resolved, so nevermind my request for update (I thought it'd been radio silence for the last 4 weeks).

 

Looking forward to hearing back when a fix is found!

FidoPamela
Former Moderator

That's definitely odd. Can you confirm that you're able to log in and view all your information while logged in with your email address?

 

 



nahuhh
I'm a Participant Level 2

Same problem, never tried the app before today.

SaryRizk
I'm a Participant Level 1

I have the same problem even if i used 4g only

JBond
I'm a Contributor Level 1

Sadly it's still a problem. The login works on the website but doesn't on the app. Just wanted to play the Flip Game before it ended.

Adflau
I'm a Participant Level 2

Yes I too am having that issue.

I actually have 2 Fido accounts, one works in the app and the other (my main account) asks for validation.  Both work on the website however.

 

I've reinstalled, restarted, I too wonder what's causing it.

FidoMaria
Former Moderator

@Adflau Do you get the same error message if you disconnect from WiFi?



Adflau
I'm a Participant Level 2

Interesting assumption but trying both data connection and wifi was the first thing I checked. 

It makes no difference - uninstall, restart, reinstall, wifi, lte, just a message that requires e-mail validation at fido.ca like the original post.

And everyone here has a valid email address on their Fido.ca account? 

 

Can someone provide a screencapture? 



JBond
I'm a Contributor Level 1

 

 Yeah, same info on both. Works perfectly fine on the website but not the app.

 

 

 

*** Edited to remove personal info ***