Fido IOS app. "Sorry, we've hit a snag..."

Fido IOS app. "Sorry, we've hit a snag..."

Fido IOS app. "Sorry, we've hit a snag..."

josueperez
I'm a Participant Level 2

Fido IOS app. "Sorry, we've hit a snag..."

Looks like I am also being plauged by the Fido app "snag bug". I am a new customer to Fido coming over from Rogers, activated my account 2 days ago.

 

I open the app and I get to the "Get Access Now" screen where I am asked to enter my Fido Mobile number. I enter my number and hit the "Send Me the Code" button. I get the authorization codes via SMS, enter the code and hit the button to contiune. Then I get the following prompts in order "Hmm... sorry, we've hit a snag. Please check back later.", "Session Expired, Please re-login to continue using the MyAccount app.",  "Hmm... sorry, we've hit a snag. Please check back later." and then finally "Sorry, something went wrong Please try using Data Bytes later. 

 

Below is a list of what I have done and the results

- I am able to log in to my account via fido.ca, no problem there

- I am using my email address as the user name to log in on Fido.ca

- I get the error on wifi and on celluar network

- I have uninstalled the app / restarted the phone / installed the app multiple times, still same errors

- I am using the latest verison (as of this post) of the Fido app 3.3.1 from the ios app store

- I am able at times able to log in to the app if I hit the "I dont have a fido number" button on the "Get Access Now" screen. I get the "Authentication Required, we noticed you have a fido number. Please authenticate you account" prompt. But I noticed that it will sometime loop me back to the "Get Access Now" screen before it will actually let me see my acount details. 

-Yesterday I was locked out from getting  authorization codes for 24 hours. Something about me trying to many times to get codes. 

 

I have attached some screen shots below to show the error prompts I get. 

 

IMG_0011.PNGIMG_0012.PNGIMG_0009.PNGIMG_0010.PNGIMG_0013.jpgIMG_0008.PNG

11 REPLIES 11
Cochrane
I'm a Participant Level 1

Also having the same problem on Android. I get the error when entering my activation code.  Have tried it on WiFi and mobile data. Can't uninstall the app because it is installed as a system app.

 

I can log in at fido.ca. If I try to log in to the app with my email address, the app crashes.

Hi there @Cochrane !

 

Welcome to the Community!

 

Have you tried clearing your app's caches and/or reinstalling the app (in your case the app's updates) completely?

 

If that still doesn't work, you'll have to reach our customer service agents so that we can troubleshoot this and open a ticket if required for you. Alternately, we can send you a PM here and further check this out together.



Sarahhh
I'm a Participant Level 2

I'm having the same problems. Same issue for years now; I go through all the app updates and suggestions. I can easily log in to pay my bill and view my plan/usage. As soon as I try to change my plan or update my account info I am asked to log in again, and without fail I get the error message 'sorry, we've hit a snag'. I call in and get asked for my postal code - upon providing all postal codes I've had over the years as a fido customer I am told that they can't verify my identity and refuse to help. There is no option to speak to anyone who can help me. There are no Fido stores near me to go in person. Ive been a loyal customer for almost 6 years. I'm so frustrated. Why is it so difficult to contact you or access my account?!

Hi there @Sarahhh!

 

When you want to change your plan or update your information on the app, you are taken out of the app and redirected to your account on a web browser instead to make the required change. Although this is how it's supposed to be, you shouldn't be getting that message error.

 

That said, if you already have access to your account online, you should be able to update your postal code (from a web browser) before reaching us out. That way, you'll be sure to provide us the right information you have put yourself on your profile for the authentication.

 

From there, there shouldn't be any issue reaching us out for assistance. We'll be able to look into why your app is giving that error out and open a ticket for you if required. Hope this helps!



FidoThomas
Moderator (inactive)

Hey @josueperez,

 

Welcome to the Community!

 

You've indeed found a workaround we sometimes use in the meantime the issue is fixed Smiley

 

Thank you for all the details, it's much appreciated!

 

I'll send you a PM and we'll continue over there. 



hcpoon
I'm a Participant Level 2

I have the exact problem with the Fido My Account app on iOS.  It looks like the formum have had reported this issue for the last year.  I am surprised that this has not been fixed.  I contacted Chat line mobile support and they promised to escate this to the back-end programming department.  Let's hope for a quick fix.

FidoJulien
Moderator (inactive)

Hey @hcpoon

 

Welcome to the community Smiley

 

If a request was sent to have this looked into, you should get things resolved soon.  Just to confirm, did you update your app to the latest version?  If you did, did you try deleting it and installing it again?


Let us know!



hcpoon
I'm a Participant Level 2

I have tried install version 3.3 after reboot the iphone.  I have also uninstall and re-install the app from Apple Appstore.  At this time, I have been lock-out for 24 hours before I can try again.  

FidoThomas
Moderator (inactive)

Thanks for the update @hcpoon! Those are the first step one can try when having this issue, but if that doesn't work then our tech team will fix it Smiley

 

 



TA111
I'm a Participant Level 1

I'm having the same issue on my android app. Any fix for this yet? 

Hey there @TA111

 

Since the above example was impacting a device running IOS (Apple), we would need you to provide more details on your current situation:

 

  1. What is the current App version installed? If not already done, I would suggest updating to the latest Fido app version and OS version on your device as well.
  2. Are you able to log into the Fido mobile app, and at which step/action do you get that error message "Hmm... sorry, we've hit a snag. Please check back later."
  3. Have you had a chance to contact us at these channels for troubleshooting?

Let us know so we can better assist you Smiley