Wifi Calling on S7 Edge - Bought from Costco - Not a FIDO Phone

Wifi Calling on S7 Edge - Bought from Costco - Not a FIDO Phone

Wifi Calling on S7 Edge - Bought from Costco - Not a FIDO Phone

SOLVED
swiftycanada
I'm a Contributor Level 1

Wifi Calling on S7 Edge - Bought from Costco - Not a FIDO Phone

Hi there - I have an S7 Edge I got from Costco that has locked itself to my Fido SIM when I installed it (meaning it reset the phone and put the FIDO apps on it), but there is no option in Phone > Settings to turn on Wifi calling. Can someone please tell me how to get this to work this is Marshmallow 6.01. 

I do have a plan that Fido says is eligible for Wifi but without a phone 'option' to turn it on I am not getting it !

 

 

** Edited to add labels **

Accepted Solution

Re: Wifi Calling on S7 Edge - Bought from Costco - Not a FIDO Phone

Solved by Former Moderator FidoCatherine

Hi there @swiftycanada

 

Since the phone is unlocked, we can't guarantee on our end that the function will work with your handset. 

 

That said, starting today August 11:

Wi-Fi Calling is available on the Samsung Galaxy S7 and Samsung Galaxy S7 Edge!

 

To check whether your phone has it or not, you'll need to verify your handset's Settings menu. 

View solution in context
19 REPLIES 19
AdamBeast
Fido Employee

Here is steps for how to enable Wi-Fi calling on LG device.  

More info can be found here: 

http://www.fido.ca/consumer/content/wifi-calling  

 

 

    1. Select the phone on your phone’s main screen.

 

    1. Select the more in the top-right corner.

 

    1. Select “Call settings”.
      call settings

 

    1. If you’re already registered for Wi-Fi Calling, move the Wi-Fi Calling toggle switch to the ON position, and you’re done! The status bar will display the Wi-Fi Calling icon when Wi-Fi Calling is ready to use.
      Wi-Fi calling Enabled

      Or, if it’s your first time enabling Wi-Fi Calling, click on Wi-Fi Calling. This will bring you to the Wi-Fi Calling page, where you can follow the remaining steps:
      Wi-Fi Calling

 

    1. Click on the link to register for Wi-Fi Calling.

 

    1. Enter your phone number and select “Get Verification Code”. You’ll then receive a text message with your verification code.

 

    1. Enter your verification code and press “Submit”.

 

    1. Accept the Terms and Conditions.

 

    1. Enter your emergency address and press “Continue”.

 

    1. The portal will now display two versions of your emergency address: One version shows your address exactly as you just entered it, and the other is a Canada Post-recommended version of your address. Select the version you want to use (we recommend using Canada Post’s version). Once your address is verified, you’ll receive a text message confirming that your registration is complete.

 

  1. Go back to “Call settings” and then toggle the Wi-Fi Calling switch to the ON position, and you’re done! The status bar will display the Wi-Fi Calling icon when Wi-Fi Calling is ready to use.


KAPABLE-K
MVP

@swiftycanada From what I know Rogers/Fido did not enable WiFi calling on the S7 Edge as yet.

 

These are the only phones that has WiFi calling support.

  • iPhone 5c, 5s, 6, 6 Plus, 6s, 6s Plus or SE with iOS9 (or later) installed
  • LG G4 with Android software version 6.0 (or later) installed


Hi there @swiftycanada

 

Since the phone is unlocked, we can't guarantee on our end that the function will work with your handset. 

 

That said, starting today August 11:

Wi-Fi Calling is available on the Samsung Galaxy S7 and Samsung Galaxy S7 Edge!

 

To check whether your phone has it or not, you'll need to verify your handset's Settings menu. 



swiftycanada
I'm a Contributor Level 1

 


@FidoCatherine wrote:

Hi there @swiftycanada

 

Since the phone is unlocked, we can't guarantee on our end that the function will work with your handset. 

 

That said, starting today August 11:

Wi-Fi Calling is available on the Samsung Galaxy S7 and Samsung Galaxy S7 Edge!

 

To check whether your phone has it or not, you'll need to verify your handset's Settings menu. 



This is good news so how do I update my phone so it gets the service that is now available from you to enable me to get the WIFI calling menu in Call Settings. The person who later posted the link to the LG wifi calling - this is a Samsung phone and not LG so that doesnt help thanks,

You will most likely get an update to your phone which will enable the WiFi calling option.


FidoPierre
Moderator (inactive)

Hey @swiftycanada

 

As KAPABLE-K, mentioned if you're using the most recent updates you would usually have access to the feature. You can take a closer look at the instructions on how to set this up for android devices right here. Smiley 

 

 



swiftycanada
I'm a Contributor Level 1

Hey @FidoPierre - thanks for the reply and for the link which is rather useless to me because as I mentioned in my first post I dont have WIFI Calling as an option under Phone > Settings.

 

So, as you work for Fido, could you please tell me how I request that you push this service to my phone and enable the menu or operating system (Marshmallow 6.0.1) to have the correct 'button' to turn it on. Or is this something that you just expect to happen in the future when you push an android update for instance.

 

Please let me know would you as we are just going around in circles here.

 

Roy

Hey @swiftycanada

 

In this case it is possible that the feature is not available due to the fact that it was not purchased directly from Fido. At this time we are only able to guarantee this function in Fido devices with the most recent upates. 

 

I hope this helps clarify. Smiley 



swiftycanada
I'm a Contributor Level 1

Hi @FidoPierre 

 

I appreciate what you say but that this is seems to be the usual "operator answer" that "we won't help you unless you get the phone from us".   I am not sure if you are aware but the phones that the carriers use in Canada in the Samsung line (at least) are all the same, they are programmed by Samsung to reset when the first SIM card is entered in (even if you have set it up with without being on a network), and then lock to that provider.  This is different to unlocked manufacturers' phones or 'user unlocked'.

So, my phone from Costco is now identical to a phone from Fido as it has the Fido apps loaded on it and it is locked to Fido. If I had bought a Fido phone it would have locked to Fido in the same way.

 

Since I seem to be at an impasse with Fido (as you are a representative) I will need to take a different tack.

 

Since this is now locked to Fido, the level of the Android build is now determined by Fido (and I do NOT have  an Android version with the Wifi Calling options that I can select) so I am headed into a Fido store to see whether anyone has a working S7 Edge or S7 to compare the version of Android builds.

 

Fido's attitude in this respect of saying "sorry, not our fault" was the same when I used an unlocked Blackberry from Rogers which worked perfectly (and is still working on another line) after you guys sorted out your service books on my account after I was told repeatedly that I had a phone that wasnt supported even though you sold an identical model.

 

Pierre, you could so something for me please.

 

Can you (or anyone else watching this thread) please post me a screen shot of the Software Version screen for a Fido supplied S7 or S7 Edge. This will tell me what version Android build you are supplying and support Wifi Calling on.

 

Thanks in advance

Hey @swiftycanada

 

I'm sad to see you feel this way, I assure you that we absolutely do want to help the most we can with this. I'll send you a PM so we can take a closer look together. Smiley 



gabrielboyer
I'm a Participant Level 2

 

 

Actually I got the update today. When i checked yesterday there were no available updates for my phone but today there was one and it enabled wifi calling.

So thank you very much!

 

Have a good day

swiftycanada
I'm a Contributor Level 1

This is what happened with my Costco phone that locked itself to Fido. I didnt get the update till a couple of days ago and now I have the WIFI calling option enabled and working. 

Fido and all the other carriers really dont know their 'asses from their elbows' when it comes to things like this and take the easy way out by saying 'you didnt purchase the phone from us so you are out of luck'.  For people reading the forum who dont know, all 'regular Carrier phones' including those bought at Costco are the same (for Samsung atleast) , they lock to the first SIM card thats installed and install all the carrier bloatware etc so then they become just like a phone purchased from the carrier. If you have an uninstallable Fido app on the phone its a Fido phone !!!

 

Fido and all the other carriers take the easy option and say 'sorry we cannot really support you' because you didnt buy from us rather than look into the real issue like this Android update.  In private email with Support they said that they really didnt know how to help me further. They were very friendly but didn't bother or couldn't check the build of S7 Android required to do this, not just 6.0.1 but the build itself like the version which was included in the recent update.

 

So, I am not sure what happens if you have a Bell/Telus/Roger/Whoever phone that is now unlocked or even a manufacturer unlocked item, how you get updates for WIFI calling but if you get a Costco one and use your Fido sim first of all you should be all set when you get the update to 6.0.1 - it wont happen immediately but keep checking for system updates and dont listen to Fido when they say they cant help. 

 

 

Good luck !

Rami2
I'm a Contributor Level 1

I've had the exact same problem and get the same stock answer from Fido.  It's frustrating, because I have the exact same phone as every other Fido customer with an S7, but mine doesn't get features like Wifi Calling or VoLTE.  I'd really appreciate someone from Fido actually providing an answer, rather than the "Sorry, we can't help you".

FidoManuel
Former Moderator

Hi @Rami2!

 

I'll look into that for you Smiley 
Can you confirm these few details: 

 

- android version that you have

- are you using a Fido device, or an unlocked phone?

- are you getting an error message when trying to enable Wi-Fi calling?



Rami2
I'm a Contributor Level 1

The Android version is 7.0.  It is a phone I bought unlocked from Costco, but is now locked to Fido once I put the Fido sim card in.  Have all of the Fido bloatware installed and can't get rid of it, so as far as I can tell, it's now a Fido device.  I get the message when I put in the verification code that gets texted to me when I attempt to register for WiFi calling.  As for the VoLTE, it does not allow me to make VoLTE calls, even though I have that activated in the settings.  Some technical support would be great . . . I have been trying to deal with this for a few weeks now and seem to just get bumped from person to person, without anyone seeming to know how to solve the problem.

FidoManuel
Former Moderator

Thanks for those details @Rami2, I've replied to your request on another topic, click here.



gabrielboyer
I'm a Participant Level 2

I just bought a samsung S7 edge directly from fido and I don't have the wifi calling option when following the steps in the previous link. 

Wifi calling was a major point in me taking the S7 and even when i called customer service they told me I should have the option already, which is not the case. 

Would it be possible that I have the same problem? If so, could you tell me if you found any solutions to it?

 

Thank you!

Welcome to the community @gabrielboyer! Did you already update to the latest version of Android? Smiley



Hey @gabrielboyer!

 

The update is available to everyone with an S7 device from Fido. Were you able to get it working?