Unlocked Android phone connected to network, but no mobile data

Reply
I'm a Participant Level 1 mkw2016
I'm a Participant Level 1

Unlocked Android phone connected to network, but no mobile data

Hello!

 

I recently purchased an unlocked Lenovo Z6 Pro and with the Fido sim card that I had before in an older phone, I am able to connect to the Fido network with voice (make phone calls), but am unable to connect to the internet.

 

Lenovo Z6 Pro supports:
2G - GSM 850 / 900 / 1800 / 1900

3G - HSDPA 850 / 900 / 1900 / 2100

4G - LTE band 1(2100), 3(1800), 5(850), 7(2600), 8(900), 20(800), 34(2000), 38(2600), 39(1900), 40(2300), 41(2500)

 

Fido network uses the bolded bands, as well as 4G - 12(700) and 4(1700/2100). My previous phone also only supported band 7(2600) and worked fine on LTE, so I am under the assumption the bands are not an issue.

 

 

From https://www.fido.ca/consumer/content/configure-unlocked-device-guide I have tried manually setting the APN with the following (ignoring the MMS settings since I'm only concerned about mobile data):

  • ltemobile.apn (also tried LTEMOBILE.APN)
  • Fido-core-appl1.apn

I have made sure I enabled mobile cellular data, but both still do not work.

 

 

I have tried manually searching for network operators. I actually do not see the Fido 4G option (as I do in my old phone), but I see all other carriers like Rogers, Rogers 4G, Telus 4g, Freedom 4G, etc. I continued to use Auto Select  (which chooses just "Fido").

 

 

I have seen 3g and H icons appear on the mobile connection icons on the top task bar (never LTE or 4G) throughout all my attempts. If I check the SIM status, the settings show:

Network: Fido

Mobile network type: UMTS

Service status: Voice: In service / Data: In service

Mobile network state: Disconnected

 

I am not sure how else to proceed and was wondering if anyone else ever had experienced these issues.

 

Many thanks in advance!

 

Flag this to a Moderator
Message 1 of 3
162 Views
Highlighted
MVP
MVP

Re: Unlocked Android phone connected to network, but no mobile data

Hello Mkw2016,

 

  Welcome to the community!

 

  Are you unable to use data on any network or just can't connect to LTE?

 


@mkw2016 wrote:..
Lenovo Z6 Pro supports:

2G - GSM 850 / 900 / 1800 / 1900

3G - HSDPA 850 / 900 / 1900 / 2100

4G - LTE band 1(2100), 3(1800), 5(850), 7(2600), 8(900), 20(800), 34(2000), 38(2600), 39(1900), 40(2300), 41(2500)...


  You are correct in that the phone has all of the compatible bands for 2G and '3G', but only one band for LTE. While the phone should work on the LTE networks, you should note that coverage is dependent on your location relative to the cellular towers as well as the bands/frequencies used at those towers. You can get an idea of your area cellular towers here. You should also note that the different frequencies differ in their characteristics. For example, the higher frequencies would decay faster than lower frequencies (see graphic here). In addition, different phones may have differences in reception capability.

 

  Since the phone is LTE-capable, it should be using ltemobile.apn

 


@mkw2016 wrote:.. I have tried manually searching for network operators. I actually do not see the Fido 4G option (as I do in my old phone), but I see all other carriers like Rogers, Rogers 4G, Telus 4g, Freedom 4G, etc. I continued to use Auto Select  (which chooses just "Fido")..

  Have you tried to connect to the Rogers 4G network? Fido and Rogers share their networks so either network should work.

 


@mkw2016 wrote:...

I have seen 3g and H icons appear on the mobile connection icons on the top task bar (never LTE or 4G) throughout all my attempts. If I check the SIM status, the settings show:

Network: Fido

Mobile network type: UMTS

Service status: Voice: In service / Data: In service

Mobile network state: Disconnected


  Are you able to use data using the UTMS network? If you're seeing the H, that indicates that your phone is connected to allow a data connection. Were you connected to Wifi when you recorded that information? If yes, that could explain why it states mobile network state is disconnected.

 

Hope this helps 😀

 

Cheers

 

 

 



Flag this to a Moderator
Message 2 of 3
138 Views
I'm Helpful Level 3
I'm Helpful Level 3

Re: Unlocked Android phone connected to network, but no mobile data

I have had this happen a few times a while back. In my case it was somehow related to the SIM card. What I did was power off, remove SIM, re-insert SIM, power up. Don't ask me why, I guess it is just magic. 🤔

Have you ever seen a little red SIM icon up in the top corner? It took me a few weeks when I switched from BELL to FIDO SIM cards to get the UTMS/SIM error problems to go away. Each time I just did the same thing, as described above and eventually my phone became better acquainted with the FIDO network and started to behave normal.

 

Yes I had the UMTS too. And didn't get data connection, but settled in to getting 4G and LTE with data eventually.

 

IT troubleshooter question #1: Did you try unplugging it and plugging it back in?

LOL 🙄

 

in my case it actually worked.

 

🐩

 

 

 

Flag this to a Moderator
Message 3 of 3
93 Views