Samsung Phone Very Annoying Recurring Screen

Samsung Phone Very Annoying Recurring Screen

Samsung Phone Very Annoying Recurring Screen

SOLVED
HannaBanana
I'm a Participant Level 2

Samsung Phone Very Annoying Recurring Screen

Can anyone advise on how to handle the following screen that keeps popping up on my Samsung Note 20

faster richer higher-quality chat on wi-fi or data

It only offers two choices:

Use without chat features or Agree

In researching this, it says that it is changing from SMS or MMS to RCS technology.  But encryption is not improved or fully reliable.  Therefore, I am not confident in Agreeing to this at this time.

 

Does anyone know if they are working to fix this so that either it gives more choices or it stops showing up so often.  Will there be a new update to fix this? 

It really prevents normal use of the phone

Thanks,

Hanna

Accepted Solution

Re: Samsung Phone Very Annoying Recurring Screen

Solved by MVP MVP

Hi @HannaBanana , that pop up window, I believe is from the Samsung messenger app not Fido. You may be able to disable it in the messenger settings. I don't use Samsung messenger so I'm not totally familiar with the app, but if you open your messaging app there should be 3 dots in the top right corner. Tap on that and look for settings. Then look for something about sms or mms and see if it contains an option for rcs. If yes then perhaps it's possible to disable it. 

 

I found this on the Samsung forum, hope it helps. It's referring to going into the device settings. 

 

"Settings--> apps--> messages--> Appear on top - TURN THIS OFF!!! This is what worked for me S21 ultra"

View solution in context
2 REPLIES 2
HannaBanana
I'm a Participant Level 2

Hallelujah, this looks like it worked.  Thank you for going beyond just the Fido realm.  Your expertise and knowledge really shows here, and I will spread that word the Fido gives great service.

Hi @HannaBanana , that pop up window, I believe is from the Samsung messenger app not Fido. You may be able to disable it in the messenger settings. I don't use Samsung messenger so I'm not totally familiar with the app, but if you open your messaging app there should be 3 dots in the top right corner. Tap on that and look for settings. Then look for something about sms or mms and see if it contains an option for rcs. If yes then perhaps it's possible to disable it. 

 

I found this on the Samsung forum, hope it helps. It's referring to going into the device settings. 

 

"Settings--> apps--> messages--> Appear on top - TURN THIS OFF!!! This is what worked for me S21 ultra"