LTE not working on Iphone 6s plus

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

LTE not working on Iphone 6s plus

My phone is iphone 6s plus. I got a plan Fido pulse 3+5gb-BYOP. I can't access my cellular data on my phone. But if they insert the sim card on a different phone it works just fine. I tried to reach fido customer care and apple care, They tried to do several troubleshoot but nothing seems to work. I am not sure what can I do. Please give me a solution. Thanks

Flag this to a Moderator
Message 1 of 2
282 Views
Highlighted
Former Moderator
Former Moderator

Re: LTE not working on Iphone 6s plus

Hey @zissani1

 

That's rather odd, however it seems to be handset related.

 

To clarify, are you able to use the other services such as calling and texting with your iPhone 6s Plus? 

 

Did you purchase the phone yourself or did you buy it through a third party? If it's not a Fido phone, was it unlocked from the previous provider? 

 

If it was bought through a third-party, did you verify that the IMEI of the phone wasn't blacklisted? 

 

Please don't hesitate to include the troubleshooting steps that you took with our technical support and Apple support. That will help us narrow down the issue. Smiley 

 

 



Flag this to a Moderator
Message 2 of 2
260 Views