Internet Connectivity Problem with an HTC S A510b bought Overseas Australia

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Internet Connectivity Problem with an HTC S A510b bought Overseas Australia

Ive had my phone unblocked Phone & Text Works Fine but I cant connect to the Internet with Fido 3G Network as I used to Overseas using a different provider.

When I connect to a Wi-Fi Network it works.

I've gone through all the Features on my phone and I Can't seem to find how to connect to the internet using the Fido 3G Network although it is the one selected under Mobile Network / Network Operator / Search Network

Hopefully someone can help with this Problem ... I called Fido all they did for me was refer me to this Forum.

Thank you

AnnaD

 

 

***Edited to add labels***

Accepted Solution

Re: Internet Connectivity Problem with an HTC S A510b bought Overseas Australia

Hi AnnaD,

 

Welcome to the community!

 

In order to operate on Fido's network, a handset must be compatible with the 1900 MHz and 850 MHz frequencies. Your phone does function on these frequencies, so it should work just fine. 

 

I would suggest checking that you have the correct APN settings in your phone. You can find the settings in this thread.

 

To enter a new APN, go to settings > wireless & networks > mobile networks > access point names. Tap the menu button, then select New APN. Once all the info is entered, click menu > save APN. The primary one should have a bullet next to it (green if Gingerbread OS, blue if ICS or JellyBean OS). Make sure that the bullet is highlighted. 

 

Another thing to check would be that your Data Enabled is checked (this is found in settings > wireless & networks > mobile networks). 

 

If you continue to experience issues after verifying all of the above, I'd suggest turning data roaming on to see if it works (sometimes non-Fido phones need to have data roaming enabled sicne they are not on their home network, but as long as you are connected to our network, you will not incur additional roaming data charges). 

 

Let me know how it goes!

View solution in context
Flag this to a Moderator
Message 1 of 4
1,779 Views
Highlighted
Community Manager
Community Manager
Solution

Re: Internet Connectivity Problem with an HTC S A510b bought Overseas Australia

Hi AnnaD,

 

Welcome to the community!

 

In order to operate on Fido's network, a handset must be compatible with the 1900 MHz and 850 MHz frequencies. Your phone does function on these frequencies, so it should work just fine. 

 

I would suggest checking that you have the correct APN settings in your phone. You can find the settings in this thread.

 

To enter a new APN, go to settings > wireless & networks > mobile networks > access point names. Tap the menu button, then select New APN. Once all the info is entered, click menu > save APN. The primary one should have a bullet next to it (green if Gingerbread OS, blue if ICS or JellyBean OS). Make sure that the bullet is highlighted. 

 

Another thing to check would be that your Data Enabled is checked (this is found in settings > wireless & networks > mobile networks). 

 

If you continue to experience issues after verifying all of the above, I'd suggest turning data roaming on to see if it works (sometimes non-Fido phones need to have data roaming enabled sicne they are not on their home network, but as long as you are connected to our network, you will not incur additional roaming data charges). 

 

Let me know how it goes!



Flag this to a Moderator
Message 2 of 4
1,768 Views
Highlighted
Fido Employee
Fido Employee

Re: Internet Connectivity Problem with an HTC S A510b bought Overseas Australia

Hey AnnaD!

 

I know this is an old post but I thought I would provide some up-to-date information about the APN settings required in order to be able to access the internet/use MMS on Fido's network when using an unlocked device in case anyone else were to have a similar issue. :smileyhappy:

 

The APN settings are the following: 

    • APN: Fido-core-appl1.apn
    • If you have a LTE device, use the following setting: LTEMOBILE.APN

    MMS (Picture & Video Messaging Settings):

Leave the following fields blank: Proxy, Port, User Name, Password, Server. 

 

Once you have programmed these settings in your device, you will be able to access the internet and/or use MMS.

 

Hope this helps!



Flag this to a Moderator
Message 3 of 4
1,355 Views
Highlighted
Senior MVP Senior MVP
Senior MVP

Re: Internet Connectivity Problem with an HTC S A510b bought Overseas Australia


@AnnaD wrote:

Ive had my phone unblocked Phone & Text Works Fine but I cant connect to the Internet with Fido 3G Network as I used to Overseas using a different provider.

When I connect to a Wi-Fi Network it works.

I've gone through all the Features on my phone and I Can't seem to find how to connect to the internet using the Fido 3G Network although it is the one selected under Mobile Network / Network Operator / Search Network

Hopefully someone can help with this Problem ... I called Fido all they did for me was refer me to this Forum.

Thank you

AnnaD

 


Hello AnnaD,

 

  While this information might be a little late to be useful to you now, hopefully others with a similar situation might benefit from it.

 

  Unfortunately the Australian version of that phone uses WCDMA(UMTS) 2100MHz which is not compatible with Fido/Rogers' '3G' network frequencies (850 and 1900MHz). So that phone will not work on '3G' here. For a more complete list of the compatible frequencies, you can check here: http://www.fido.ca/web/content/phonewarranty/configure_unlocked_device_guide

 

Cheers


Flag this to a Moderator
Message 4 of 4
1,344 Views