Showing results for 
Search instead for 
Did you mean: 

Help, I can't get the LTE network on the smartwatch

I'm a participant level 2
I'm a participant level 2

Hi everyone, recently I bought the android smartwatch for my daughter, the watch works with 4g LTE internet and request Nano physical sim card

We already has a Fido 3gb data Plan and with Gpad tablet , but I think she better to have a smartwatch when she after school walk home or outside the house playing so we can easy to contact 


 I just received the smartwatch in this few days I tried so many times but I still can't get the LTE 4g network , if without the internet the watch for us is unusful , I just wondered here anyone who knows how to fix this issue ?  

Thanks for the reading hope can hear from  you soon ! 




Senior MVP Senior MVP
Senior MVP

Hello Icecold924,


  Welcome to the community!


  Is the watch you purchased 4G LTE only? If not, is the watch able to connect to the networks at all? What watch did you purchase? Have you verified whether the watch is compatible with the networks? You can verify the compatible bands/frequencies here.


  Are you able to access the network settings on the watch? You might verify whether the watch is using the proper APN. Since the device is LTE-capable, it should be using ltemobile.apn. You can verify those settings here.


  Are you using the same SIM as your 3Gb data plan? I'm not sure of the capabilities of your daughter's watch, but you should note that voice and messaging may not be available on a data-only plan.


Hope this helps 😀




I'm a participant level 2
I'm a participant level 2

Hi Cawtau , thanks for your kindly help, let me explain to you , I have a Fido LTE 3gb  plan only , it's  come with the tablet was 2 years ago Fido promotion, make a phone calls and texts is allowed but needs to pay extra fee.


Recently I on Amazon bought this running on 4g smartwatch , here is the link


For the APN, I already choose the ltemoilbe.apn there the info everything is correct but still can't get the network , so I tried to use available network to searching I can see Rogers 4g, bell 4g , Telus 4g even wind 4g show up except Fido network, I saw on the Amazon other customers who  using Rogers and say works fine, I tried many times restart the watch but it still doesn't detch the network Sad 



Hello again,


  Thank you for the additional information. Have you tried to connect to the Rogers 4G network? As mentioned above, Fido and Rogers share the same network.


  I haven't been able to find any additional information regarding those watches other than that which you have provided. As such, I cannot verify how many compatible bands/frequencies that device has. However, since it can detect those networks, it appears to have at least one compatible band/frequency. In addition, according to the available specifications, that watch does not appear to be able to connect to the 2G or '3G' networks. If true, your daughter won't be able to use the watch for voice calls or text messaging since it's unlikely the device will work with voLTE or Wifi-calling.


  That said, there does appear to be one review claiming the watch can be used for calls and text messages. However, I'm wondering if that review is for the 3G version of that phone.


Hope this helps 😀


Use Rogers it's the same network.