GSM problems with a COMAT relay

GSM problems with a COMAT relay

GSM problems with a COMAT relay

I'm a Contributor Level 1

GSM problems with a COMAT relay

I am having a reoccuring problem - a FIDO card put into a GSM modem for auto SMS sending gets blocked almost imediately - the device (COMAT relay) is good and has been tested.  Problem showed up a few months ago - after good service for almost a year plus.  Strangly enough the card strated working on it's own a few weeks later and then quit again a few weeks ago.  The log files on the modem indicate that texts are being accepteted on the network - but then dissapearing into the ether.  Tried lots of talk with techs - and even got a case file going - but they never got back to us with a solution.  Any thoughts?

 

 

***Edited to add labels***

13 REPLIES 13
Former Moderator

@Cawtau: Any ideas?

 



Former Moderator

Hey dougn! 

 

Welcome to the Community!

 

Would you be able to provide us more information about what a COMAT relay is/does?

 

Have you tested out a different SIM card in the device? Does the same thing happen?

 

Let us know!



I'm a Contributor Level 1

Hi !  Yes - I have tried with a new SIM card and the same happens - even when first registared on a phone first.

Have a second GSM modem replacement to troubleshoot and also had the same result. 

Hello Dougn,

 

  Welcome to the community!

 

  I'm not too familiar with COMAT relays. Is the device strictly GSM or is it also capable of UMTS/WCDMA? I'm not sure if this is related to your issue or not, but you should note that Rogers is only committing to support its 2G GSM network until 2018 (see here). They have already begun reducing their 2G capacity (see here). So if you are able to get the device to work properly, it may not work for very much longer.

 

Hope this helps Smiley

 

Cheers


I'm a Contributor Level 1

OK - I will check and get back with the status regarding the UMTS/WCDMA capacity.  

Now to be sure - if the 2g service has dropped in my area - would the result be a `blocking` of the SIM card?

(Which would result in no recieving of texts)?

 

Intersting enough here is a statement from the manufacturer (Europe):

 

"

Prepaid cards:

For trouble-free operation of the SMS relay in Switzerland we recommend the use of SIM cards from the providers Swisscom and Sunrise. In order to prevent the card from being deactivated when used rarely, we recommend the activation of the option «send periodic status message» when configuring the device. IMPORTANT:

It is not recommendable to use prepaid cards from Salt, as the deactivation criterion for this provider in the event of non-use is outgoing calls.

"

 

So what is the criteria on the Rogers network for deactivation?

 

Doug

I'm a Contributor Level 1

OK - so it is confirmed that the device is GSM only (up to 1900mhz Quad band). The device does registar that it is on the network.

 

Here is a short excerpt from the log files on the relay:

 

Fri Jul 07 13:09:18 UTC 2017 com.cinterion.io.ATCommandFailedException: error response: AT+COPS=?

+CME ERROR: 258 (atcommand failed exception) while reading operators
Fri Jul 07 13:09:18 UTC 2017 retries 1
Fri Jul 07 13:09:25 UTC 2017 com.cinterion.io.ATCommandFailedException: error response: AT+COPS=?

+CME ERROR: 258 (atcommand failed exception) while reading operators
Fri Jul 07 13:09:25 UTC 2017 retries 2
Fri Jul 07 13:09:32 UTC 2017 com.cinterion.io.ATCommandFailedException: error response: AT+COPS=?

+CME ERROR: 258 (atcommand failed exception) while reading operators
Fri Jul 07 13:09:32 UTC 2017 retries 3
Fri Jul 07 13:09:40 UTC 2017 com.cinterion.io.ATCommandFailedException: error response: AT+COPS=?

 

--

 

Fri Jul 07 13:32:07 UTC 2017 GSM state: 5, RSSI: -82 dBm, LAC: 2396 CI: C059
Fri Jul 07 13:32:07 UTC 2017 +CUSD not registered AtEvent, can not be removed
Fri Jul 07 13:32:07 UTC 2017 +CMT not registered AtEvent, can not be removed

 

 

Thoughts?

 

Doug

Hello again,

 

  While I cannot confirm the status of the 2G coverage in your area, I can provide the location of the celluar towers in your area.

Armstrong.jpg

Taken from here.

 

  Unfortunately, neither of Fido/Rogers' cellular towers are very close to Armstrong. The nature of mobile phones is that they are dependent on cellular signals reaching the phones. Many factors can affect those signals from reaching the phones-- including proximity to cellular towers and interference caused by obstructions between the cellular and the device (see here). That is why no mobile provider will be able guarantee their service.

 

  I understand the device does register on the network. However, does it specifically say it's connected to the Fido/Rogers network? There is a Telus celluar tower in Armstrong. If the device had connected to the Telus tower as Fido-EXT, that would be considered extended coverage. Unfortunately, pre-paid accounts do not have access to to extended coverage. That could explain why the device is giving error messages.

 

  Have you tried the SIM in a different device?

 

Hope this helps Smiley

 

Cheers


Hello again,

 


@Cawtau wrote:
...

  I understand the device does register on the network. However, does it specifically say it's connected to the Fido/Rogers network? There is a Telus celluar tower in Armstrong. If the device had connected to the Telus tower as Fido-EXT, that would be considered extended coverage. Unfortunately, pre-paid accounts do not have access to to extended coverage. That could explain why the device is giving error messages....


  I apologise, in trying to think of a possible reason for your issue, I temporarily failed to recall that the device was 2G GSM only. Telus does not have a GSM network so the device wouldn't have been able to connect to them at all.

 

  I understand the signal received by the device appears to be adequate at your location, however, have you tried the device in other locations?

 

  After some further research, it appears that the error your device is receiving is Phone is Busy (CME ERROR: 258; see here).

 

Hope this helps Smiley

 

Cheers


I'm a Contributor Level 1

OK - here is an update: 

 

Got a new FIDO SIM card today - and registared and inserted in my phone first.

 

Rogers/Fide network is available - phone hooked up.  

 

Data works.

 

However - no sending or receiving of messages.

 

Could this have been overthought?  Perhaps there is an issue with the actual phone number  getting blocked or not working?  Is that possible?

 

Doug

Hello again,

 


@dougn wrote:
...

Got a new FIDO SIM card today - and registared and inserted in my phone first.

 

Rogers/Fide network is available - phone hooked up.  

 

Data works.

 

However - no sending or receiving of messages.

...

  Have you verified that the Message Centre Number is correct? I should be 514-993-1123.

 

Hope this helps Smiley

 

Cheers


Hey dougn!

 

We'll need to take a look in your account to check that out so I'll be sending a PM your way shortly!



I'm a Contributor Level 1

Hmm - Put in phone, the card does indicate a rogers network is available.    Is there any way to see if 2g has been dropped in this area? Surely a network tech would know?

 

I'm a Contributor Level 1

And is there any way to confirm the status of 2G in my area?  Specificly it is in Armstrong BC.