Blackberry torch 9810 only connects to 2G network

Blackberry torch 9810 only connects to 2G network

Blackberry torch 9810 only connects to 2G network

SOLVED
I'm a Participant Level 2

Blackberry torch 9810 only connects to 2G network

As mentionned in the title, the phone only connects with 2G. After looking at pages of specs for the torch 9810, it has UMTS/HSPA 1900/850 MHz capabilities. According to this page: "http://www.fido.ca/consumer/content/configure-unlocked-device-guide" fido supports those frequencies. Am I missing something? This phone previously had a line with videotron and 3G was working fine. 

 

**Edited to add tags and labels**

Accepted Solution

Re: Blackberry torch 9810 only connects to 2G network

Solved by Senior MVP Senior MVP

Hello Justin001,

 

  Welcome to the community!

 

  Which version of the Torch 9810 do you have? According to Phone Scoop, there are at least 2 versions of the device with WCDMA:

 

A: 850MHz (B5), 1900MHz (B2), 2100MHz (B1) and B: 900MHz (B8), 1700/2100MHz (B4)

 

  If your phone previously worked on Videotron, they use 1700/2100MHz (see here). That is, the B version of the device.  If those specifications are correct, unfortunately, that version does not have the compatible bands/frequencies for Fido/Rogers '3G' networks.

 

Hope this helps Smiley

 

Cheers

 

View solution in context
3 REPLIES 3
Senior MVP

Hello Justin001,

 

  Welcome to the community!

 

  Which version of the Torch 9810 do you have? According to Phone Scoop, there are at least 2 versions of the device with WCDMA:

 

A: 850MHz (B5), 1900MHz (B2), 2100MHz (B1) and B: 900MHz (B8), 1700/2100MHz (B4)

 

  If your phone previously worked on Videotron, they use 1700/2100MHz (see here). That is, the B version of the device.  If those specifications are correct, unfortunately, that version does not have the compatible bands/frequencies for Fido/Rogers '3G' networks.

 

Hope this helps Smiley

 

Cheers

 


Former Moderator

Hey Justin001!

 

Welcome to the Community!

 

Is it possible that you have 2G only selected as your Network Mode under the phone's network settings?

 

Let us know!

 



I'm a Participant Level 2

In network services i have 

data: on

roaming: off

network selection mode: automatic

network mode: 3G & 2G

 

Ive messed a bot with these settings and the only 3G connection I seem to be able to get is SOS services.