Showing results for 
Search instead for 
Did you mean: 

BB Curve APN settings

I'm a participant level 1
I'm a participant level 1

alright, i have spoken to fido reps about this issue many times. they alwats refer me to RIM to fix this but i KNOW there is an answer they are not giving me.


i have a 3rd party application that has worked for 4 months on my Curve 8520 until today.


current apn setting:

username: <blank>

password:< blank>


my question....what would cause the application to stop working all of a sudden with this error:


"Couldn't fetch update availability: Network error: General socket error"


i have another phone on Rogers with the same 3rd party app and it has never had this error and never had a problem working.


who can help me here? very frustrating!!!





Former Moderator
Former Moderator
Hello simonopolis,

What is the application exactly? Is it only this application that is not working or are all of your data services not working?

Please let us know so that we can help you further.

I'm a participant level 1
I'm a participant level 1



I have the same issue. When I first began using my unlocked phone with fido I found that youtube streaming through the browser would produce an error message. I put in the the same apn settings as above and youtube streaming and all other applications would work perfectly. For a year now I haven't had any problems until the other night when the same error message comes up despite not changing the apn settings on my phone. Have the apn settings been changed on fido's end?

Hello Bolduser,

You can find all APN settings here:

I hope this helps!