Showing results for 
Search instead for 
Did you mean: 

Phone calls Not Working

I'm a participant level 2
I'm a participant level 2



I've been with Fido 2 years and for the last 2 years I've had sporadic issues with calls going straight to my voicemail without even ringing, or when I try to place a call, it just tries for 20 sec (without ringing) then just ends the call. 


This happens while the 4G works fine and it shows bars of phone network connections. 


I've gone to a couple Fido stores and they want to blame it on the fact my phone is a dual sim (I even removed the other sim just in case but no improvement) and also blame the fact my phone was bought in Europe (I'm European). 


Last week I switched plans from 10GB to 8GB (unsure if related), and now it seems no calls are coming through to me at all and I can't make any calls either. Not even my voicemail (who has a number in Alberta apparenty?). 


I've tried a fix found on another topic here with an APN custom update, but it didn't help at all and completely cut off network. I've reset it so it's back to normal APN and able to access Data but still no calls. SMS seem to come through though. 


Please help. My phone is a Honour 8X (Huawei's sub brand).  


Senior MVP Senior MVP
Senior MVP

Hello DD222,


  Welcome to the community!


  Sorry to hear you're having call issues with your phone. I understand you phone was purchased in Europe. Which version of the phone do you have? Have you verified it has compatible bands/frequencies with the networks? You can view the compatible bands/frequencies here.


  Judging by the specifications found here and here, that phone appears to only have a few compatible bands/frequencies. I understand that it might have some compatible LTE or 4G bands/frequencies. However, since the phone was not purchased from Fido, it's possible it is not supported for voice-over-LTE (voLTE). That is, it might not be supported for voice calls over 4G networks. If that is the case, then voice calls would fall-back on to the 2G or '3G' networks. From the specification listings, at least one version might not have any compatible '3G' or UMTS bands/frequencies. While another version does appear to have a compatible '3G' band/frequency, you should note that coverage would depend on your location relative to the cellular towers. You can get an idea of your cellular towers here


  I understand that you might have been able to sporatically use the phone for calls. It's possible that the phone was connecting to the 2G network for those calls. You should note that Rogers has been in the process of decommissioning the GSM or 2G network (see here). While there have been some delays to that timeline, I would expect the full decommission to happen in the near future.


Hope this helps 😀



I'm a participant level 2
I'm a participant level 2



I've checked further into my phone and it seems indeed that it's only the VoLTE that causes issues since the phone doesn't have it and it's the first I hear about it. 


Shame though as I wasn't planning on a new phone but it seems I don't have much of a choice in the matter.


Thanks for the help!